Unable to locate printer - Brother MFC L8900CDW

Hello.

First of all - big thank you to all contributors for a great distro!
It works very well for me as I'm attempting to switch to Garuda for daily driver for most of the activities including work.

i have encountered an issue with printer installation though:
My printer is visible in discovered network printers and by playing with cups i was able to get this printer added (initially, i was finishing add printer wizard, but printer was not appearing. I'm not sure if it is cups related or just the installation of a latest driver from AUR helped to get the printer added.)
But now the printer is there, but i cannot print as it is reporting an error "Unable to locate printer", so i cannot print a test page.

I would appreciate any advice.
printer model in question: brother MFC L8900CDW

╰─λ garuda-inxi  
System:
Kernel: 5.17.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=cfa490e8-fc51-4b99-b39e-9e21021d7ed1 rw root[email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: ROG CROSSHAIR VIII FORMULA v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 0702
date: 07/04/2019
CPU:
Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701013
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3657 high: 4141 min/max: 2200/4761 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3426 2: 3644
3: 3722 4: 3516 5: 3840 6: 3509 7: 3539 8: 3133 9: 3419 10: 4006 11: 3608
12: 3575 13: 3437 14: 3845 15: 3982 16: 3941 17: 3561 18: 4141 19: 3666
20: 3890 21: 3515 22: 3593 23: 3591 24: 3766 25: 3401 26: 3723 27: 3962
28: 3399 29: 3511 30: 4031 31: 3761 32: 3402 bogomips: 223568
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Micro-Star MSI driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: DP-2,DP-3 empty: DP-1,HDMI-A-1 bus-ID: 0e:00.0
chip-ID: 1002:731f class-ID: 0300
Device-2: Afatech NarviCapture U3 HD60 4K Device type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1:2 chip-ID: 1b80:e104
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x2880 s-dpi: 96 s-size: 1354x762mm (53.31x30.00")
s-diag: 1554mm (61.17")
Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,bottom-l
model: Samsung C49RG9x serial: <filter> built: 2018 res: 5120x1440 hz: 120
dpi: 109 gamma: 1.2 size: 1190x340mm (46.85x13.39") diag: 1239mm (48.8")
modes: max: 5120x1440 min: 720x400
Monitor-2: DP-3 mapped: DisplayPort-2 pos: top-right
model: LG (GoldStar) ULTRAWIDE serial: <filter> built: 2015 res: 3440x1440
hz: 60 dpi: 109 gamma: 1.2 size: 800x335mm (31.5x13.19")
diag: 867mm (34.1") modes: max: 3440x1440 min: 640x480
OpenGL: renderer: AMD Radeon RX 5700 XT (navi10 LLVM 13.0.1 DRM 3.44
5.17.1-zen1-1-zen)
v: 4.6 Mesa 22.0.0 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0e:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 10:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Afatech NarviCapture U3 HD60 4K Device type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1:2 chip-ID: 1b80:e104
class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.17.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: yes
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: Aquantia AQC111 NBase-T/IEEE 802.3bz Ethernet [AQtion]
vendor: ASUSTeK driver: atlantic v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 1 link-max: lanes: 4 port: N/A bus-ID: 06:00.0 chip-ID: 1d6a:11b1
class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 08:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-6:4 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 4.58 TiB used: 1.62 TiB (35.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7
temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 4TB
size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
ID-3: /dev/sdf maj-min: 8:80 type: USB vendor: Generic
model: STORAGE DEVICE size: 31.25 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 9744 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 15.79 GiB (16.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 500.7 MiB size: 499.7 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
ID-3: /home raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 15.79 GiB (16.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 15.79 GiB (16.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 97.17 GiB size: 97.17 GiB (100.00%)
used: 15.79 GiB (16.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.78 GiB used: 2.1 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 46.0 C mobo: 38.0 C gpu: amdgpu temp: 65.0 C
mem: 64.0 C
Fan Speeds (RPM): cpu: 999 gpu: amdgpu fan: 0
Info:
Processes: 611 Uptime: 3h 10m wakeups: 9 Memory: 62.78 GiB
used: 11.52 GiB (18.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1478 lib: 360 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.14
Garuda (2.5.6-2):
System install date:     2022-03-17
Last full system update: 2022-03-30 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Welcome :slight_smile:


Why you post,

same like inxi -Faz, if we want your garuda-inxi?

Did you search in forum about your problem, internet, manuals, arch wiki?

If anyone would like to help, the name of the printer might also be helpful.

Hi,

sorry for omissions! I saw other topics where people were providing this inxi command and thought that would be the one;) fixing now.
the printer model is Brother MFC L8900CDW
And yes i was trying to solve it by myself but wasn't able to find relevant info - the ones i saw helped me to install better driver, but no one seem to have experienced a combo where printer is visible in the network during the setup wizard, but then cannot be located to actually print a page.
I apologize if my research wasn't thorough enough.

Is this the driver you installed?

aur/brother-mfc-l8900cdw 2:1.5.0-2 [+2 ~0.23]
LPR and CUPS driver for the Brother MFC-L8900CDW

It looks like the exact right driver. Did you install through paru? Or something else?

What did you have to do with CUPS?

My printer works on Garuda without me doing anything, but to get the same printer working on a different distro I looked up the IP address of the printer and added the printer by IP.

My printer has a small display panel with a couple lines of text and it revealed the IP address in a settings menu somewhere, but I ended up going in to the admin portal of my home router to assign the printer a static IP address in the DHCP options (so it wouldn't get a different IP address every time I powered it on). This made finding the printer automatic.

4 Likes

find out the ip address of your printer, add as an ipp connection, then it;ll be fine (with the driver you already installed).

HI,

thank you for your replies!

  1. yes i have installed the brother-mfc-l8900cdw driver from aur. I did it using yay. After i installed this driver i was actually able to see the printer after i finished the wizard. before that using the "driverless" driver the printer was not showing up in printers in system settings after wizard completion. Unfortunately the forum doesn't allow me to upload screenshots - it would be much easier to explain.

Just to reiterate: I can see the printer in Add new printer dialog - it is finding it in the list of Network discovered printers. I was able to locate new driver in the list on the next step and eventually my printer was added and it is now present in the printers section of the settings.

When i tried to print a page it was reporting the error that the system is unable to locate the printer.
Surprisingly enough the scanlite utility was able to work with the printer. More over the behavior have changed after sleep/restart.
Now i have the printer added and it reports status as idle. But it is failing to print test page or any page for that matter - except for the self test page from maintenance drop down.
When i look at the list of completed jobs in printer print queue window i see that only the self test page is counted as one page printed. every other attempt i made is reported as 0 pages.

That's curious that you got the scanner working. Have you tried deleting the printer and adding it again?

It might be worth power cycling the printer as well.

Hello,

Pulled the plug on the printer and re-added it again. Same thing. The job of printing a test page is reporting being completed but shows 0 pages

Do you have the rest of the printer packages installed (from Garuda Assistant)?

in garuda assistant all items under printing and scanning are checked

It looks like there is a bit of song and dance involved with getting the printer itself properly set up to accept jobs over a wireless network. You have to change a bunch of settings depending on if you want to set it up through your router or your PC.

Here's the instruction page for directly connecting it:

Here is the same for going through your router:

There are videos and stuff, it does not appear to be a plug-and-play device by any stretch. Have you attempted any of this setup yet?

3 Likes

Hi @BluishHumility

Thank you for those references. No i didn't try that type of song and dance yet. The printer worked flawlessly being setup through windows, no questions asked (on the same machine where i have garuda in dual boot mode). I was able to add it to all of the devices - mac and windows and android and able to print from those.
So, in general it was plug-n-play quite alright;)

HI,

i tried to look at the options above in the video, but both are not applicable much as there is no software package that provides the setup interface for linux.

The problem i'm experiencing doesn't seem to be in network connection, because I can see the printer, i can scan using scanlite, i can send self-test page print command (sifferent from test page) . but it just doesn't print and i think the fact that it is reporting 0 pages every time in completed jobs is relevant.

Can you print a test page from the printer itself (without using the computer)?

yep, and i'm also able to print a doc from google drive through my phone

Try to print something from your computer (the same way you have been doing), and afterward paste the output of:

cat /var/log/cups/error_log

This is hardly a fair comparison, because most printer/driver setup utilities are only released with full support for Windows and Apple products. Most hardware sold off the shelf does not have full manufacturer support for Linux, (if at all).

Trying to even get wireless working in Linux is often an uphill battle, let alone wireless printing in Linux. This limitation is at the manufacturers end, as in most cases they don't provide the full featured setup utilities for their products in Linux that they do for the big commercial OS's.

Sometimes that's just the bitter pill you need to swallow if you intend to use Linux. The other option would be to set Windows up in a VM and do your network printing from Windows. Windows often creates hardware issues when dual booting with Linux, so this may be a decent compromise solution (if you are unable to get your printer working wirelessly in Linux).

In the end you either pay up front for the convenience factor with Windows & Apple, or you pay on the back end with having to do a lot of research to get some hardware working correctly in Linux.

Good luck.

3 Likes

like i said way up this thread - set it up with an ipp connection. seriously, it'll work (had the same a few times over the years to the point i don't setup a local printer connection via wi-fi any other way these days....)

1 Like

I have tried to print out from borwser and this is the only entry for today's date in /var/log/cups/error_log.1

E [04/Apr/2022:14:56:25 -0400] [Client 77] Returning IPP client-error-bad-request for Create-Printer-Subscript
ions (/) from localhost.

Hi,

I have two options in the drop down to select from when i try to add this printer: IPP network printer via DNS-SD and LPD/LPR Queue. Here is my connection string from printer properties:

dnssd://Brother%20MFC-L8900CDW%20series._ipp._tcp.local/?uuid=********

Is this IPP connection that you are referring to?