Unable to install python-lief package

Hello Garuda users.

i unable to build package "python-lief" please help me also i unable to install it from pacman

─alex@alex in ~ as 🧙 took 50ms
╰─λ garuda-inxi
System:
Kernel: 6.4.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c2a1ce2d-f45a-46a8-8f05-8cd48a950b58 rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 psi=1
ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: A320M-S2H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F53 date: 01/05/2021
CPU:
Info: model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen level: v3 note: check built: 2017-19 process: GF 14nm
family: 0x17 (23) model-id: 0x11 (17) stepping: 0 microcode: 0x8101016
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 2644 high: 3569 min/max: 1600/3500 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3008 2: 2155
3: 3569 4: 1845 bogomips: 27947
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 07:00.0
chip-ID: 1002:15dd class-ID: 0300 temp: 49.0 C
Display: wayland server: X.org v: 1.21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.1.4 renderer: AMD Radeon Vega 8 Graphics
(raven LLVM 15.0.7 DRM 3.52 6.4.7-zen1-1-zen) direct-render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 07:00.1
chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.4.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.76 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8168 v: 8.051.02-NAPI modules: r8169 pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: enp7s0f3u4 state: unknown speed: -1 duplex: half mac: <filter>
IF-ID-2: vetht5tkho state: up speed: 10000 Mbps duplex: full mac: <filter>
IF-ID-3: virbr1 state: down mac: <filter>
IF-ID-4: waydroid0 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
Bluetooth:
Device-1: OPPO RMX2027 driver: rndis_host v: kernel type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:5 chip-ID: 22d9:2766
class-ID: 0a00 serial: <filter>
Report: bt-service: disabled note: tool can't run
Drives:
Local Storage: total: 585 GiB used: 255.6 GiB (43.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SSD 128GB size: 119.24 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
fw-rev: XKR scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT3500SC 6
CTB5029G21Y034 size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: A52B
scheme: GPT
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.07 GiB (46.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.07 GiB (46.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.07 GiB (46.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.07 GiB (46.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.59 GiB used: 897.5 MiB (6.4%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 59.5 C mobo: N/A gpu: amdgpu temp: 59.0 C
Fan Speeds (RPM): N/A

here is the logs

:: marked out of date: python-lief

Btw, post full garuda-inxi :slight_smile: , please.

System:
Kernel: 6.4.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c2a1ce2d-f45a-46a8-8f05-8cd48a950b58 rw rootflags=subvol=@
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 psi=1
ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_wayland dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: A320M-S2H v: N/A serial: N/A
Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: N/A
UEFI: American Megatrends v: F53 date: 01/05/2021
CPU:
Info: model: AMD Ryzen 3 2200G with Radeon Vega Graphics socket: AM4
bits: 64 type: MCP arch: Zen level: v3 note: check built: 2017-19
process: GF 14nm family: 0x17 (23) model-id: 0x11 (17) stepping: 0
microcode: 0x8101016
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 1775 high: 2300 min/max: 1600/3500 boost: enabled
base/boost: 3500/3700 scaling: driver: acpi-cpufreq governor: schedutil
volts: 1.4 V ext-clock: 100 MHz cores: 1: 1600 2: 1600 3: 1600 4: 2300
bogomips: 27947
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 07:00.0
chip-ID: 1002:15dd class-ID: 0300 temp: 49.0 C
Display: server: X.Org v: 23.1.2 with: Xwayland v: 23.1.2
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :1 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
s-diag: 583mm (22.95")
Monitor-1: HDMI-A-1 model: 24HC1QR serial: <filter> built: 2020
res: 1920x1080 hz: 120 dpi: 94 gamma: 1.2 size: 520x300mm (20.47x11.81")
diag: 600mm (23.6") ratio: 16:9, 15:9 modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.4 renderer: AMD Radeon Vega 8 Graphics
(raven LLVM 15.0.7 DRM 3.52 6.4.7-zen1-1-zen) direct-render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 07:00.1
chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.4.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.76 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8168 v: 8.051.02-NAPI modules: r8169 pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 06:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: enp7s0f3u4 state: unknown speed: -1 duplex: half mac: <filter>
IF-ID-2: vetht5tkho state: up speed: 10000 Mbps duplex: full mac: <filter>
IF-ID-3: virbr1 state: down mac: <filter>
IF-ID-4: waydroid0 state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
Bluetooth:
Device-1: OPPO RMX2027 driver: rndis_host v: kernel type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:5 chip-ID: 22d9:2766
class-ID: 0a00 serial: <filter>
Report: bt-service: disabled note: tool can't run
Drives:
Local Storage: total: 585 GiB used: 255.6 GiB (43.7%)
ID-1: /dev/sda maj-min: 8:0 model: SSD 128GB size: 119.24 GiB block-size:
physical: 512 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s tech: SSD
serial: <filter> fw-rev: XKR temp: 40 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 172d 3h cycles: 1867
read: 5 MiB written: 5.5 MiB
ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT3500SC 6
CTB5029G21Y034 size: 465.76 GiB block-size: physical: 512 B logical: 512 B
sata: 2.6 speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: A52B temp: 41 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 183d 4h cycles: 2742
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.06 GiB (46.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.06 GiB (46.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.06 GiB (46.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 55.06 GiB (46.3%) fs: btrfs block-size: 4096 B dev: /dev/sda2
maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.59 GiB used: 1.19 GiB (8.7%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 48.4 C mobo: N/A gpu: amdgpu temp: 48.0 C
Fan Speeds (RPM): N/A

thats all i got

So, the package is out of date, and we don't know if your system is rebooted or partially upgraded.

  Fan Speeds (RPM): N/A
Info:
  Processes: 304 Uptime: 1h 43m wakeups: 13617 Memory: total: 16 GiB
  note: est. available: 15.21 GiB used: 7.57 GiB (49.7%) Init: systemd v: 253 
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: pm: dpkg pkgs: 0 pm: pacman pkgs: 1747 libs: 412
  tools: octopi,pamac,paru Shell: fish v: 3.6.1 running-in: kitty inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2021-11-30
  Last full system update: 2023-07-29
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            
2 Likes

As SGS already indicated the lief package on AUR is out of date why don't you use pip to install lief instead?

pip install lief

should work. Remember Never give pip root privileges while doing anything.

3 Likes

because someone says that pip install commands are horrable idea on arch

also this is not working
saying this

╭─alex@alex in ~ took 4s
[🔍] × python-pip install lief
python: can't open file '/home/alex/pip': [Errno 2] No such file or directory

╭─alex@alex in ~ took 27ms
[🔴] × pip install lief
find-the-command: "pip" is not found locally, searching in repositories...
find-the-command: /var/cache/pkgfile/*.files are out of date, update? [Y/n] n
find-the-command: "pip" may be found in the following packages:
extra/python-pip
chaotic-aur/anaconda
chaotic-aur/azure-cli
chaotic-aur/google-cloud-cli
chaotic-aur/natron-bin
chaotic-aur/whoogle
chaotic-aur/whoogle-git

It literally told you pip is not in your system and that you need to download it. Please read the error messages you send. I get that it might be a horrible idea because python dependencies pulled via pip are not going to be auto updated with pacman and using pip to update your python packages is not very convenient either. But there are times when we have no other option available to use like this one. If not pip what other method do we have to pull this package.

sudo pacman -S python-pip
pip install lief
2 Likes
× This environment is externally managed
╰─> To install Python packages system-wide, try 'pacman -S
python-xyz', where xyz is the package you are trying to
install.

If you wish to install a non-Arch-packaged Python package,
create a virtual environment using 'python -m venv path/to/venv'.
Then use path/to/venv/bin/python and path/to/venv/bin/pip.

If you wish to install a non-Arch packaged Python application,
it may be easiest to use 'pipx install xyz', which will manage a
virtual environment for you. Make sure you have python-pipx
installed via pacman.

note: If you believe this is a mistake, please contact your Python installation or OS distribution provider. Y
ou can override this, at the risk of breaking your Python installation or OS, by passing --break-system-packag
es.
hint: See PEP 668 for the detailed specification.

here the error

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.