Unable to install notepadqq on live image dr460nized

Downloading and booting garuda-dr460nized-linux-zen-220822.iso inside Virtualbox. I know it's not supported as graphical issues, but need to test some things.

This is the error I get trying to install some software:

$ garuda-inxi 
System:
Kernel: 5.19.2-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
misobasedir=garuda misolabel=GARUDA_DR460NIZED_TALON quiet
systemd.show_status=1 driver=free nouveau.modeset=1 i915.modeset=1
radeon.modeset=1
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Virtualbox System: innotek GmbH product: VirtualBox v: 1.2
serial: <superuser required> Chassis: Oracle Corporation type: 1
serial: <superuser required>
Mobo: Oracle model: VirtualBox v: 1.2 serial: <superuser required>
BIOS: innotek GmbH v: VirtualBox date: 12/01/2006
Battery:
ID-1: BAT0 charge: 47.5 Wh (95.0%) condition: 50.0/50.0 Wh (100.0%)
volts: 10.0 min: 10.0 model: innotek 1 type: Unknown serial: N/A
status: not charging
CPU:
Info: model: Intel Core i7-6700HQ bits: 64 arch: Skylake-S gen: core 6
built: 2015 process: Intel 14nm family: 6 model-id: 0x5E (94) stepping: 3
microcode: N/A
Topology: cpus: 1x cores: 1 smt: <unsupported> cache: L1: 64 KiB
desc: d-1x32 KiB; i-1x32 KiB L2: 256 KiB desc: 1x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): 2592 min/max: N/A core: 1: 2592 bogomips: 5183
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT Host state unknown
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT Host state
unknown
Type: retbleed status: Vulnerable
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds status: Unknown: Dependent on hypervisor status
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.20.0.0 ports:
active: Virtual-1 empty: Virtual-2, Virtual-3, Virtual-4, Virtual-5,
Virtual-6, Virtual-7, Virtual-8 bus-ID: 00:02.0 chip-ID: 15ad:0405
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: vmware unloaded: modesetting
alternate: fbdev,vesa gpu: vmwgfx display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: Virtual-1 mapped: Virtual1 res: 1920x1080 hz: 60 size: N/A
modes: max: 1920x1080 min: 640x480
OpenGL: renderer: llvmpipe (LLVM 14.0.6 256 bits) v: 4.5 Mesa 22.1.6
direct render: Yes
Audio:
Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0
v: kernel bus-ID: 00:05.0 chip-ID: 8086:2415 class-ID: 0401
Sound Server-1: ALSA v: k5.19.2-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: kernel port: d020
bus-ID: 00:03.0 chip-ID: 8086:100e class-ID: 0200
IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
driver: piix4_smbus v: N/A modules: i2c_piix4 port: N/A bus-ID: 00:07.0
chip-ID: 8086:7113 class-ID: 0680
Drives:
Local Storage: total: 8 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: VirtualBox model: VBOX HARDDISK
size: 8 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: 1.0
Partition:
Message: No partition data found.
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.83 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
Message: No sensor data found. Is lm-sensors configured?
Info:
Processes: 128 Uptime: 11m wakeups: 280 Memory: 3.83 GiB used: 1.4 GiB
(36.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1166 lib: 292 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-08-25
Last full system update: 2022-08-25 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            garuda-live-keyring.service snapper-cleanup.service
McFly: Importing shell history for the first time. This may take a minute or two...done.

Then install the software:

# pacman -Sy notepadqq
:: Synchronizing package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
resolving dependencies...
looking for conflicting packages...
 
Packages (2) qt5-webkit-5.212.0alpha4-15  notepadqq-1.4.8-6
 
Total Installed Size:  52.68 MiB
 
:: Proceed with installation? [Y/n] Y
(2/2) checking keys in keyring                                     [------------------------------------] 100%
downloading required keys...
:: Import PGP key 7A4E76095D8A52E4, "Antonio Rojas <[email protected]>"? [Y/n] Y
error: key "Antonio Rojas <[email protected]>" could not be imported
:: Import PGP key F99FFE0FEAE999BD, "Allan McRae <[email protected]>"? [Y/n] Y
error: key "Allan McRae <[email protected]>" could not be imported
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

Have you tried refreshing the keyrings from within Garuda assistant first?

Edit: Type update remote keyring then update and you should be all good

3 Likes

You're doing a partial upgrade, and this will cause issues.

You need to update all packages - usually garuda-update is the way forwards here.

But, keep in mind that installing things in the live environment can create other issues, e.g. out-of-memory conditions. If you want to test you're better off installing into the VM.

4 Likes

No need to install any update.
Just do as root update remote keyring and when says :: Proceed with installation? [Y/n] answer n, then do as root pacman -Sy notepadqq and do proceed. Will install only notepadqq and qt5-webkit

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.