Unable to install from live USB - failed to create partition

Just trying to work out where the failure is here. I am trying to install Garuda on to an external HDD by booting my machine from the downloaded Garuda ISO which I Etcher'ed on to a USB and booted from. I have tried starting with a blank HDD and using the installer to wipe and create partitions it needs but this fails. I have tried manually creating the partitions within the installer and this fails. I have tried creating the partitions in the KDE Partition manager and this works fine but I am unsure how to make Garuda use these partitions during the install.

The error I always receive is :
Create a new partition (465.46 GiB, btrfs) on ‘/dev/sde’
Job: Create new partition on device ‘/dev/sde’

I cannot find any logs or more details on the issue. When I view the drive after a failure - it seems to have successfully created the partitions.

Hi there, welcome!

Maybe you could try using the "Replace a partition" option in the Partitions step of the installer.

1 Like

Recently a Calamares bug was giving someone a similar issue. I'm not sure if this is the same thing or not, but they got through it by deselecting a couple boxes in the installer. Installation failed on an NVME - #7 by vedranmiletic


Thanks Filo - Am just trying that now as the partitions now exist after the failed install attempt

1 Like

Thanks for the help. Ended up using the partitions created during the install and setting the mount points, flags etc to match what Garuda said it was going to do during a Full Wipe install. All has worked fine :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.