Unable to install any apps

I installed garuda linux today, but im unable to install firefox, brave, chrome . I am completely new in Linux, its my first time. Plz help me guys

and i want to install other apps also

I have installed garuda on SSD and want to format my HDD, where to do that?


How are you unable? (Installing from Add/Remove Software?)

yay -Syu firefox brave google-chrome

Create partitions with the partition manager. Install using Advanced option while installing and select a partition from them.

Do you mean formalt? If so, partition manager helps you.


How to update system??
which command do i have to put on terminal?

Please edit your thread title as begging for help is frowned upon on the Garuda forum. You have created a thread in the "Issues & Assistance" sub-forum, it is already understood that you are asking for help. Posting "please help" in your thread title is not only redundant, but has the stench of begging for help. It is also demeaning to other users and their help requests, as it insinuates your issue is more important than other users who are patiently waiting for help.

Please edit your thread title to accurately reflect your issue at hand.


Garuda Assistant > System update


update or upd in terminal

Added to whag @ tbg said, for others searching for the same issue or something similar, it would be helpful to get into right thread.


after installing garuda unable to install any apps and terminal commands are also not working, i dont know where im making mistakes.
Could you help me with this?

chaotic-aur is up to date
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: failed to synchronize all databases (unexpected error)

╭─[email protected] in ~ took 27s
[:red_circle:] ×

This thing is coming

What apps? What was the error message?

Which terminal commands? Again, what was the exact error message?

We can't help with no information given on what error message occurs.


See above prior posts^^^


It is showing this

I don't know about this error, but I think Refresh Keyring and Refresh Mirrorlist in Garuda Assistant may help.

Is update command also giving the same error? (which should not, actually)

yes, same error

Please try avoiding screenshots, you can copy & paste (which is even easier) with "~~~" above and below.

echo "looks cool, isn't it?"
sudo rm /var/lib/pacman/sync/*

Then proceed with refreshing keyrings via Garuda Assistant.

And please don't post pictures, we don't like pictures here as they are hard to read. :slight_smile:


thanks, it worked

I dont understand you just installed your first linux and you want to dual boot.

no, only Garuda

My dear Linux is an idea and distro's projects on that idea(This is super vague but probably easy for him to understand)
So you cant install "Linux" you have to install one of the "Distributions" based on Linux and you already have garuda installed why need something else when you already have the best?