Unable to find a matching version for "aspell"

Saturday I went to update using Topgrade and I received the below in regards to aspell. yesterday I removed aspell and replaced it with hunspell and figured that would be the end of it, but today I check updates and I still get the below. I thought I would uninstall Micro figuring it was a install helper only to be greeting with it wanting to remove garuda-assistant. I backed out of removing Micro. I've doubled check the Pamac GUI and according to it Aspell is not installed. Any idea on how to rectify this? Thanks

―― 09:54:48 - micro ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――
Checking for plugin updates
unable to find a matching version for "aspell"

Retry? (y)es/(N)o/(s)hell

―― 09:54:53 - micro ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――
Checking for plugin updates
unable to find a matching version for "aspell"

Retry? (y)es/(N)o/(s)hell

―― 09:54:55 - micro ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――
Checking for plugin updates
unable to find a matching version for "aspell"

Retry? (y)es/(N)o/(s)hell

―― 09:54:57 - Flatpak User Packages ――――――――――――――――――――――――――――――――――――――――――――
Looking for updates…
Nothing to do.

Garuda Gaming completely updated with the above exception.

Is there a reason you don't want/can't have aspell and hunspell both installed?

1 Like

This "update all the things!" script isn't part of Garuda, so you'd have to treat it cautiously.

For example, what is it trying to update for micro?

1 Like

As I stated I only removed Aspell in an effort to stop getting the error message from Micro. I have no issue in having both Aspell and Hunspell installed at the same time.

The issue is that even though Aspell is currently uninstalled I'm still getting that error message from Micro, and when I try go to uninstall Micro so I can stop getting that message it also wants to uninstall Garuda-Assistant. Looks like for whatever reason Garuda-Assistant is dependent on Micro.

@jonathon All Topgrade does is make the various calls to the actual updaters and run them so one doesn't have to run each individually. As stated in my original post and in this post I can't remove Micro without removing Garuda-Assistant.

1 Like

I caught the same error messages as you did, using Topgrade. And I've used Topgrade since it arrived in the AUR. I take it as a mismatch of package updates, and the messages as spurious. The update check still completes when using the "No" option.

I suppose a person could downgrade Topgrade (snicker) and see if it disappears. I'm not too excited either way, not at this point.

regards

It fails to see micro. I haven't looked at the PKGBUILD (yet) of Topgrade but it may be something as simple as a versioning mismatch. It's no biggie right now. I may look for bug reports...there's nothing on the AUR page at this point.

It's not a Topgrade issue. It's a Garuda / Micro issue. Why else would Garuda-Assistant be tied to it? According to Pamac Micro is a text editor so not even sure why it's wanting to look for Aspell versions. I'd just as soon uninstall Micro and Aspell since besides Hunspell there are plenty of other spell checkers out there.

1 Like

Yeahhhh...Micro is kinda tied into Garuda...I haven't really looked at the .skels or the depends...maybe after my nap. :slight_smile:

1 Like

@dr460nf1r3 I noticed you mention micro in your thread for the new ISO's I uninstalled it to get rid of the message about aspell. In the new ISO am I really going to need it?

And which "updater" is checking for updates for micro plugins?

Work out what Topgrade is trying to do with plugins for micro first.

How about you check what the underlying issue is before asking Garuda maintainers to alter Garuda to fix a problem you are having that's caused by your using a piece of software that's not included by default?

1 Like

First How about letting me know why micro is tied to garuda-assistant and grauda-assistant gets uninstalled if I uninstall micro like I've asked several times since micro is suppose to be a terminal text editor. Second I did not ask for any changes to be made by the Garuda devs to the ISO, I clearly said I removed micro to stop the issue for now, once the issue is resolved I'll restore it so I can add garuda-assistant back. Third I have a active issue open on the developers github for micro which means I am actively looking at other sources as the possible cause of the issue, just not at topgrade since I'm sure it's not the problem.

I seem to have missed this one, could you please link it here? :eyes:

As for the aspell issue - this is a plugin for micro shipped in garuda-common-settings:

Its still available on the Micro plugin page as you can see here: Micro - Plugins

You can try to update it manually using micros inbuild updater - if that succeeds topgrade would be to blame I guess.

3 Likes

My bad actually I had added to a closed ticket and received a couple of replies there. Since I don't use micro much less knew it was even installed is there away way I can remove it without losing garuda-assistant? That's all I really want. Thanks for the reply.

You can force the removal with pacman -Rdd micro although you must not complain about any potential issues then. Also it will get reinstalled once Garuda Assistant gets an update.

I'll have a look at the code to see if Micro is really required, I cant recall what exactly its used for right now.

You could as well just remove the plugins if the notifications triggers you that much for a less trouble btw :eyes:

2 Likes

As stated above aspell has been removed but that message still came up attempting updates with topgrade, so for some reason micro when installed and aspell isn't still thinks aspell is still installed. So the only option I was left with for now was to allow the system to remove garuda-assistant along with micro. As for issues with micro removed I'm not seeing anything other than of course garuda-assistant being removed.

Edit:
No, the problem is not with micro or the Garuda assistant,
so you should solve your problem with the help of the problem creator.

I chose @dr460nf1r3 post earlier as the solution.

It doesn't help to remove this tag and keep harping on the issue.
We would just keep going in circles.

That's why I'm closing here.

2 Likes

Micro is indeed not needed for Garuda Assistant anymore - it was used for editing mirrors before we introduced Pace as GUI solution for this. I hope the just pushed update restores your sanity @bonesaw :crazy_face:

3 Likes