Unable to create window management shortcuts on Garuda LXQt Kwin

Hello everyone. I recently installed Garuda LXQt Kwin and found that there are no keyboard shortcuts set for closing, minimizing and maximizing windows or moving windows around workspaces, per the Shortcut Keys app that I can find in the menu. When I create one, I can set the keystroke combination but I cannot select the action (close window, maximize window, etc), because I don't know what the command for that would be, and I couldn't find a list of commands for LXQt/Kwin I can use for the keyboard shortcuts.

Can an experienced user provide me with a list of commands or an insight on where should I look for them? Or maybe the app I am talking about is not the one I should be using? Thank you

By the way, I just found out Alt+F4 (not the shortcut I would like) closes the window but is not listed in the Shortcut Keys app, so I guess there must be another configurator around there but I am unable to find it.

System:
  Kernel: 5.16.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/vmlinuz-linux-zen
    root=UUID=c25e5f86-6783-4d6e-b5a0-7d4e06c7f3a8 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: LXQt 1.0.0 tk: Qt 5.15.3 info: cairo-dock, lxqt-panel
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: BANGHO product: MAX L4 v: MAX L4
    serial: <superuser required> Chassis: type: 10 v: N/
    serial: <superuser required>
  Mobo: BANGHO model: MAX L4 serial: <superuser required> UEFI: INSYDE
    v: 1.07.07RPA2 date: 11/27/2020
Battery:
  ID-1: BAT0 charge: 34.0 Wh (87.9%) condition: 38.7/36.2 Wh (107.0%)
    volts: 12.1 min: 11.4 model: Notebook BAT type: Li-ion serial: <filter>
    status: Discharging
CPU:
  Info: model: Intel Celeron N4020 bits: 64 type: MCP arch: Goldmont Plus
    family: 6 model-id: 0x7A (122) stepping: 8 microcode: 0x1C
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1515 high: 1523 min/max: 800/2800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1508 2: 1523
    bogomips: 4377
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel GeminiLake [UHD Graphics 600] vendor: CLEVO/KAPOK
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0300
  Device-2: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 1-7:5
    chip-ID: 5986:9102 class-ID: 0e02
  Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP1 mapped: eDP-1 model: Chi Mei Innolux built: 2016
    res: 1366x768 hz: 60 dpi: 112 gamma: 1.2 size: 310x170mm (12.2x6.7")
    diag: 354mm (13.9") ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 00:0e.0
    chip-ID: 8086:3198 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.13-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: AzureWave driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 02:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-3:2 chip-ID: 13d3:3533 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
Drives:
  Local Storage: total: 111.79 GiB used: 8.3 GiB (7.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400M8120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 62B3 scheme: MBR
Partition:
  ID-1: / raw-size: 39.06 GiB size: 39.06 GiB (100.00%)
    used: 8.17 GiB (20.9%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
  ID-2: /boot raw-size: 256 MiB size: 252 MiB (98.46%)
    used: 135.3 MiB (53.7%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%)
    used: 296 KiB (0.0%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-4: /home raw-size: 39.06 GiB size: 39.06 GiB (100.00%)
    used: 8.17 GiB (20.9%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
  ID-5: /var/log raw-size: 39.06 GiB size: 39.06 GiB (100.00%)
    used: 8.17 GiB (20.9%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
  ID-6: /var/tmp raw-size: 39.06 GiB size: 39.06 GiB (100.00%)
    used: 8.17 GiB (20.9%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.33 GiB used: 147 MiB (4.3%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 209 Uptime: 42m wakeups: 1 Memory: 3.34 GiB
  used: 2.32 GiB (69.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 1139 lib: 291 Shell: Bash v: 5.1.16
  running-in: qterminal inxi: 3.3.13
Garuda (2.5.5-1):
  System install date:     2022-03-10
  Last full system update: 2022-03-10
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

I think those are in the Openbox keyboard shortcuts.

Edit: sorry, disregard--obviously Openbox is not used in the Kwin version. :man_facepalming:

You may have to set up keyboard shortcuts that are not in the GUI via config file. Look in your ~/.config/ directory and see if you can find anything related to shortcuts (open with micro).

1 Like

Inside /home/tomas/.config/lxqt I found the file globalkeyshortcuts.conf, which apparently contains the same shortcuts set via GUI. I set a dummy shortcut before in the GUI app and it is listed here, so probably the app is editing this file, which must be what lxqt is reading.

I found this file searching inside the .config/ folder for key. Maybe there is another file with other settings and a different name that I can use.

I still don't know how the window management commands look like yet anyways

I found the file ~/.config/kglobalshortcuts which seems to contain the Alt+F4 that I wanted to change (among others). The line where it appears looks like this:
Window Close=AltF4,Alt+F4,Close Window

so I change it to:
Window Close=Meta+Q,Meta+Q,Close Window
With no immediate effect, and when I log out and log back in, the shortcut still doesn't work, and the line changed to this hybrid between my modification and the original:
Window Close=Meta+Q,Alt+F4,Close Window
Now Meta+Q does nothing as well as Alt+F4, so I guess those two have to match, but the line automatically changes itself on login

Is there any utility to change those shortcuts and make the change effective?

Can you upload the file in a pastebin or something?

IDK :smiley:
Just remove the first +
Window Close=MetaQ,Meta+Q,Close Window

3 Likes

You may need to enter "Win" instead of "Meta".

Since you are using kWin for WM, you should try Plasma Settings -> Keyboard shortcuts (this acts on this file ~/.config/kglobalshortcuts).

Also look into your open/running tasks to see relevant keyboard/shortcuts daemon active. If more than one, they might conflict.
And X11 (xorg server) is usually forcing its own shortcuts over user session.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.