Unable to change display resolution on LG TV

Will submit inxi later as I am remote from computer. However when attempting to change resolution from 4k to 1080P it ends up failing with with an output error (A new output has been added. Settings have been reloaded) message. What I did notice is that KDE is displaying an odd refresh rate of 30HZ. Thought it might have been just a Garuda issue, however using Big Linux (Manjaro Based) to test under live environment, I get the same output error and same refresh rate of 30HZ.

I’ve attempted to make the changes on Gnome and not only did it work, it also displayed (Correct) refresh rate of 120HZ.

Again I will submit INXI later but hoping someone has had this experience and can suggest a possible fix, not looking to go to gnome :frowning:

garuda-inxi
System:
Kernel: 6.9.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6c4ba715-4c06-403c-a7f2-0f1d33c14a35 rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Mini-pc System: Mini PC product: Quieter 4C v: N/A
serial: <superuser required> Chassis: type: 35 serial: <superuser required>
Mobo: Mini PC model: Rev ADLN62 1.10 serial: <superuser required>
part-nu: 10000 uuid: <superuser required> UEFI: American Megatrends LLC.
v: ML_ADLN6 V2.3 date: 11/18/2023
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 Plus
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel N100 bits: 64 type: MCP arch: Alder Lake level: v3
note: check built: 2021+ process: Intel 7 (10nm ESF) family: 6
model-id: 0xBE (190) stepping: 0 microcode: 0x17
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 1x2 MiB L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 700 high: 703 min/max: 700/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 703 2: 700 3: 700 4: 700
bogomips: 6451
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Alder Lake-N [UHD Graphics] driver: i915 v: kernel
alternate: xe arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
active: HDMI-A-3 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:46d1 class-ID: 0300
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 168 s-size: 580x326mm (22.83x12.83")
s-diag: 665mm (26.19")
Monitor-1: HDMI-A-3 mapped: HDMI-3 model: LG (GoldStar) TV SSCR2
serial: <filter> built: 2023 res: 3840x2160 hz: 30 dpi: 61 gamma: 1.2
size: 1600x900mm (62.99x35.43") diag: 1836mm (72.3") ratio: 16:9 modes:
max: 3840x2160 min: 720x400
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.8-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL-N)
device-ID: 8086:46d1 memory: 15 GiB unified: yes
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu
name: Intel Graphics (ADL-N) driver: mesa intel v: 24.0.8-arch1.1
device-ID: 8086:46d1 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.8-arch1.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Alder Lake-N PCH High Definition Audio vendor: IP3 Tech
driver: snd_hda_intel v: kernel alternate: snd_soc_avs,snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:54c8 class-ID: 0403
API: ALSA v: k6.9.2-zen1-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel CNVi: Wi-Fi driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:54f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:3
chip-ID: 8087:0aaa class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 1.16 TiB used: 24.67 GiB (2.1%)
ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: Generic model: A3A564
size: 232.96 GiB block-size: physical: 512 B logical: 512 B type: Removable
tech: SSD serial: <filter> fw-rev: 0x8 scheme: GPT
SMART Message: Unknown smartctl error. Unable to generate data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM9A1 NVMe 1024GB
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 36310029 temp: 40.9 C
scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 24.67 GiB (2.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 24.67 GiB (2.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 24.67 GiB (2.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 24.67 GiB (2.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.36 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 49.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB note: est. available: 15.36 GiB used: 5.49 GiB (35.7%)
Processes: 267 Power: uptime: 25m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 1 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.13 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 1768 pm: pacman pkgs: 1751 libs: 476 tools: gnome-software,
octopi, pamac, paru pm: flatpak pkgs: 17 Compilers: gcc: 14.1.1
Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-26
Last full system update: 2024-05-28
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

type or paste code here

using Wayland I can change resolution, however still shows 30HZ for a refresh rate, not a fan of Wayland as many applications like spotify flatpak does not work. Only under X11.

Providing xrandr output:

xrandr
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 16384 x 16384
HDMI-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
3840x2160 30.00*+ 25.00 24.00 29.97 23.98
4096x2160 30.00 25.00 24.00 29.97 23.98
1920x1080 120.00 100.00 119.88 60.00 50.00 59.94 30.00 25.00 24.00 29.97 23.98
1280x1024 60.02
1360x768 60.02
1152x864 59.97
1280x720 60.00 50.00 59.94
1024x768 60.00
800x600 60.32
720x576 50.00
720x480 60.00 59.94
640x480 60.00 59.94
720x400 70.08
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
HDMI-3 disconnected (normal left inverted right x axis y axis)

Had this same issue when I switched from the older DP cables to newer HDMI (2.1) cables on my monitors. I just plugged it in the other HDMI port to solve the issue. Some people are not aware that different ports sometimes support different standards (i.e. refresh rate).
So I’d recommend trying other ports.

EDIT:
Just saw your mention of Gnome. Not sure why it works there but not in Plasma. Guess I’ll leave my original response in case it’s helpful to anyone.

Thanks will give that a try and report back. Will also try a different HDMI Cable as well.

So tried changing the HDMI port on the TV and computer, no progress there. I’m finding out I can use a USB C to HDMI cable to project. Ordered it yesterday, will report back once I receive it.

1 Like

I’ve tried every combination to get Garuda working on my LG TV via KDE. Purchased different cables tried different ports, etc. Nothing worked. Looks like I’m destined to go with Garuda Gnome and go the extensions route to make it usable.

You can add an undetected resolution manually following this guidance: https://wiki.archlinux.org/title/Xrandr#Adding_undetected_resolutions

Once you get it working you can make it persistent by adding a config to /etc/X11/xorg.conf.d/. https://wiki.archlinux.org/title/Xrandr#Permanently_adding_undetected_resolutions

1 Like

Just thinking… have you not tried Wayland on Plasma?

1 Like

I have actually. It works better for sure, but issue is many flatpaks aren’t set up to work under Wayland :frowning:

Quoting one of the recommendations from the Garuda download page, as FYI:

Try to avoid using Snapd and Flatpack whenever possible. They are considered unsupported.

1 Like

Yes, as mad said, snap and flatpak are unsupported on (I think) all Arch based systems, including Garuda.

Understood and I try the best I can to use regular packages but you’re not going to find every package on Chaotic-AUR. Opera being one of them.

It’s on the AUR though.
Funnily enough, I’ve found everything I’ve ever looked for. I’ve had to manually compile nothing (outside of using paru). Of course, not everyone is comfortable with using AUR packages though.

I would agree with you however in this case Opera in the AUR has not been functioning as expected lately.