Unable to boot an ISO since /09/23

As the title would suggest, I’ve been unable to get an ISO to boot since the last released in September (Which has since been removed as only 2 iso’s show in the repo at all times?) all of the October releases fail to boot in one way or another with both open source and proprietary drivers and I’m at a bit of a loss as to why.

On my first attempt I used the last Sept release, which booted with open source drivers to a non-functional/lock up situation at desktop, no other ISO will get that far since, all bouncing back to login screen after a black screen and access to that ISO which could have atleast gave me a base to work from is gone :sweat_smile:

All the prior posts would seem to suggest there’s not much in the way of bare metal installs and alot is being done in VM’s.

Anyone had any luck with these ISO’s, Nvidia, bare metal? Just seems to despise my laptop.

NixOS with a custom install and ArcolinuxB work just fine so I’m at a loss.
CPU:AMD R7-5800H
GPU:RTX 3080

#MandatoryF***YouNvidia before anyone says it.

– update:

I’ve managed to make the current ISO boot, not sure which of the many potential fix’s I applied did the trick, could have been the Nvidia driver reinstall, removing garuda-settings etc. hard declaring my monitor in hyprland.conf, I tried just about everything.

See how the install goes and what I’m greeted with on first boot. :rofl:

– update --update
Nope, I have a seemingly identical setup between the ISO and install, one logs in to a fully functional desktop and the other doesn’t.

There is one difference I’ve noticed though, my install doesn’t have hyprstart? Had to run exec Hyprland from TTY3… Could that be something?

– update --update --update
Nope. Changing SDDM to launch with Hyprland instead of hyprstart did nothing, didn’t really expect it to as it doesn’t work from a console either… Logs don’t seem to point to anything in particular :upside_down_face:

1 Like

Oh my word, fixed it after way too many man hours.

It was the keyboard settings! The auto exec was wrongly pulling “uk” into the Hyprland config when it should be “gb”

I had to set it manually myself with data from localectl and then # the auto exec for an easy fix.

I’ll take a look at the script in a bit and see where it was going wrong, but THAT was the cause of all my troubles D:

The script use localectl and set the kb_layout.
But the ISO boot, wrong kb_layout do not stop it.

# .local/bin/garuda-locale.sh

localectl > /tmp/garuda-locale.txt

cat /tmp/garuda-locale.txt | grep Keymap > /tmp/keymap.txt

locale=$(cat /tmp/keymap.txt | awk '{ print $3 }')

sed -i "/kb_layout =/c\kb_layout = $locale" .config/hypr/hyprland.conf

There are problems with nvidia GPU, a miracle that it boots now.

1 Like

I have all the other fixes installed, THAT was the final thing that was preventing it from loading, found it in a log originally and paid it no mind thinking it couldn’t possibly be that.

When the Keymap and not the X11 layout is passed for an English GB user leading you to have “uk” pulled instead, it forces you back to the login.

I found it by accident, after revisiting the hyprland.conf I spotted it said “uk” and I went “that’s not right, Linux has always called it gb” when I changed only that and attempted to run Hyprland it logged in then about 2 seconds later, forced back to TTY3. That was my first successful desktop view since I installed hours ago.

Tested, repeated, tested, repeated, tested repeated. If you live in England, you’re gonna get a hard fault on this with that script.

Also, with the prescribed well known fixes, I have had little issues now on multiple distros (NixOS, Arch, ArcolinuxB, and now Garuda) with my laptops 3080, a blessed model perhaps.

P.s, the ISO boot did stop it, I left the Lang & kb as US and didn’t change it for the sake of installing, I only changed it during the calamares install on the attempt that DID work.

Just went to the ISO to test it aswell.

There’s a picture of a log, the last error can clearly be seen at the bottom of the log before it stops.


Thanks for the feedback.
I guess this keyboard problem affects me too then. However, I was able to log in with TTY3 and boot hyprland when testing and booting up to the black screen. Nothing changed on my keyboard then though.

Now would have to figure out why you don’t have this result when booting with hyprland-nvidia.
Even the Hyprland developers don’t write anything about keyboard and think it’s an Nvidia problem.
What is the command for this logfile and why can’t you post it as text?
If necessary, paste it here https://bin.garudalinux.org/.

This after password input, back to password input is strange because my password has no special characters and no matter if qwertz or qwerty keyboards works.

If this is all true now, I guess all users with Nvidia GPU who have no problems are from America :slight_smile: or have a keyboard layout that fits. Like @Ankur , who lives in India, and also has no problems with his Nvidia card :slight_smile:

Translated with DeepL Translate: The world's most accurate translator (free version)


Oh I can post it, that isn’t a problem - it was just late at night and quicker to show you a picture of it in the log! haha

This problem still persisted with all the -nvidia patches etc, it was irrelevant to the card. If I used the login manager, it sent me back to that after a dark screen and a blink, if i started it from TTY, it would send me back to that.

My password does contain special characters. but I don’t think it’s down to that as it didn’t have any issue submitting my password, it started to log in… then panicked when the uk vs gb conflict happened.

This is a hyprland crash log that saves to /home/.hyprland/hyprlandCrashReport<ID#>.txt

   Hyprland Crash Report

Hyprland received signal 11 (Segmentation fault)

Version: bb9d0aed5bd11879f5a532e26fc0a91d1a8af714
Tag: v0.31.0-13-gbb9d0aed

System info:
	System name: Linux
	Node name: dean-beastx25
	Release: 6.1.58-1-lts
	Version: #1 SMP PREEMPT_DYNAMIC Sun, 15 Oct 2023 18:38:43 +0000

	01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA104M [GeForce RTX 3080 Mobile / Max-Q 8GB/16GB] [10de:249c] (rev a1) (prog-if 00 [VGA controller])
06:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cezanne [Radeon Vega Series / Radeon Vega Mobile Series] [1002:1638] (rev c5) (prog-if 00 [VGA controller])

	NAME="Garuda Linux"
	PRETTY_NAME="Garuda Linux"

	#0 | Hyprland(_Z12getBacktracev+0x62) [0x5563bc6b5e92]
	#1 | Hyprland(_ZN13CrashReporter18createAndSaveCrashEi+0x5a4) [0x5563bc66d884]
	#2 | Hyprland(_Z25handleUnrecoverableSignali+0x44) [0x5563bc5dd864]
	#3 | /usr/lib/libc.so.6(+0x3e710) [0x7fa448e5c710]
	#4 | /usr/lib/libc.so.6(+0x15aedd) [0x7fa448f78edd]
	#5 | Hyprland(_ZNSt16basic_format_argISt20basic_format_contextINSt8__format10_Sink_iterIcEEcEE8_M_visitIZNS1_19_Formatting_scannerIS3_cE13_M_format_argEmEUlRT_E_EEDcOS9_NS1_6_Arg_tE+0x42b) [0x5563bc6208cb]
	#6 | Hyprland(+0xce321) [0x5563bc5eb321]
	#7 | Hyprland(+0xce58d) [0x5563bc5eb58d]
	#8 | Hyprland(_ZSt7vformatB5cxx11St17basic_string_viewIcSt11char_traitsIcEESt17basic_format_argsISt20basic_format_contextINSt8__format10_Sink_iterIcEEcEE+0x89) [0x5563bc621e79]
	#9 | Hyprland(_ZN13CInputManager21applyConfigToKeyboardEP9SKeyboard+0xaac) [0x5563bc74045c]
	#10 | Hyprland(_ZN13CInputManager11newKeyboardEP16wlr_input_device+0x4ec) [0x5563bc74162c]
	#11 | Hyprland(_ZN6Events17listener_newInputEP11wl_listenerPv+0xc3) [0x5563bc68ae63]
	#12 | /usr/lib/libwayland-server.so.0(wl_signal_emit_mutable+0x7e) [0x7fa44974601e]
	#13 | /usr/lib/libwayland-server.so.0(wl_signal_emit_mutable+0x7e) [0x7fa44974601e]
	#14 | /usr/lib/libwlroots.so.12032(+0x5ace5) [0x7fa4497e9ce5]
	#15 | /usr/lib/libwlroots.so.12032(+0x59e8c) [0x7fa4497e8e8c]
	#16 | /usr/lib/libwlroots.so.12032(+0x5a0e0) [0x7fa4497e90e0]
	#17 | /usr/lib/libwlroots.so.12032(+0x60466) [0x7fa4497ef466]
	#18 | Hyprland(_ZN11CCompositor15startCompositorEv+0x582) [0x5563bc5f3d12]
	#19 | Hyprland(main+0xb3b) [0x5563bc5c9c9b]
	#20 | /usr/lib/libc.so.6(+0x27cd0) [0x7fa448e45cd0]
	#21 | /usr/lib/libc.so.6(__libc_start_main+0x8a) [0x7fa448e45d8a]
	#22 | Hyprland(_start+0x25) [0x5563bc5dd6e5]

Log tail:
[LOG] Registered signal for owner 5563bd95c910: 5563bd95c998 -> 5563bc849b00 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95c9a8 -> 5563bc849ac0 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95c9b8 -> 5563bc849aa0 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95c9c8 -> 5563bc849a80 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95ca08 -> 5563bc8499e0 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95c9f8 -> 5563bc8499c0 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95ca18 -> 5563bc8499a0 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95ca38 -> 5563bc849980 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95c9d8 -> 5563bc849960 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bd95c910: 5563bd95c9e8 -> 5563bc849940 (owner: WLRCursor)
[LOG] Registered signal for owner 5563bcf90190: 5563bcf901a8 -> 5563bc849d20 (owner: Backend)
[LOG] Registered signal for owner 5563bcf7f1d8: 5563bd964248 -> 5563bc849cc0 (owner: Seat)
[LOG] Registered signal for owner 5563bcf7f1d8: 5563bd964258 -> 5563bc849ca0 (owner: Seat)
[LOG] Registered signal for owner 5563bcf7f1d8: 5563bd964298 -> 5563bc849c20 (owner: Seat)
[LOG] Registered signal for owner 5563bcf7f1d8: 5563bd9642a8 -> 5563bc849c00 (owner: Seat)
[LOG] Registered signal for owner 5563bcf7f1d8: 5563bd964258 -> 5563bc849ca0 (owner: Seat)
[LOG] Registered signal for owner 5563bcf7f1d8: 5563bd964278 -> 5563bc849c80 (owner: Seat)
[LOG] Registered signal for owner 5563bd964590: 5563bd9645b0 -> 5563bc849e20 (owner: LayerShell)
[LOG] Registered signal for owner 5563bd95c740: 5563bd95c760 -> 5563bc849e80 (owner: OutputLayout)
[LOG] Registered signal for owner 5563bd9647b0: 5563bd9647e8 -> 5563bc849c60 (owner: OutputMgr)
[LOG] Registered signal for owner 5563bd9647b0: 5563bd9647f8 -> 5563bc849c40 (owner: OutputMgr)
[LOG] Registered signal for owner 5563bd964890: 5563bd9648c0 -> 5563bc849be0 (owner: InhibitMgr)
[LOG] Registered signal for owner 5563bd964890: 5563bd9648d0 -> 5563bc849bc0 (owner: InhibitMgr)
[LOG] Registered signal for owner 5563bd964a00: 5563bd964a18 -> 5563bc849ce0 (owner: PointerConstraints)
[LOG] Registered signal for owner 5563bd964700: 5563bd964730 -> 5563bc849ba0 (owner: XDGDecoMgr)
[LOG] Registered signal for owner 5563bd964c00: 5563bd964c30 -> 5563bc849d00 (owner: VirtPtrMgr)
[LOG] Registered signal for owner 5563bd964b50: 5563bd964b80 -> 5563bc849a00 (owner: VKeyboardMgr)
[LOG] Registered signal for owner 5563bd1f8460: 5563bd1f8460 -> 5563bc849b80 (owner: WLRRenderer)
[LOG] Registered signal for owner 5563bd964fb0: 5563bd964fe0 -> 5563bc849b60 (owner: WLRIdleInhibitMgr)
[LOG] Registered signal for owner 5563bd95c790: 5563bd95c7c0 -> 5563bc849a60 (owner: PowerMgr)
[LOG] Registered signal for owner 5563bd965430: 5563bd965460 -> 5563bc849a40 (owner: IMEMgr)
[LOG] Registered signal for owner 5563bd965380: 5563bd9653b0 -> 5563bc849a20 (owner: TextInputMgr)
[LOG] Registered signal for owner 5563bd9654e0: 5563bd965508 -> 5563bc849de0 (owner: ActivationV1)
[LOG] Registered signal for owner 5563bd965630: 5563bd965638 -> 5563bc849920 (owner: SessionLockMgr)
[LOG] Registered signal for owner 5563bd95c690: 5563bd95c6d0 -> 5563bc849900 (owner: GammaCtrlMgr)
[LOG] Registered signal for owner 5563bd9656d0: 5563bd9656d8 -> 5563bc8498e0 (owner: CursorShapeMgr)
[LOG] Registered signal for owner 5563bd965770: 5563bd9657a0 -> 5563bc8498c0 (owner: TearingControlMgr)
[LOG] Registered signal for owner 5563bcf7ef30: 5563bd964da0 -> 5563bc849e40 (owner: DRM)
[LOG] Registered signal for owner 5563bcf90220: 5563bcf90380 -> 5563bc849b40 (owner: Session)
[LOG] wl_display_add_socket for wayland-1 succeeded with 0
[LOG] Running on WAYLAND_DISPLAY: wayland-1
[LOG] Attached a keyboard with name Video Bus
[LOG] Registered signal for owner 5563bd99c750: 5563bd999670 -> 5563bd99c758 (owner: Keyboard)
[LOG] Registered signal for owner 5563bd99c750: 5563bd999660 -> 5563bd99c7c0 (owner: Keyboard)
[LOG] Registered signal for owner 5563bd99c750: 5563bd999540 -> 5563bd99c890 (owner: Keyboard)
[LOG] Registered signal for owner 5563bd99c750: 5563bd999680 -> 5563bd99c828 (owner: Keyboard)
[LOG] ApplyConfigToKeyboard for "video-bus", hasconfig: 0
[LOG] Attempting to create a keymap for layout uk with variant  (rules: , model: , options: )
[ERR] Keyboard layout uk with variant  (rules: , model: , options: ) couldn't have been loaded.
[LOG] [hookSystem] New hook event registered: activeLayout


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.