Unable to boot after removing Plymouth

I removed all the Plymouth packages i had installed
plymouth-git, plymouth-kcm-git and the dragonized theme and then rebooted and it got stuck on the boot splash screen (which should of been removed) don't know how to post an incxi from tty but i got this hw-probe which shows all that plus system logs

Did you remove/replace the Plymouth hooks from /etc/mkinitcpio.conf and regenerate your initrds?

Try the fallback entry in grub. I that doesn't work you may want to restore a snapshot.

If you don't have snapshots, you will probably have to boot off an ISO and chroot in.


I tried that and this time it didn't give me a splash screen but threw me right into a tty

I gave you three options. Which one did you try?

Sorry it didn't type everything and i didn't notice i tried editing the mkinitcpio config dije to remove the Plymouth hook and rebuilt init and it just booted me to a tty

got a log hastebin there seems to be a issue with my nvidia modules

Can we see the content of mkinitcpio.conf and the output of sudo mkinitpio -P

Also, which display manager and DE/WM are you using?

KDE 5.23 (X11) - SDDM


Should probolay add that mkinitcpio was from after restoring a working snapshot so i still have the plymouth hook there.

realized that it could be misunderstood to be how I modified it to remove plymouth which should look like this hastebin
and then regenerated with sudo /usr/bin/mkinitcpio -P

Do you have a timeshift restore point?

yeah i restored and then edited the mkinitcpio config and it wouldn't boot so for now im just leaving plymouth for some reason removing it breaks my system

I remember this worked for several people in the past.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.