Unable to boot after latest update




I am unable to log in after the last garuda-update routine

I can do alt f2 and run garuda-inxi command but would be grateful for a tip as to how to save as a log file that I can email to you separately

For now, I attach some error messages I have seen via screen photos

Hope you can assist

Cheers
R

Hey, sign-in in a TTY and upload your log file to a link using the command garuda-inxi | tb. This assumes you have an Ethernet connection.

2 Likes

Many thanks for quick reply; much appreciated. Grateful for some pointers re how to perform the TTY approach

Cheers
R

Hmm? You already seem to know how to get to a tty as you wrote out in your first message, what more do you need?

Sorry not familiar with terminology. Let me try that and get back to you

https://termbin.com/wgob5

Clever, I will remember this..

According to the AUR comments below your Nvidia driver does not fully support Kernel 6.0.
https://aur.archlinux.org/packages/nvidia-470xx-dkms
It could be that it was working fine with a previous version (e.g. linux-zen- 6.0.9) then the recent release of 6.0.10 created troubles.
I'd try to install the linux-lts:

sudo pacman -Syu linux-lts linux-lts-headers
2 Likes

Many thanks for the advice

I was able to apply the updates but unfortunately get the error message "Failed to start Displaylink Manager Service" and "Failed to start Samba NMB Daemon"

Should I try one of the alternative boot options?

Grateful for your thoughts

Cheers
R

Actually I went into advanced options and can boot via LTS option

Should I just do this from now on and ignore the standard menu option

Also, should I continue to apply system updates

Thanks again
R

Sure you have to continue applying the updates.
I'll link you in a few minutes a procedure to boot by default to the linux-lts kernel.
That should be useful, so you keep the linux-zen installed, keep it up-to-date, and every now and then (when zen is updated) you give it a try.
Here we go:

Pay attention to the "1>2" example, which should be the case you need.

3 Likes

Thanks again

I set "GRUB_DEFAULT=4" and commented out the "saveddefault", however it still boots to the Zen version

When I boot into LTS and check the file, the changes are saved

Not a big deal for me to go via advanced options though. Just delighted I am back in

Cheers
R

Have you given

sudo update-grub

?
Is your linux-lts in row number 5 in the plain list (without submenus I guess) since you used GRUB_DEFAULT=4?
Check also that GRUB_DEFAULT does not apoear twice in that file (It happened sometimes).

1 Like

Hi screen photo attached

Also text file copied below:

# GRUB boot loader configuration

GRUB_DEFAULT=4
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Garuda"
GRUB_CMDLINE_LINUX_DEFAULT="quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off" # Modified by garuda-migrations: ibt=off
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
# Modified by garuda-migrations: GRUB_DISABLE_RECOVERY=default
#GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/usr/share/grub/themes/garuda-dr460nized/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
GRUB_DISABLE_OS_PROBER=false

Thanks so much
R

I did the update Grub command and now it defaults to snapshots which is new

You have to use

GRUB_DEFAULT=3

Because it is the fourth in the list (starts counting from 0).
Additionally, set
#GRUB_SAVEDEFAULT
Finally
sudo update-grub
Again

2 Likes

Snapshots option has now disappeared but no LTS default. Honestly it's fine and appreciate your trying to help me. If anything it's an added security layer given I am the only one who knows which menu option to get in!

You could try simply uninstalling the Zen kernel while running the LTS. Update grub, then reboot and install the Zen kernel again. Update grub again. Sometimes simply changing the order the kernels were installed will change the default order they are booted.

2 Likes

Have you tried changing the boot default in Garuda Boot Options? There is a drop-down menu called "Boot to" where you can choose from all the available boot options.

3 Likes

From the image and text analysis, the image is from the 2nd page of grub menu.
If you read again previous advice, you should understand.

1>2 means activate the second choice at the 1st page (menu line numbers start from zero 0, so 1 is second line), which is the Advanced menu options submenu, and on the new page, boot the 3rd line (2 is 3rd line).

Keep trying and reading, until you succeed. :smiling_face:

2 Likes

Hah OK! Thanks for explaining further. 1>3 now highlights advanced options as default. However, if I let it run, it still boots Zen. Even 1>4 boots Zen. Also did the update command both times as well. So I am very close but still missing one last piece...