Ubuntu grub entry boots to Garuda OOTB

This is pretty weird.
I have a multi-boot system with Windows, Ubuntu and Garuda.
After repairing a grub issue, when I go and choose the Ubuntu entry in the grub menu, after a ten second delay I get to Garuda, but as it is out of the box. It is not my customized installation of Garuda.
I tried deleting the Garuda partition altogether (I saved a system image of it), and I get the same behavior.
The only thing I can think of is that a Garuda directory is hiding somewhere inside of my Ubuntu installation. I don't know where to look for it or how such a thing could happen. :thinking:
Any ideas?

This is not really OOTB :slight_smile: You break it...
I'd start checking your efibootmgr -v, the contents of your EFI system partition and lsblk -f.
It weird anyway, without knowing what you did and what you have.
You know you cannot expect much support here, don't you?
Multibooting (not supported), unclear starting status and previous actions, everything could drive somewhere into the 4xx Client Error forum category...


Hello. Is it possible you put Garuda's GRUB entry in a place belonging to another distribution, say Ubuntu? @filo's suggestion might provide more information.


1 Like

I have no expectations for miracle solutions, just thought it's worth asking, though. I can always restore an earlier system image of Ubuntu if I really want to.

Where is Garuda's grub entry supposed to go? I assume that grub entries go into the little fat32 partition at the beginning of the disk, before the Windows partition. Is that wrong?

efibootmgr -v                                   ✔ 
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0005,0003,0002,0000,0004,0006
Boot0000* Windows Boot Manager  HD(2,GPT,33a74615-4c79-4b19-8c91-2d2805352162,0x109000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* Manjaro       HD(2,GPT,33a74615-4c79-4b19-8c91-2d2805352162,0x109000,0x32000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0002* arch  HD(2,GPT,33a74615-4c79-4b19-8c91-2d2805352162,0x109000,0x32000)/File(\EFI\ARCH\GRUBX64.EFI)
Boot0003* ubuntu        HD(2,GPT,33a74615-4c79-4b19-8c91-2d2805352162,0x109000,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0004* Garuda        HD(2,GPT,33a74615-4c79-4b19-8c91-2d2805352162,0x109000,0x32000)/File(\EFI\GARUDA\GRUBX64.EFI)
Boot0005* MX21  HD(2,GPT,33a74615-4c79-4b19-8c91-2d2805352162,0x109000,0x32000)/File(\EFI\MX21\SHIMX64.EFI)
Boot0006* UEFI: SanDisk, Partition 2    PciRoot(0x0)/Pci(0x14,0x0)/USB(11,0)/HD(2,MBR,0x3ed5f7cc,0x1c8a000,0x18800)..BO

lsblk -f                                        ✔ 
│    ntfs               CAC44E39C44E2851                                    
│    vfat   FAT32       2641-384E                              52.4M    45% /boot/efi
│    ntfs         Windows
│                       01D807D3060A1E90                                    
│    ntfs               A46C85746C8541D2                                    
│    ext4   1.0   Virtual Machines
│                       bb38277b-a6df-42dc-9079-9864c822426a   10.6G    87% /mnt/bb38277b-a6df-42dc-9079-9864c822426a
     ext4   1.0   Arch  e348fe77-c36a-42a9-96fa-4a4757baff3a   93.5G    20% /
│    ntfs         Personal Data
│                       22EC446AEC4439F5                      356.5G    64% /mnt/22EC446AEC4439F5
│    ntfs         Backups
│                       FE3448B334487127                                    
     ext4   1.0   TimeShiftBackup
                        7fe6f0e9-d71f-449f-9e02-985f048e1ecb   54.9G    41% /run/timeshift/backup
│    ext4   1.0   MX_Snapshot
│                       95ae4f0b-b103-4325-826b-3977f412be44                
     vfat   FAT32 LIVE-UEFI

Nope, that should be correct. Sometimes a user will unknowingly do so. I just don't multi-boot anymore. I got tired of having to repair problems such as yours a long time ago. So have others, and it may be the reason Garuda does not 'officially' support multiple booting and associated problems. I've had better luck with VMs, myself. Though not very.

As regards your repeated virginal Garuda login experience, could you have been using the Guest account?


1 Like

Holy guacamole! I'm out o' my depth after that screenshot. Sorry.


You've got that right. I've seen less things in a Ventoy ISO setup for a distro hopper!


The first thing that comes to mind for me is that you wrote the Garuda installation image into your Ubuntu partition instead of onto a USB flash drive, and when you generate the boot menu it's finding that image.

Where is Ubuntu in this listing?


I'm lost as well.
Never seen such massive multibooting.
And also the ESP partition needs some clean-up of your past installations.
I also cannot see ubunt in the lsblk, although in the efibootmgr entry I see it pointing to \EFI\UBUNTU\SHIMX64.EFI, which should be a secure-boot entry.

Yes, that makes sense, the Garuda image must be in Ubuntu somewhere. I could probably find it if I navigate the file structure from a live USB.

Ubuntu is not there because I currently have Manjaro as the only linux distro on my hard disk. Garuda and Ubuntu exist right now only in backup form. The partition on which Manjaro is installed is named "Arch", but that is just the name of the partition, not what is actually installed on it right now.


Your setup sounds very unique, so you probably won't find people who will be able to help.

1 Like

Check your bios settings see if it has not changed the default boot drive?

Ahh - almost as many builds as I run! :grin: One way out of the confusion that you might consider is to switch to rEFInd for booting purposes. rEFInd can either directly boot any of those mentioned, or can optionally pick up grub entries. If what I saw has any connection to the real situation, then I would direct boot all but Garuda which I would have boot up to its grub entry (for compatability reasons with its Timeshift or snapper setup).

Just installing rEFInd on any of the Linux systems, then running its install script should have you in action for the basics. Determining what is actually there will help regardless though!

I will help if needed on that - but here is not the place for discussing multi-boots! Too many problems (caused by the 'W', usually) for the small help team here to handle!) but I can help myself some. If you need more rEFInd info, you could visit the forums over on EndeavourOS, and see the wiki entries on rEFInd - or prepare for a lot of reading on The rEFInd Boot Manager...


Hmmm - on my four systems I have:

  1. 5 Linux distros
  2. 8 Linux distros
  3. Arch + Windows
  4. EnOS as a mirror server

OP seems pretty restrained to me :grin:


You won.
You only need to create a script on top of the grub or what, that randomly launches the distro of the day.


Actually, the EFI partition has leftovers from installs and regrubbings of existing installations, going back a couple years. When I go into the BIOS I don't actually see all those entries.

But I am glad I made you guys laugh over my crazy boot partition. At least it was good for something. :slight_smile:


This is why I switched to refind, GRUB was just a pain to manage with multibooting.

Thread moved to Dual boot| Unsupported hardware for obvious reasons.