Ublock Origin Not Showing In Unified Extension Button [Solution]

Had this issue while playing around with Firedragon.
Installed Floorp and saw a similar issue, which is that even though Ublock Origin is installed, it does not show in the Unified Extension Button.
A quick search on the .net yielded this solution.

  • about:addons

  • Select ublock
    Click on gear and select “Manage Extension Shortcuts”

  • In “Activate toolbar button” choose a shortcut, cntrl+shft+2 (just take one which doesn’t conflict other settings)

  • Restart firefox

  • Press cntrl+shft+2 (or the combination you have set yourself)

  • Under the extensions icon in the toolbar, the ublock icon appears.

  • Right click ublock icon and select “Pin to toolbar”

  • Now you can remove cntrl+shft+2

Enjoy.

1 Like

It’s not always uBlock.

This is on a fresh new install after clearing out a machine with everything Firedragon related:

image

But the procedure should work to get Dark Reader out of the Extensions Overflow: