Typing Password on Login Screen

Hello after recent update i seem to have to click on the password field on login instead of only typing it. I have searched web and forums for solution but havent found any yet. here is my inxi

garuda-inxi

System:
Kernel: 5.19.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c06e65eb-8bdb-4787-838c-49ba9d398d64 rw [email protected]
splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=132ac4ba-2e04-49ee-91e4-ae326edcac97 loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: MAG B560M BAZOOKA (MS-7D18) v: 2.0
serial: <superuser required> UEFI: American Megatrends LLC. v: A.40
date: 01/18/2022
CPU:
Info: model: 11th Gen Intel Core i5-11400F bits: 64 type: MT MCP
arch: Rocket Lake gen: core 11 built: 2021+ process: Intel 14nm family: 6
model-id: 0xA7 (167) stepping: 1 microcode: 0x54
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2898 high: 4400 min/max: 800/4400 scaling:
driver: intel_pstate governor: performance cores: 1: 2600 2: 2600 3: 2600
4: 4382 5: 2600 6: 2600 7: 2600 8: 2600 9: 2600 10: 4400 11: 2600
12: 2600 bogomips: 62208
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate] vendor: ASUSTeK
driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
(7nm) built: 2020-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max:
gen: 4 speed: 16 GT/s bus-ID: 01:00.0 chip-ID: 10de:2489 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 80 s-size: 609x343mm (23.98x13.50")
s-diag: 699mm (27.52")
Monitor-1: HDMI-0 size-res: N/A modes: N/A
Monitor-2: HDMI-1 pos: primary res: 1920x1080 dpi: 82
size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
OpenGL: renderer: NVIDIA GeForce RTX 3060 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA
515.65.01 direct render: Yes
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 1-4.1:6 chip-ID: 046d:0aaa
alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 class-ID: 0300
chip-ID: 8086:43c8 serial: <filter> class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
Device-3: Logitech Logitech G PRO X Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound Server-1: ALSA v: k5.19.6-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 04:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-2:2 chip-ID: 0bda:2550 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 3.64 TiB used: 1.18 TiB (32.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P5PSSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: P7CR402
temp: 50.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Crucial model: CT500P2SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P2CR033
temp: 39.9 C scheme: GPT
ID-3: /dev/nvme2n1 maj-min: 259:5 vendor: Crucial model: CT500P2SSD8
size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: P2CR045
temp: 32.9 C scheme: GPT
ID-4: /dev/sda maj-min: 8:0 vendor: Crucial model: CT2000MX500SSD1
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 033 scheme: GPT
Partition:
ID-1: / raw-size: 448.41 GiB size: 448.41 GiB (100.00%) used: 326.69 GiB
(72.9%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:3
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 612 KiB
(0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:2
ID-3: /home raw-size: 448.41 GiB size: 448.41 GiB (100.00%) used: 326.69
GiB (72.9%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:3
ID-4: /var/log raw-size: 448.41 GiB size: 448.41 GiB (100.00%) used: 326.69
GiB (72.9%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:3
ID-5: /var/tmp raw-size: 448.41 GiB size: 448.41 GiB (100.00%) used: 326.69
GiB (72.9%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.51 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.06 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p3 maj-min: 259:4
Sensors:
System Temperatures: cpu: 38.0 C mobo: N/A gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 343 Uptime: 7m wakeups: 0 Memory: 15.51 GiB used: 3.97 GiB
(25.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pacman: 1812 lib: 507
Shell: fish v: 3.5.1 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-08-05
Last full system update: 2022-09-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Works here.

Any chance you change something?
Check list what changed in

please.

grep -i installed /var/log/pacman.log
grep -i removed /var/log/pacman.log
grep -i update /var/log/pacman.log
grep -iE 'installed|upgraded|removed|update' /var/log/pacman.log
5 Likes

Thanks for fast answer should i post result of command? only shows reinstalled software.

SDDM, your (and mine) Display Manager, providing the graphical login, hasn't been updated since several months.
My only idea is, did you happen to change the SDDM theme from the settings? This could maybe have an impact on that aspect.

3 Likes

My SDDM Theme is Sweet havent changed it in a long time. It does seem to have reverted back to standard though. just rebooted to check i can simply not type without clicking the pw box first. Thank you for your help

I have just tested changing my sddm theme. it worked but still the problem of not being able to type without clicking pw box persists

I just double checked this command on other pc where issue does not exist and my original post PC output looks the same. Anyways thank you for help on a minor inconvenience. and for an amazing linux distro keep up the amazing work.

1 Like

i have same behavior on my PC , i think it is not a problem , but it is working for me when you lock and unlock the screen. i always considered it as a default plasma login behavior,
very surprised to see that it bothers you

well it does bother in a minor manor that i have to take my mouse and click on little field or just type my pw. if that makes sense? other 2 pcs i can turn on and type my pw directly no mouse required for startup.

I think you are one of those affected by this so old and still open issue!
Try to give a look at the comments and replicate what could help you.
Very strange...

3 Likes

So i have tried reinstalling sddm and changing the sddm theme. finally the text cursor is missing and cant see that im typing but i can type without mouse usage. Thank you for fast responses and amazing distro. Peace out.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.