Tuxi-git not working

I've tried installing it with pacman, and through the github. All my searches get "no results!"

Any suggestions?

Kernel: 5.18.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f9ef267e-8b7f-41b0-afed-b96ded78cd39 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=08d8a7c4-2f5d-44df-acb6-3606b2cfa700 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: A320M-HDV R4.0
serial: <superuser required> UEFI: American Megatrends v: P3.30
date: 07/31/2019
CPU:
Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ gen: 2
built: 2018-21 process: GF 12nm family: 0x17 (23) model-id: 8 stepping: 2
microcode: 0x800820D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 2593 high: 3395 min/max: 1550/3400 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2416 2: 2408
3: 2235 4: 2606 5: 2411 6: 2998 7: 2676 8: 2690 9: 2320 10: 2302 11: 2667
12: 3395 bogomips: 81586
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: ZOTAC driver: nvidia
v: 515.48.07 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 06:00.0
chip-ID: 10de:2184 class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: nvidia
unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 7680x2160 s-dpi: 101 s-size: 1930x543mm (75.98x21.38")
s-diag: 2005mm (78.93")
Monitor-1: DP-1 pos: primary,top-center res: 1920x1200 hz: 60 dpi: 94
size: 518x324mm (20.39x12.76") diag: 611mm (24.05") modes: N/A
Monitor-2: DP-2 pos: bottom-l res: 1920x1200 hz: 60 dpi: 94
size: 518x324mm (20.39x12.76") diag: 611mm (24.05") modes: N/A
Monitor-3: HDMI-0 pos: top-right res: 3840x2160 hz: 60 dpi: 52
size: 1872x1053mm (73.7x41.46") diag: 2148mm (84.56") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1660/PCIe/SSE2
v: 4.6.0 NVIDIA 515.48.07 direct render: Yes
Audio:
Device-1: NVIDIA TU116 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 06:00.1 chip-ID: 10de:1aeb class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 08:00.3
chip-ID: 1022:1457 class-ID: 0403
Sound Server-1: ALSA v: k5.18.2-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
vendor: ASUSTeK driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp4s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: ASUSTek type: USB driver: btusb v: 0.8 bus-ID: 1-9:2
chip-ID: 0b05:1868 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.95 TiB used: 44.14 GiB (2.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: PNY model: CS900 500GB SSD
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0613 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 4B6Q scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: HD642JJ
size: 596.17 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: N/A serial: <filter> rev: 1114 scheme: MBR
Partition:
ID-1: / raw-size: 111.76 GiB size: 111.76 GiB (100.00%)
used: 30.75 GiB (27.5%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
ID-2: /boot/efi raw-size: 600 MiB size: 598.8 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 815.43 GiB size: 815.43 GiB (100.00%)
used: 13.39 GiB (1.6%) fs: btrfs dev: /dev/sdb5 maj-min: 8:21
ID-4: /var/log raw-size: 111.76 GiB size: 111.76 GiB (100.00%)
used: 30.75 GiB (27.5%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
ID-5: /var/tmp raw-size: 111.76 GiB size: 111.76 GiB (100.00%)
used: 30.75 GiB (27.5%) fs: btrfs dev: /dev/sdb3 maj-min: 8:19
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.28 GiB used: 512 KiB (0.0%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 3.72 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sdb2 maj-min: 8:18
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 38%
Info:
Processes: 342 Uptime: 2h 20m wakeups: 0 Memory: 31.28 GiB
used: 4.44 GiB (14.2%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1974
lib: 556 Shell: fish v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.17
Garuda (2.6.3-2):
System install date:     2021-12-01
Last full system update: 2022-06-13 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Welcome to the Forums!

I do see it in the AUR repo AUR (en) - tuxi-git

2 Likes

Welcome to the forum!

Unrelated problem: this symbol means that the system has not been rebooted since the last update. In this case it is particularly important to do it, since the kernel will be now 5.18.3.

3 Likes

Thanks, I should have been more clear. I can successfully install the program. The problem is that it doesn't seem to work. Anything I search using tuxi just says "no results". I've tried to google the problem but I only get a few results of the program working fine for everyone else. I haven't seen any problems reported for it. Not sure if it's Garuda or tuxi.

If the program is not launching, or launches but crashes/freezes, as a quick start, if you run it from the Terminal window and post the output here, what does it say?

EDIT: The version on the AUR seems to be outdated, although no one flagged it as such. If it's true, this could cause program instability and issues.

2 Likes

It's a CLI program only. But when I type it says.

╰─λ tuxi
Hi, I'm Tuxi. Ask me anything!
Usage: tuxi [options] query

But then when I try to search something by throwing "tuxi what is linux" or "tuxi baseball" I get

No Result!

This script is kind of abandoned, but there are a possible work-around and a couple of forks.

3 Likes

Ha I see better what that program is.

man tuxi

Should tell you how to use the program, in case you are not using it properly.
If you are using it properly, then maybe post on the AUR URL from Post #2 asking why you get no result?

1 Like

This project has been abandoned and for all intents and purposes the program is defunct.

I suggest that the solution to your problem is learning how to search issues for yourself. You know the old saying, "If you want something done right, you have to do it yourself".

See this post on the Garuda Wiki for many helpful tips on how to search effectively:

This is really not anything to do with Garuda and is something you need to learn to do for yourself. Garuda promotes the philosophy that our users should strive to be self sufficient and only rely on the forum for solving difficult issues. This topic couldn't possibly be any further from what Garuda attempts to instill in our users.

As such, I am closing this thread because the program you want assistance with is non-functional and this topic is a total waste of forum support resources.

4 Likes