"ttf-firacode-nerd and nerd-fonts-complete are in conflict" when trying to update

Here's the output of:

garuda-inxi
System:
  Kernel: 6.0.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=a279476a-3f56-4818-b495-07b6c8fbe8f6 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
    ibt=off
  Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: Z370 SLI PLUS (MS-7B46) v: 2.0
    serial: <superuser required> UEFI: American Megatrends v: A.20
    date: 12/21/2017
CPU:
  Info: model: Intel Core i7-8700 bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2400 high: 3200 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3200 2: 3200 3: 800
    4: 3200 5: 3200 6: 3200 7: 800 8: 3200 9: 800 10: 3200 11: 3200 12: 800
    bogomips: 76799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: Gigabyte driver: nvidia
    v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1b06 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.70x13.43")
    s-diag: 692mm (27.24")
  Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 163
    size: 600x340mm (23.62x13.39") diag: 690mm (27.15") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce GTX 1080
    Ti/PCIe/SSE2 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 1-3:2 chip-ID: 0a12:1243
    bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0300 serial: <filter>
    class-ID: 0403
  Device-2: NVIDIA GP102 HDMI Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10ef class-ID: 0403
  Device-3: Cambridge Silicon Radio nuraphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.7-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.82 TiB used: 304.28 GiB (16.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 020 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Toshiba
    model: External USB 3.0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 5438 scheme: MBR
Partition:
  ID-1: / raw-size: 465.26 GiB size: 465.26 GiB (100.00%)
    used: 304.25 GiB (65.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 30.2 MiB (5.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 465.26 GiB size: 465.26 GiB (100.00%)
    used: 304.25 GiB (65.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 465.26 GiB size: 465.26 GiB (100.00%)
    used: 304.25 GiB (65.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 465.26 GiB size: 465.26 GiB (100.00%)
    used: 304.25 GiB (65.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.58 GiB used: 426.5 MiB (2.7%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 54 C
  Fan Speeds (RPM): cpu: 456 gpu: nvidia fan: 31%
Info:
  Processes: 332 Uptime: 2h 55m wakeups: 0 Memory: 15.58 GiB
  used: 6.33 GiB (40.6%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages:
  pm: pacman pkgs: 1440 libs: 340 tools: octopi,paru,yay Shell: fish v: 3.5.1
  running-in: tmux: inxi: 3.3.23
e[1;34mGaruda (2.6.9-1):e[0m
e[1;34m  System install date:e[0m     2022-01-29
e[1;34m  Last full system update:e[0m 2022-11-10
e[1;34m  Is partially upgraded:  e[0m Yes
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m bluetooth-autoconnect.service 

What I'm trying to accomplish?

I'm trying to run

garuda-update

in order to update my computer and it's dependencies.

What's stopping me?

I always get the same error when I'm writing no:

resolving dependencies...
looking for conflicting packages...
:: ttf-firacode-nerd and nerd-fonts-complete are in conflict (nerd-fonts-fira-code). Remove nerd-fonts-complete? [y/N] 
n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: ttf-firacode-nerd and nerd-fonts-complete are in conflict

When I'm writing yes:

resolving dependencies...
looking for conflicting packages...
:: ttf-firacode-nerd and nerd-fonts-complete are in conflict (nerd-fonts-fira-code). Remove nerd-fonts-complete? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nerd-fonts-complete breaks dependency 'nerd-fonts-fantasque-sans-mono' required by garuda-fish-config
 -> error installing repo packages

I think you should try to remove ttf-firacode-nerd, as nerd-fonts-complete provides nerd-fonts-firacode anyway.
pacman -R ttf-firacode-nerd (no errors I hope) then garuda-update.
Of course if the first command prompts or complains about something, stop there and let's see what depends on ttf-firacode-nerd.

1 Like

This is where it gets weird:

error: target not found: ttf-firacode-nerd

Next try: pacman -S nerd-fonts-fantasque-sans-mono and confirm removing nerd-fonts-complete. Then you'd have to reinstall the individual nerd-fonts-* you need.
I just noticed that nerd-fonts-complete is only in AUR, and I don't understand why there are two packages for the same font.

2 Likes

Here's the result

resolving dependencies...
looking for conflicting packages...
:: nerd-fonts-fantasque-sans-mono and nerd-fonts-complete are in conflict. Remove nerd-fonts-complete? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nerd-fonts-complete breaks dependency 'nerd-fonts-fira-code' required by garuda-dr460nized

pacman -S nerd-fonts-fantasque-sans-mono nerd-fonts-fira-code :crossed_fingers:
Though I suspect it will complain about the ttf again.

4 Likes

It worked! Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.