Trying to get CD-ROM established in Garuda

Paste the full input and output of the command you have run into the thread so we can help you figure out what is going on.

It sounds like you are probably trying to install a package while your system is out of sync with the repository you are using. First bring your system fully up to date:

garuda-update

Then install the kernel and headers.

sudo pacman -S linux-lts linux-lts-headers
1 Like

╰─λ inxi --optical
Drives:
Local Storage: total: 5.47 TiB used: 54.09 GiB (1.0%)
ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD
size: 476.94 GiB
ID-2: /dev/sda vendor: Western Digital model: WDBNCE0010PNC
size: 931.51 GiB
ID-3: /dev/sdb vendor: Seagate model: Expansion Desk size: 3.64 TiB
type: USB
ID-4: /dev/sdc vendor: Seagate model: ST9500325AS size: 465.76 GiB
type: USB
Message: No optical or floppy data found.

╰─λ hwinfo | grep DVD
Can read DVD:
Can write DVD-R:
Can write DVD-RAM:

So I will take a look at the BIOS as discussed, but will submit that if alternate OS on same computer (Zorin) and my previously installed OS of Kubuntu did not have issues with CD ROM visibility, BIOS seems to be ruled out. All indicators point to the Garuda OS install itself. Am I wrong to assume that?

Yes. Neither of the distributions you mention are Arch based and neither uses an Arch kernel.

1 Like

Just as a sidenote - here is HWINFO when run from ZORIN OS:
hwinfo | grep DVD
Can read DVD: 1
Can write DVD-R: 1
Can write DVD-RAM: 1
model = DVDRW GUD1N
S: disk/by-id/ata-hp_HLDS_DVDRW_GUD1N_7JXUNNAKKEJ2WF
E: ID_CDROM_DVD=1
E: ID_CDROM_DVD_R=1
E: ID_CDROM_DVD_RW=1
E: ID_CDROM_DVD_RAM=1
E: ID_CDROM_DVD_PLUS_R=1
E: ID_CDROM_DVD_PLUS_RW=1
E: ID_CDROM_DVD_PLUS_R_DL=1
E: ID_MODEL=hp_HLDS_DVDRW_GUD1N
E: ID_MODEL_ENC=hp\x20HLDS\x20\x20DVDRW\x20\x20GUD1N\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20\x20
E: ID_SERIAL=hp_HLDS_DVDRW_GUD1N_7JXUNNAKKEJ2WF
E: DEVLINKS=/dev/disk/by-path/pci-0000:00:17.0-ata-3 /dev/cdrom /dev/dvd /dev/disk/by-id/ata-hp_HLDS_DVDRW_GUD1N_7JXUNNAKKEJ2WF /dev/disk/by-label/AmigaOS3.2CD /dev/disk/by-id/wwn-0x5001480000000000 /dev/dvdrw /dev/cdrw
links: /dev/disk/by-path/pci-0000:00:17.0-ata-3, /dev/cdrom, /dev/dvd, /dev/disk/by-id/ata-hp_HLDS_DVDRW_GUD1N_7JXUNNAKKEJ2WF, /dev/disk/by-label/AmigaOS3.2CD, /dev/disk/by-id/wwn-0x5001480000000000, /dev/dvdrw, /dev/cdrw
50: SCSI 200.0: 10602 CD-ROM (DVD)
Model: "hp HLDS DVDRW GUD1N"
Device: "DVDRW GUD1N"
Device Files: /dev/sr0, /dev/disk/by-path/pci-0000:00:17.0-ata-3, /dev/cdrom, /dev/dvd, /dev/disk/by-id/ata-hp_HLDS_DVDRW_GUD1N_7JXUNNAKKEJ2WF, /dev/disk/by-label/AmigaOS3.2CD, /dev/disk/by-id/wwn-0x5001480000000000, /dev/dvdrw, /dev/cdrw
Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL, DVD-RAM

  1. System boots fine from CD-ROM.
  2. Booting with LINUX-LTS had no effect - CD-ROM still not seen.

Any clue? I have none.

Have you done this, as suggested?

That’s the Amiga 3.2 CD in the CD drive that I was using for some other testing before I ran the command.

Step taken - no change.

Did you remove the Amiga CD? Maybe the filesystem of that Amiga CD is not supported by any of the drivers shipped with Garuda?

1 Like

Did you remove the Amiga CD? Maybe the filesystem of that Amiga CD is not supported by any of the drivers shipped with Garuda?

Yes - I did during troubleshooting. Here’s an interesting point I saw while doing that though:
The CD-ROM drive is not functional while Garuda is in operation (Eject button is unresponsive). I can only eject the disk during BIOS start up OR when I go into alternate OS.

I’m thinking of maybe playing more with the secure boot and perhaps it’s a reinstall of Garuda with Secure Boot enabled to ensure third-party drivers are being implemented?? Is that the potential resolution?

No, never.

What “alternate OS?” If it is Windows, that’s the problem. If Secure Boot is enabled during install, that may be the problem. If full hardware detection in your BIOS is not enabled, that’s a probable problem.

1 Like

Have you tested this while booted with the live system you used to install the system? If you have the latest live iso of Garuda, does your cdrom drive operate while booted from that usb stick (assuming you have a usb stick with Garuda)?

I have the Xfce edition and it boots and the dvd+rw drive is functioning as normal without any intervention on my part. I can only assume the basics for CD/DVD drive operation are included in the base Garuda package list.

If you installed Garuda while the Amiga CD was in the drive, and Garuda could not see the Amiga filesystem, maybe the installation did not identify the cdrom drive as operational at install time and did not set up the device for use. That is about the only thing I can think of now.

Excellent suggestion. Same results, unfortunately.

  • Removed disc at BIOS startup
  • Launched Garuda using proprietary drivers (no effect)
  • Launched Garuda using open-source drivers (no effect)

I did find in an alternate forum (not Garuda, but Arch Linux) someone having similar problems and they reverted their system back to an older BIOS which resolved the issue. I’m thinking that may be a solution on this end, but not sure if I’m willing to take that step… but will investigate further.

2 Likes

Depending on the manufacturer and the BIOS supplier, it can be easy & painless. First, see if there is an option to do so in your present BIOS. If not, then goto the mfg’s website and see what they have. And it wouldn’t hurt to peruse their forums/msg boards, either. The solution might also be found there. Good luck! :slight_smile:

2 Likes