Trying to change kernel thru grub boot but my arrow keys broken

Might be a somewat of a silly issue. I don’t have any spare keyboards laying around. I was wondering if it was possible to change the kernel thru terminal instead? I know you can access the /defaul/grub folder but I never had to use it and i don’t really know what to do with it.

Any pointers would be appreciated

Hi there welcome to the forum.
Maybe something like this?

And maybe consider also this


Assuming the kernel/headers pair is already installed with e.g.
sudo pacman -S linux-lts linux-lts-headers
the easy way is:
sudo -E garuda-boot-options
reach the “Boot to” dropdown with TAB key then press SPACE repeatedly until the desired one is selected then ENTER then press TAB repeatedly to reach “Apply” then ENTER or SPACE wait for GRUB update progress then reboot (cleanly, with keyboard shortcut or terminal command).


Hello thank you for the reply.

I’m trying to switch linux68-tkg-bore kernel. It’s installed.

I will try this.

Thanks for the reply. @filo
So if I got that correct the number value next to GRUB_DEFAULT= corresponds to the menu selected ?

Yes, the line, that can be a kernel entry or a submenu. Consider the examples there.
But I realized that sometimes things can be easier via GUI.
I’m getting old :wink:

@meanruse Exactly what i was looking for. Thanks it worked!
@filo Haha. I tried it aswell. Learnt something new today.

Thanks for the help guys!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.