Trouble with system upgrade

After an update with problems I'm using a previous snapshot, now i have this problem:

Should I reinstall the newest Garuda ?


pacman -Qo /usr/bin/deepin-screenshot 

to see which package is owning the current file. Maybe this problem can easily be solved by removing a conflicting packge :slight_smile:

1 Like

pacman -Qo /usr/bin/deepin-screenshot
/usr/bin/deepin-screenshot ist in deepin-screenshot 5.0.0-4 enthalten

Remove either deepin-screenshot or deepin-screen-recorder with sudo pacman -R :slight_smile:


Garuda crashed while updating, i can't import images from smartphone.

Edit: only mouse and time are function

1 Like

Have you tried switching to a tty and trying to perform the upgrade again?

You can always roll back your system at the grub boot screen if needs be.

Deepin is probably the most unstable desktop that Garuda supports.


Like why does deepin-screenshot and deepin-screen-recorder ( Deepin native apps? ) conflict with each other. This shouldnt be happening :sweat_smile:

1 Like

All I can say is it's Deepin, so basically "why ask why" or "it is what it is". :smile:



1 Like

I try now Garuda ultimate with wayland, because no boot was possible anymore : "file missing"


I used the Optimizer to save disk space, perhaps this cause the problem?

Been a while. I believe deepin-screenshot was the package that was used in v15. When it changed to v20 it became deepin-screen-recorder which handles both functions. Why? because Deepin :rofl:


Well that seems completely borked to me. :sweat_smile:

Was it Deepin Ultimate you tried?
Optimizer = Stacer?
Usually there is no need to use any optimizing tool on Linux, relevant things such as cleaning the old pkgcache is done automatically in Garuda :blush:

  1. Yes

Garuda Welcome -> Tools -> System Cleaner
Garuda Welcome -> Tools -> Timeshift - clean up older stuff
Garuda Welcome -> Maintenance -> Clear cache & Clear PKG cache & Refresh mirrors (downloading is lame: 1 MiB/s @ 1 GiB/s )

This you should not have done this

After doing it you need to update grub

1 Like

A post was split to a new topic: Pipewire-pulse and pulseaudio are in conflict