Trouble after upgrade

Recently updated packages with sudo pacman -Syu and after the update
im not able to install any other package, because the new timeshift depended on a new library file which i couldnt find .

timeshift: error while loading shared libraries: libicuuc.so.69: cannot open shared object file: No such file or directory

First of all, I'd try to check which package requires that file:
pacman -Qo libicuuc.so.69
Then I'd try to reinstall that package, maybe it was a partial update...

5 Likes

It's definitely a partial update somewhere along the line. icu was updated to 69 a while ago now, so if the timeshift package is still expecting icu=68 then either it's from the AUR and needs to be rebuilt, or from an out-of-date ChaoticAUR mirror.

8 Likes

Hey,
Thanks for reaching out,
after running sudo pacman -Qo libicuuc.so.69
i got error: No package owns libicuuc.so.69

i tried rebuilding the timeshift package using pamac but to install something
timeshift starts running and runs into the above error stopping the installation :''(
is it possible to install without initiating timeshift.
I hv libicuuc.so.68 in my /usr/lib/

pacman -Qo libicuuc.so.68?

This is possible.
I think the way it works is that pacman has a hook to timeshift-autosnap.
This tool should have a config to disable the script to run.
So the easiest way IMO would be to temporarily disable there.

3 Likes

Can you please post the full output of pacman -Syu (as text)?

4 Likes

You have probably messed up something. The update must have been unsuccessful with some errors, which you should try to remedy before reboot.

Get your current status

  • Last update log from /var/log/pacman.log
  • find /usr/lib/ -name libicuuc.so\*
    Run pacman -Qo for the results (probably icu)
    pacman -Q icu
6 Likes

Easiest way to disable timeshift automatically running is:

sudo SKIP_AUTOSNAP=1 pacman -Syu

7 Likes

If @jonathon is right about the partial update, pacman could be getting held up due to the cache. I've had that happen before.

Please clear the cache and a full sync update

pacman -Sc
pacman -Syyu
4 Likes

You can use a live disk and from there use chroot and then do a proper update. I recommend you to install linux lts kernel as well.

2 Likes

Thank you so much everyone : )
It got fixed
As you said it was a partial update, it stopped after giving a message that packages were invalid or corrupt (This was my mistake, sorry for not mentioning this before )
after updating the keyrings and following the above instructions it got solved
Thank you so much for helping out

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.