Tripping screens


I'm not really sure how to address this issue, I'm gonna try to. Sometimes I experience a tripping screen like the screenshot below. The disturbances are changing if i move my cursor around and it often results in a non-responding laptop. Often it happens with my browser (I have experienced it with chromium and Mozilla Firefox) but it can also happen with other applications on my system.

I can't really figure out what the trigger is. Sometimes I think it happens more often when i have multiple browser windows open or when my system is up for a day or to. But I'm not sure.

Now I am experience this for two months now, I update my system almost every day and tried different kernels.

Do anyone now how to address this issue?

1 Like

Check this out.

Looks a lot like my problem with freezing system:

Also please read this for doing better reports so we can help you better.


This doesn't look IO related, more like it's related to the graphics driver.

Check the link @BrutalBirdie posted above, and at the very least provide full system details (inxi -Fxxxz).


@jonathon this reads like exactly the behavior I had.
When anything did some io r/w and I tried to do anything with KDE my system just froze / tear.

I also thought about a driver problems. That's why I linked Reporting Bugs from the wiki hoping he would read that and report the output of inxi -Fxxxz but you spoiled it! :smiley:

Now he knows :wink: Topic is bookmarked, I wanna know the outcome since I had a similar problem.

  Kernel: 5.11.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
  Desktop: GNOME 3.38.3 tk: GTK 3.24.26 wm: gnome-shell dm: GDM 
  Distro: Garuda Linux 
  Type: Laptop System: SAMSUNG product: 670Z5E v: P05ADG serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: SAMSUNG model: NP670Z5E-X01NL v: SEC_SW_REVISION_1234567890ABCD 
  serial: <filter> UEFI: American Megatrends v: P05ADG.010.140421.SH 
  date: 04/21/2014 
  ID-1: BAT1 charge: 36.5 Wh condition: 36.5/57.5 Wh (63%) volts: 16.7/15.2 
  model: SAMSUNG Electronics SR Real Battery type: Li-ion serial: <filter> 
  status: Full cycles: 1161 
  Device-1: hidpp_battery_7 model: Logitech Wireless Mouse MX Master 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Info: Dual Core model: Intel Core i5-3230M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20753 
  Speed: 2469 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 2469 2: 2481 
  3: 2527 4: 2022 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Samsung Co 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0166 class ID: 0300 
  Device-2: AMD Venus XT [Radeon HD 8870M / R9 M270X/M370X] driver: radeon 
  v: kernel bus ID: 01:00.0 chip ID: 1002:6821 class ID: 0380 
  Device-3: Silicon Motion WebCam SC-10HDP12631N type: USB driver: uvcvideo 
  bus ID: 1-1.4:3 chip ID: 2232:1045 class ID: 0e02 
  Display: wayland server: X.Org compositor: gnome-shell driver: 
  loaded: ati,intel,radeon unloaded: modesetting alternate: fbdev,vesa 
  resolution: 1366x768~60Hz s-dpi: 96 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Samsung Co driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:1e20 class ID: 0403 
  Sound Server: ALSA v: k5.11.2-zen1-1-zen 
  Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel 
  port: e000 bus ID: 02:00.0 chip ID: 8086:088e class ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Samsung Co driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB 
  driver: btusb v: 0.8 bus ID: 2-1.5:3 chip ID: 8087:07da class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Local Storage: total: 238.47 GiB used: 319.66 GiB (134.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 2B6Q scheme: GPT 
  ID-1: / size: 238.17 GiB used: 78.04 GiB (32.8%) fs: btrfs dev: /dev/sda2 
  ID-2: /boot/efi size: 299.4 MiB used: 560 KiB (0.2%) fs: vfat 
  dev: /dev/sda1 
  ID-3: /home size: 238.17 GiB used: 78.04 GiB (32.8%) fs: btrfs 
  dev: /dev/sda2 
  ID-4: /var/log size: 238.17 GiB used: 78.04 GiB (32.8%) fs: btrfs 
  dev: /dev/sda2 
  ID-5: /var/tmp size: 238.17 GiB used: 78.04 GiB (32.8%) fs: btrfs 
  dev: /dev/sda2 
  ID-1: swap-1 type: zram size: 3.88 GiB used: 400 KiB (0.0%) 
  priority: 32767 dev: /dev/zram0 
  ID-2: swap-2 type: zram size: 3.88 GiB used: 512 KiB (0.0%) 
  priority: 32767 dev: /dev/zram1 
  ID-3: swap-3 type: zram size: 3.88 GiB used: 316 KiB (0.0%) 
  priority: 32767 dev: /dev/zram2 
  ID-4: swap-4 type: zram size: 3.88 GiB used: 372 KiB (0.0%) 
  priority: 32767 dev: /dev/zram3 
  System Temperatures: cpu: 48.0 C mobo: 48.0 C gpu: radeon temp: 43.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 277 Uptime: 4h 44m wakeups: 17 Memory: 15.52 GiB 
  used: 4.84 GiB (31.2%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.1.0 Packages: pacman: 1450 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.3.01

No Nvidia GPU.

Could you post the output of:

mhwd -l
My Output
> 0000:24:00.0 (0300:10de:1b06) Display controller nVidia Corporation:
NAME               VERSION          FREEDRIVER           TYPE
video-nvidia-dkms            2020.12.19               false            PCI
video-nvidia-390xx-dkms            2020.12.07               false            PCI
video-linux            2021.02.19                true            PCI
video-modesetting            2020.07.13                true            PCI
video-chaotic-nvidia-dev-dkms-tkg            2020.12.19               false            PCI
video-chaotic-nvidia-dkms-tkg            2020.12.19               false            PCI
video-vesa            2017.03.12                true            PCI
> 0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2020.05.22                true            PCI

> 0000:01:00.0 (0380:1002:6821) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2021.02.19                true            PCI

> 0000:00:02.0 (0300:8086:0166) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2021.02.19                true            PCI
     video-modesetting            2020.07.13                true            PCI
            video-vesa            2017.03.12                true            PCI

For the future put your copy-paste from terminal into tripple quotes ```


My Code here

Also the @discobot provides a very good interactive tutorial for using this forum.
Just send @discobot a message with

@discobot start tutorial

Back to the topic.

Maybe try this:


Hi! To find out what I can do, say @discobot display help.

Im not sure if its the same issue that I had a while back, but try linux-mainline as kernel :face_with_monocle:
5.10/5.11 caused what I would call "tripping screens" for me

1 Like

BTW, for me work best ~~~ :slight_smile:


By clicking on APPLY NEW CONFIGS [..] it did not respond. But when I restarted my laptop my theme has changed, I think it worked. Now I've to wait for the 'tripping screens' or do you know a way to trigger it?

thanks for you advise, I'm new and learning every day.


Is this the latest BIOS update available? If not, update this first before anything else, please. If it is the latest, then please carry on.



It took me some effort to find out.

BIOS version installed: 5 (P05ADG.010.140421.SH)
BIOS version available: 5 (P05ADG)

Unfortunately my 'tripping/ flashing screen' problem is not resolved. I'm almost sure it gets worse if I run multiple applications at the same time, and it becomes less if I close applications.

Troubleshooting requires logs investigation

journalctl -b -p3 --no-hostname --no-pager

Also post /var/log/Xorg.0.log at


To clarify, did you try linux-lts or linux-mainline?


Try a couple of tests like disabling your compositor to see if it resolves. If that corrects things, then you can try switching the settings on your compositor to hopefully find one that works better.

Try restarting plasma from the terminal if this happens to see if the issue resolves temporarily.

You may also want to test linux, linux-zen, linux-rt and linux-hardened.

1 Like

Before I tried the Linux-lts 5.10.21-1 already and then it made no difference. But yesterday I switched back to this Linux-lts and it worked :slight_smile:
Then today I switched back to the 5.11.4-zen1-1-zen because I restarted my laptop and I haven't experience any tripping screens any more.

I do not know what exactly solved my issue, but it something did. Tnx for all the help!

Now I think that I stick to this 5.11.4-zen1-1-zen or do I best to get back to the Linux-lts 5.10.21-1 ?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.