Triple boot Windows & Linux not working

I'm dual booting on my second drive with Arch Linux. I installed Garuda on a new partition and everything worked fine. I managed to boot into Garuda and config everything so I'm happy with it. I thought it would be a good idea to reboot so I did. I was greeted by the Garuda boot loader, however I couldn't see Garuda on the list of OSs. Windows was on there, as was Arch, but Garuda wasn't. This is super weird as I can still get the Garuda boot loader but not the actual OS. Please help, thanks in advance.

Which? :slight_smile:

I think boot repair will help but Garuda grub whit out Garuda is new for me.

and

garuda-orange-welcome-200 :slight_smile:

2 Likes

It depends on several things.
Main question is your system boot scheme, is it a UEFI or a Legacy system?
How did you install and update grub?
Do you have your OSes on the same disk drive, or on different disks (not partitions)?

If you can boot to Archlinux, try to check if updating grub via command line shows Garunda in the list of discovered OSes. You may temporarily make Archlinux the main boot controller for your PC.

Show us the output of

sudo os-prober
sudo inxi -puo
1 Like

Thanks for the welcome haha!
It was only the visual aspects I configured. i.e. kvantum, Latte dock etc.

  • It's legacy
  • I don't know to be honest, I just installed Garuda and that's it...
  • I have two drives in my pc, Windows occupies my C drive, and Garuda and Arch occupy my D drive on separate partitions.
  • What do these commands do?
    Thanks

The results of the command were:
/dev/sda1:Windows 10:Windows:chain

Sudo: inxi: command not found

I suspect Garuda has been installed with a btrfs scheme, while Archlinux does not have grub-btrfs installed. My question is "is it possible Garuda also misses btrfs related packages?".

Maybe one of Garuda devs can help on this troubleshooting, regarding installation with Garuda ISO on Legacy BIOS.

Its weird that inxi was not found as its preinstalled in every edition :thinking:

I don't know.. When I installed it, i used the automatic partition option in the installer... How would I check?

Yeah that's what I was wondering. Afterwards, I tried sudo pacman -S inxi but it didn't work as it couldn't find the packages. How do I solve this problem with Garuda then? Is a reinstall necessary?

I have noticed in the past if there are issues with your video driver installation inxi may sometimes fail to start or throw errors as if it is not installed.

Perhaps for this reason lshw should be considered for inclusion by default.

so I should sudo ishw -puo?

Are you booting to Garuda or Archlinux?

Anyway, post

sudo fdisk -l
lsblk -f
pacman -Qs grub
pacman -Qs btrfs
grep -i cmdline /etc/default/grub
4 Likes

As I've said, I can't boot into Garuda. The results are:

[sudo] password for jakub: 
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: ST3500418AS     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xa30b25ec

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048    104447    102400    50M  7 HPFS/NTFS/exFAT
/dev/sda2          104448 975718106 975613659 465.2G  7 HPFS/NTFS/exFAT
/dev/sda3       975718400 976769023   1050624   513M 27 Hidden NTFS WinRE


Disk /dev/sdb: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: ST500DM002-1BD14
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x1988c566

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdb1            2048 507011071 507009024 241.8G  7 HPFS/NTFS/exFAT
/dev/sdb2       507011072 716726271 209715200   100G 83 Linux
/dev/sdb3       926441472 976773119  50331648    24G 82 Linux swap / Solaris
/dev/sdb4  *    716726272 926441471 209715200   100G 83 Linux

Partition table entries are not in disk order.
> lsblk -f
NAME   FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                                     
├─sda1 ntfs         System Reserved 6EF43DCBF43D95F5                                    
├─sda2 ntfs                         BAA63FC0A63F7C47                                    
└─sda3 ntfs                         42AA3E3FAA3E2FB1                                    
sdb                                                                                     
├─sdb1 ntfs         DANE            06FC646BFC6456C9                                    
├─sdb2 ext4   1.0                   777937bc-2e33-0949-a6f3-8910ab196a23   78.8G    14% /
├─sdb3 swap   1                     9f8ccd4d-8be5-46b3-80a7-261843add55c                [SWAP]
└─sdb4 btrfs                        79e12c6d-10bc-40f7-b33b-d8e31c4fac4b                
sr0  
> pacman -Qs grub
local/grub 2:2.04-8
    GNU GRand Unified Bootloader (2)
> pacman -Qs btrfs
local/btrfs-progs 5.7-1
    Btrfs filesystem utilities
> grep -i cmdline /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"
GRUB_CMDLINE_LINUX=""```

..........

I feel that you "de-configured" something by mistake, which made your system un-bootable.
Grub can recognize and boot btrfs systems, so Archlinux would at least "see" Garuda installation.
Initial Garuda setup was fine, as you have booted at least once.
There is no visible problem with partitioning, regarding grub and btrfs.

I would suggest a re-installation, as it is a new system.

You may want to try remember what system changes in configuration you have done, so you don't repeat a possible mistake again.

3 Likes

I'll reinstall.. However the only thing i changed we things like wallpapers and themes in latte-dock.

1 Like