Treesitter parser in neovim would work as libstdc++.so.6 doesn't exist

Hi,

I have just install Garuda and I was downloading a Neovim distribution:

and when I open a file it outputs

indent-blankline: Failed to load parser: uv_dlopen: libstdc++.so.6: cannot open shared object file: No such fi
le or directory
Error detected while processing BufReadPost Autocommands for "*":
Error executing lua callback: ...s-neovim-unwrapped-0.8.0/share/nvim/runtime/filetype.lua:22: Error executing
lua: ...s-neovim-unwrapped-0.8.0/share/nvim/runtime/filetype.lua:23: Vim(append):Error executing lua callback:
Failed to load parser: uv_dlopen: libstdc++.so.6: cannot open shared object file: No such file or directory
stack traceback:
[C]: in function '_ts_add_language'
...0.8.0/share/nvim/runtime/lua/vim/treesitter/language.lua:36: in function 'require_language'
...nwrapped-0.8.0/share/nvim/runtime/lua/vim/treesitter.lua:38: in function '_create_parser'
...nwrapped-0.8.0/share/nvim/runtime/lua/vim/treesitter.lua:96: in function 'get_parser'
.../start/nvim-treesitter/lua/nvim-treesitter/highlight.lua:161: in function 'start'
.../start/nvim-treesitter/lua/nvim-treesitter/highlight.lua:167: in function 'attach'
...er/start/nvim-treesitter/lua/nvim-treesitter/configs.lua:477: in function 'attach_module'
...er/start/nvim-treesitter/lua/nvim-treesitter/configs.lua:500: in function 'reattach_module'
...er/start/nvim-treesitter/lua/nvim-treesitter/configs.lua:108: in function <...er/start/nvim-treesit
ter/lua/nvim-treesitter/configs.lua:107>
[C]: in function 'nvim_cmd'
...s-neovim-unwrapped-0.8.0/share/nvim/runtime/filetype.lua:23: in function <...s-neovim-unwrapped-0.8
.0/share/nvim/runtime/filetype.lua:22>
[C]: in function 'nvim_buf_call'
...s-neovim-unwrapped-0.8.0/share/nvim/runtime/filetype.lua:22: in function <...s-neovim-unwrapped-0.8
.0/share/nvim/runtime/filetype.lua:11>
stack traceback:
[C]: in function 'nvim_cmd'
...s-neovim-unwrapped-0.8.0/share/nvim/runtime/filetype.lua:23: in function <...s-neovim-unwrapped-0.8
.0/share/nvim/runtime/filetype.lua:22>
[C]: in function 'nvim_buf_call'
...s-neovim-unwrapped-0.8.0/share/nvim/runtime/filetype.lua:22: in function <...s-neovim-unwrapped-0.8
.0/share/nvim/runtime/filetype.lua:11>
stack traceback:
[C]: in function 'nvim_buf_call'
...s-neovim-unwrapped-0.8.0/share/nvim/runtime/filetype.lua:22: in function <...s-neovim-unwrapped-0.8

my garuda-inxi:

System:
Kernel: 6.0.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=484f403a-4af9-4e9b-858e-a5d10f309617 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Dell product: Inspiron 7700 AIO v: N/A
serial: <superuser required> Chassis: type: 13 serial: <superuser required>
Mobo: Dell model: 0MHWCY v: A00 serial: <superuser required> UEFI: Dell
v: 1.15.0 date: 09/05/2022
CPU:
Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
microcode: 0xA4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2565 high: 2800 min/max: 400/4700 scaling:
driver: intel_pstate governor: powersave cores: 1: 2800 2: 2800 3: 927
4: 2800 5: 2800 6: 2800 7: 2800 8: 2800 bogomips: 44851
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
ports: active: HDMI-A-1 empty: HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:9a49
class-ID: 0300
Device-2: NVIDIA GP108M [GeForce MX330] vendor: Dell driver: nouveau
v: kernel non-free: 520.xx+ status: current (as of 2022-10) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s
lanes: 4 link-max: gen: 3 speed: 8 GT/s bus-ID: 02:00.0 chip-ID: 10de:1d16
class-ID: 0302 temp: 46.0 C
Device-3: Realtek Integrated_Webcam_FHD type: USB driver: uvcvideo
bus-ID: 3-5:3 chip-ID: 0bda:5503 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa dri: iris,nouveau gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Dell Inspiron 7700
serial: <filter> built: 2017 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: OpenGL v: 4.6 Mesa 22.2.2 renderer: Mesa Intel Xe Graphics (TGL GT2)
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0403
Sound API: ALSA v: k6.0.7-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:a0f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.4 TiB used: 12.53 GiB (0.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM991 NVMe 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 25305039 temp: 16.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: 02 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Sony model: Storage Media
size: 28.97 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 468.19 GiB size: 468.19 GiB (100.00%)
used: 12.53 GiB (2.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 628 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 468.19 GiB size: 468.19 GiB (100.00%)
used: 12.53 GiB (2.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 468.19 GiB size: 468.19 GiB (100.00%)
used: 12.53 GiB (2.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 468.19 GiB size: 468.19 GiB (100.00%)
used: 12.53 GiB (2.7%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.26 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 47.0 C mobo: 45.0 C gpu: nouveau temp: 46.0 C
Fan Speeds (RPM): cpu: 1381
Info:
Processes: 271 Uptime: 3h 30m wakeups: 11 Memory: 15.26 GiB
used: 3.61 GiB (23.6%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: 1532 pm: nix-default
pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 216 libs: 38 pm: pacman
pkgs: 1316 libs: 347 tools: octopi,pamac,paru Shell: fish v: 3.5.1
default: Zsh v: 5.9 running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-07
Last full system update: 2022-11-07 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

If I ran ls /usr/lib | grep libstd

$ ls /usr/lib | grep libstd

.rw-r--r--  6.4M root 20 Aug 02:12  libstdc++.a
lrwxrwxrwx    19 root 20 Aug 02:12  libstdc++.so -> libstdc++.so.6.0.30
lrwxrwxrwx    19 root 20 Aug 02:12  libstdc++.so.6 -> libstdc++.so.6.0.30
.rwxr-xr-x   19M root 20 Aug 02:12  libstdc++.so.6.0.30
.rw-r--r--  183k root 20 Aug 02:12  libstdc++_libbacktrace.a
.rw-r--r--  793k root 20 Aug 02:12  libstdc++fs.a

I can see that the file exist but the error keeps coming up.
The syntax highlighting in is not fully working.

Sorry for the badly typed question, this is my first time
Thanks.

How did you install Neovim and what version is it?

The guy linked a separate repo, did you try that?

Important Update When I initially created this repo I didn't anticipate the amount of breaking changes, if you'd like to use the same basic config as this one as a base I recommend my new repo: nvim-basic-ide

3 Likes

Additionally, a reboot is due. Sometimes it helps.

2 Likes

Oh I fixed it.

I realised that neovim was install with nix-env package manager.
I uninstalled it and reinstalled it with pacman and it works now.

I used nix-env package manager because it was suppose to be a package manager that works in many different os.

Thanks for the help.

p.s. how to I mark this as resolved

Click on the little checkmark box.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.