Transparency effect for Latte

My Latte dock lost its transparency.

What I did until:
a) Renaming and by that resetting the .config files by hand
b) -Rcns latte-dock and reinstall
c) Looking into the Latte settings.

I see two latte-dock in the repositories.

One in garuda and one in community. I see no repo being used in -Qi, but since garuda is listed above community in the pacman.config, I assume this is used.

2 Likes

0 post your garuda-inxi
1 reboot
2 restore from garuda assistant

garuda-inxi
System:
Kernel: 5.19.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=4b4ec066-54eb-42cb-aa34-33a4ed96d5e1 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=287a963a-2888-4881-a2a8-a7fa19e52387 loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME B550-PLUS v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 0320
date: 05/13/2020
CPU:
Info: model: AMD Ryzen 5 3500X bits: 64 type: MCP arch: Zen 2 gen: 3
built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
desc: 2x16 MiB
Speed (MHz): avg: 3950 min/max: 2200/4521 boost: enabled scaling:
driver: acpi-cpufreq governor: performance cores: 1: 3950 2: 3950 3: 3950
4: 3950 5: 3950 6: 3950 bogomips: 47399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT disabled
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel arch: GCN-4
code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
speed: 8 GT/s lanes: 16 ports: active: DVI-D-1 empty: DP-1, DP-2,
HDMI-A-1, HDMI-A-2 bus-ID: 06:00.0 chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: DVI-D-1 mapped: DVI-D-0 model: MAGIC LCD 222 serial: <filter>
built: 2010 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 480 Graphics (polaris10 LLVM 14.0.6 DRM
3.47 5.19.1-zen1-1-zen) v: 4.6 Mesa 22.1.6 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 3
speed: 8 GT/s lanes: 16 bus-ID: 06:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 08:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.19.1-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 6.01 TiB used: 553.23 GiB (9.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Intenso model: SSD size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 6A0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-75WN4A1 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
rev: 7113 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 850 EVO 250GB
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 1B6Q scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: Intenso model: N/A
size: 223.57 GiB block-size: physical: 512 B logical: 512 B type: SSD
serial: <filter> scheme: GPT
ID-5: /dev/sdf maj-min: 8:80 type: USB vendor: Seagate
model: ST5000LM000-2AN170 size: 4.55 TiB block-size: physical: 4096 B
logical: 512 B type: HDD rpm: 5526 serial: <filter> rev: 1153 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 206.2 GiB size: 206.2 GiB (100.00%) used: 73.55 GiB
(35.7%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
(0.2%) fs: vfat dev: /dev/sdd1 maj-min: 8:49
ID-3: /home raw-size: 206.2 GiB size: 206.2 GiB (100.00%) used: 73.55 GiB
(35.7%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-4: /var/log raw-size: 206.2 GiB size: 206.2 GiB (100.00%) used: 73.55
GiB (35.7%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
ID-5: /var/tmp raw-size: 206.2 GiB size: 206.2 GiB (100.00%) used: 73.55
GiB (35.7%) fs: btrfs dev: /dev/sdd2 maj-min: 8:50
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.52 GiB used: 4.91 GiB (31.6%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 17.07 GiB used: 5.6 MiB (0.0%)
priority: -2 dev: /dev/sdd3 maj-min: 8:51
Sensors:
System Temperatures: cpu: 48.0 C mobo: N/A gpu: amdgpu temp: 55.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1071
Info:
Processes: 333 Uptime: 8d 3h 16m wakeups: 46 Memory: 15.52 GiB used: 7.51
GiB (48.4%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1532 lib: 462 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-07-20
Last full system update: 2022-08-24 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service pacman-filesdb-refresh.service pkgfile-update.service
1 Like

Post if problem is solved

I already did several reboots since the last system update and this problem has occurred already a week ago.

Not today, just restore.
I lost transparency often but after next reboot it work, so ask the developer, wait he stop maintaining latte. So wait for KDE developer.

1 Like

I already did a reboot after you mentioned it. I am a bit hesitant to restore by setting back btrfs, but I guess there is no other choice.

How can it be, that a freshly installed latte with clean config files still shows this behavior?
An incompatibility with an updated part of KDE or so?

Thanks for the help

No, please, restore latte config with garuda-assistant

1 Like

I remember that switching between transparent and opaque didn't work properly on Xorg for me, you can try switching to Wayland to see if things changes.

1 Like

I've had this same problem for a long time: before using latte-dock-git and after moving to garuda/latte-dock. I tried resetting the config with Garuda Assistant before, and also played a little with the configs: both didn´t help. I reboot every day, and aproximately half the times the top panel transparency works, the other half it won´t.

I guess this is an upstream bug.

2 Likes

I had the same issues and it seems to have to do with gpu driver issues.

I solve my driver issues by reinstalling all my driver packages since my blender didn't work as well.
(I need HIP for AMD GPU's on blender).
After I solved all those issues and blender was running properly it also resolved the issue with the transparency which is rooted in the compositor.
Reset the compositor b/c it will turn down features if it recognizes driver issues or driver related issues (which can pseudo-appear due to updates).

Hence: Check your compositor and reset it :slight_smile: It solved my transparency issue with Garuda and Docker

All the best,

Bruce :shark:

P.S.: I'm currently rendering a short little abstract animation with the Garuda logo :smiley:

5 Likes

If you mean with "compositor" the setting in KDE, which allows you to switch between OpenGL2, OpenGL3 and XRender: That setting is gone. They removed it a few versions ago

Done

(After restoration with Garuda Assistent)

1 Like

Nope,
1. you need to do a right click on your desktop background
2. and click on screen settings.
3. Choose compositor and then on the bottom of the window
you might get an information box which tells you that the compositor has deactivated some functions b/c it has detected issues. (This also counts if you have tearing issues additionally to transparency issues). But it isn't necessary to restore the compositor as I'll show you now:

Deactivate compositing click apply and then activate compositing and click apply.
You also can check your vsync and scaling methods if you want to. If satisfied click apply and restart.

There is no option about any render API.

Example Window (I use german btw but you might recognize the window anyways by design):

It solved my transparency issue :smiley:

3 Likes

This solved it for me. It seems, it was a driver issue. I guess it would make sense to put a notification about that in the KDE notifications. There is one for lots of pretty minimal cases, why not one for such a significant one. Getting this to KDE bugs, thanks a ton.

Screenshot_75

2 Likes

I'm pretty happy this worked out for you and I'm super glad I could help!

True, that little information box definitely needs to be in the notifications!
I was annoyed it isn't myself!
Yep getting it to the KDE bugs you'd help a ton of ppl with that issue!

Have a great day :slight_smile:

Bruce :shark:

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.