TP Link Archer AC1300 (T4U) Driver installation

Hi,

Happy New Year to Everyone in the Garuda Linux Community!

I am new to linux and CLI. I am not able to find instructions on how to install network drivers for the TP Link's Archer AC1300. The support documents have instructions only for certain distributions of linux (couldn't find Arch linux in there).

Here is the link to the product page: Click Here

And here is the Support documents link (TP Link website): Click Here

I do have a native WiFi card on my laptop which was recognized and works flawlessly out of the box, but it's slow. I want to use the TP Link wireless adapter as it offers better range and speeds. On Windows 10, it's recognized as soon as I plug it in and am able to select which wifi card I want to use. ( Ihad windows 10 previously installed on this machine; and no, I don't have dual boot; Garuda Linux is the only OS I am using.)

I tried to use these instructions to see if the wireless adapter is recognized. No, it wasn't showing up.

ksnip_20210101-023334

Let me know if you need more information.

2 Likes

Welcome to Garuda and happy new year as well.

Try running this command, then post:

hwinfo --netcard --bluetooth | grep -Ei "(speed|hotplug|model|status|cmd|file|detected|driver:)" | grep -v "Config S"  

Try not to have alternate wireless connections attached when that command is run (or phone tethering, & other wireless dongles).

3 Likes

Hi,

Here are the results:

 Model: "Intel Centrino Wireless-N 1000 BGN"
      Driver: "iwlwifi"
      Device File: wlp3s0
      Link detected: yes
        Driver Status: iwlwifi is active
        Driver Activation Cmd: "modprobe iwlwifi"
      Model: "Lenovo ThinkPad T520"
      Driver: "e1000e"
      Device File: enp0s25
      Link detected: no
        Driver Status: e1000e is active
        Driver Activation Cmd: "modprobe e1000e"

So then, I assume this information is about your older internal Intel wifi adapter. Can you disable this internal adapter in your bios? If so, I would download and install the proper driver and an older LTS kernel and then disable the internal adapter via the bios (if possible).

Download and install an older LTS kernel:

sudo pacman -Syu linux-lts linux-lts-headers

After the updates and the LTS kernel is installed reboot.

At the advanced grub boot screen switch to the LTS kernel.

Once booted into the LTS kernel install this driver from the AUR:

https://aur.archlinux.org/packages/rtl88x2bu-dkms-git

Be sure to read all recent comments on the driver's AUR webpage.

You can either use an AUR helper or pamac to install the driver.

If you use pamac you may need to enable the AUR from pamac's preferences/options.

Install the driver, then reboot. If the adapter is still not working post:

inxi -Fxxxza
lsusb | grep -Ei "(rtl|wl|adapter)"
lsmod | sort
rfkill list
sudo dmesg  | grep -Ei "(error|fail|firm|regdom|cfg80211|alpha2|wmi|wl|80211|deauth|rtl88*)" | grep -viE "(acpi|ras|nvidia|*faillock|eth)"
grep -r "blacklist\|install\|options"  /etc/modprobe.d/ /etc/modules-load.d/ /usr/lib/modprobe.d/ 
3 Likes

pls use pamac and search t4u then you must build the driver
its an aur package so you must enable it before
hope it helps

tbg: Thank you for all the help, I really appreciate it. Being relatively new to Linux and that too Arch, I'm going to refrain myself from going through the pains of making the AC1300 work. I was hoping it would be much easier TBH. I'll revisit this 'project', which it is now, at later date. Also, I need to do some reading on What GRUB is.

@anon4516988, That driver is listed as out of date. It may work on the LTS kernel, but I would try the one I recommended first.

This is really no big deal. I asked you to install the lts kernel because it is more likely to work with your driver. However that may not be required. You should always have a fallback kernel installed regardless.

The kernel and driver install is all of 5 minutes work. Its really not a big deal.

3 Likes

https://wiki.archlinux.org/index.php/GRUB

But if your system boot read later :wink:

More interesting is maybe pacman :slight_smile:

https://wiki.archlinux.org/index.php/Pacman

2 Likes

I was able to install the LTS kernel and booted into it. Need some help to build the driver.

I ran the git clone command. What are the next steps?

Here are the contents of the folder:

    ~/S/D/T/RTL88x2BU-Linux-Driver  on   master 
❯ ls                                                    100%   65 Mbps  ─╯
clean      hal          include  Makefile  README.md         runwpa
core       halmac.mk    Kconfig  os_dep    ReleaseNotes.pdf  wlan0dhcp
dkms.conf  ifcfg-wlan0  LICENSE  platform  rtl8822b.mk

    ~/S/D/T/RTL88x2BU-Linux-Driver  on   master 
❯                                                       100%   65 Mbps  ─╯

No, do not use git clone.

Use:

pamac build rtl88x2bu-dkms-git

Reboot after it's built.

3 Likes

It worked! Thank you so much! Wow! am I so glad! :smiley:

Happy to report that it works in the default (non-lts) kernelas well; phew!

1 Like

Very nicely done, glad I could help, and you're welcome.

Again, welcome to the forum, and have a Happy New Year.

3 Likes

means that you can build it under new kernel

maybe important and useful for others

i'm glad to hear that it is solved

2 Likes

Ah, I see. Had that not been the case, my next question would be, how to change the default kernel to the lts one. :smiley:

Search forum or web.

1.000.000.000 times asked and answered :smiley: