Touchpad scrolling in KDE reverting to default

Output of garuda-inxi at the end.

I set up edge scrolling on my touchpad (as oppossed to the default two-finger scrolling). Every so often the setting reverts back to the default. The strange thing is that when I go back to the setting I see the "Touchpad Edges" option is selected, but the machine behaves as if "Two fingers" were selected. I tried selecting "Two fingers" and clicking apply, then selecting "Touchpad Edges" and clicking apply, but nothing happens. I'm not sure what triggers the reversal; this time it happened after booting up my computer. And I'm not sure what "fixes" it and switches back to the actual selection ("Touchpad Edges"). I tried rebooting but that didn't fix it either. This is not the first time it has happened; in previous times the problem just "fixed" itself at some point but it's a recurring problem.

[:mag:] × garuda-inxi
System:
Kernel: 6.2.11-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=c5880357-769f-4d8f-a77f-611b7a01dd58 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Latitude 6430U v: 01
serial: Chassis: type: 9 serial:
Mobo: Dell model: 0V4GYG v: A00 serial: BIOS: Dell
v: A03 date: 12/03/2012
Battery:
ID-1: BAT0 charge: 3.3 Wh (9.4%) condition: 35.2/62.2 Wh (56.6%) volts: 10.5
min: 11.1 model: Samsung SDI DELL P70V52C type: Li-ion serial:
status: discharging
Device-1: wacom_battery_0 model: Wacom Intuos PT S 2 serial: N/A
charge: 100% status: full
CPU:
Info: model: Intel Core i7-3667U bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1994 min/max: 800/3200 scaling: driver: intel_cpufreq
governor: schedutil cores: 1: 1994 2: 1994 3: 1994 4: 1994 bogomips: 19936
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: Sunplus Innovation Integrated Webcam type: USB driver: uvcvideo
bus-ID: 1-1.5:4 chip-ID: 1bcf:289b class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: LVDS-1 model: BOE Display 0x05f6 built: 2013 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.2 Mesa 23.0.2 renderer: Mesa Intel HD Graphics 4000 (IVB
GT2) direct-render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
API: ALSA v: k6.2.11-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.69 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
IF: eno1 state: down mac:
Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:422b
class-ID: 0280
IF: wlp2s0 state: up mac:
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: f060 bus-ID: 00:1f.2 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
Local Storage: total: 268.2 GiB used: 34.09 GiB (12.7%)
ID-1: /dev/mmcblk0 maj-min: 179:0 model: SB32G size: 29.72 GiB block-size:
physical: 512 B logical: 512 B type: SSD serial: scheme: MBR
SMART Message: Unknown smartctl error. Unable to generate data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/sda maj-min: 8:0 vendor: LITE-ON IT model: LMT-256M6M-41 mSATA
256GB SED size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: rev: 10F scheme: MBR
Partition:
ID-1: / raw-size: 154.4 GiB size: 154.4 GiB (100.00%)
used: 34.09 GiB (22.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /home raw-size: 154.4 GiB size: 154.4 GiB (100.00%)
used: 34.09 GiB (22.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-3: /var/log raw-size: 154.4 GiB size: 154.4 GiB (100.00%)
used: 34.09 GiB (22.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/tmp raw-size: 154.4 GiB size: 154.4 GiB (100.00%)
used: 34.09 GiB (22.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.63 GiB used: 591.5 MiB (7.6%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 85.0 C mobo: 66.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 7021
Info:
Processes: 221 Uptime: 39m wakeups: 3 Memory: 7.63 GiB
used: 3.89 GiB (50.9%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: 1489 pm: pacman pkgs: 1483
libs: 383 tools: octopi,pamac,paru,yay pm: flatpak pkgs: 6 Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
Garuda (2.6.16-1):
System install date: 2023-04-11
Last full system update: 2023-04-20
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut
Windows dual boot:
Failed units: