Tor Browser does not load many pages after update (whattaa?)

So after an update Tor Browser weirdly became dysfunctional. How can this be? This Tor Browser is even on the different physical drive than Garuda. Tried re-downloading the Tor Browser from the official site, unpacked, still the same. Tried even another internet connection.

On my other machines Tor Browser work normally. The issue is, that the Tor Browser starts properly and i can go to pages, but for example Protonmail's login page just keeps loading infinitely. This, again, does NOT happen in this house holds other computers: Tor Browser works as expected, and also on Protonmail.

How on earth can Garuda affect on this totally separate folder and program of the system?

I can't imagine Garuda blocking or changing anything but wrong Categories.


The recent update to glibc 2.33 has created a number of issues with software that has a sandbox function (including e.g. containers on older distributions):

The needs a fix from the Tor Browser developers.


Oh i see, so on to waiting that update from the Tor Browser devs. By the way if some one else bumps into this issue: i downloaded the latest Alpha build of Tor Browser (10.5a8) and through that all worked as expected!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.