Top menu vanishing when setting window to fullscreen on second monitor

Hi,

my Garuda installation is still fresh, and here's one of the issues I have.

I have two identical 1080p 144Hz monitors, and I extend the first to the second (second one is 0+1920 from the first one). Having any application on the first monitor maximized plugs the top bar and buttons of the window into the dock at the top, so I can normalize, minimize and close from there.

Dragging any (almost any) window to the second monitor and maximizing it there, the top bar disappears, as if there was a dock where the top bar docks. For some applications it's still possible to normalize them (Firefox can be dragged on its menu bar, Lutris doesn't lose its top bar), however, most applications cannot be normalized or closed in the usual fashion, as the top bar buttons are lost.

Now, I have read that a workaround would be to add a dock similar to the one from the first monitor to the second. I understand that could work, but does currently not. Going into "Edit panel" from the context menu of the top dock on the first monitor and selecting anything from the monitor list, the whole configuration crashes/disappears, the windows are still there, but all controls disappear and it's not usable anymore.

A better version/solution would be to not remove the top bar from windows being maximized when there is no top bar to plug the functionality (close, normalize, minimize) into. Is there a realistic way to get this version to work?

I don't even know which configuration I would need to check, which system/application is responsible for that behavior.

You should know that actually this is not what is happening.
It just removes the window title bar. Latte top panel includes relevant applets/widgets (buttons, title) that provide those functions.

Not a workaround, it's how it's done officially.

Just copy the top panel. It will automatically go to the next monitor without a panel.
Y0222_001

3 Likes

You can hopefully see how I get to "plug into the top bar". As the top bar doesn't contain maximize, minimize and normalize buttons when there is no fullscreen window on the top, there's clearly more going on than just removing the bar from the top of the window.

Not for me. Right-clicking the top panel, opening the bottom left menu and choosing "Copy panel" it goes to the left of the first monitor.

Outside of the monitor? That's awesome!! It got out of the system!

If you have more monitors, shouldn't you say so?
Or explain in a way a person that isn't in your room/site could understand, please.

I have two monitors: DP-2 is the left one, DP-0 is the right one. DP-2 is my primary monitor in a way that on the left monitor I have the top latte bar (Garuda symbol, menu bar File/Edit and so on), and the monitor is selected as "Primary" in the Display settings configuration. My second monitor, DP-0 is to the right of that one.

This is the configuration in the settings dialog:

I have this bar on the left monitor on the top:

If I right click it and "Edit panel" and in the left bottom menu where it says "New Dock" I open the options and choose "Copy panel", this is the menu that appears on the left side of my first monitor:

If I now right click the new panel that is on the left of my primary monitor and instead of the pre-selected "Follow primary monitor" mode I choose "DP-0" (my second monitor), the dialog stops working and looks like this:

Thank you for taking the time to look into my problem.

This seems like a bug in Latte, or a configuration/cache problem.
You could change Latte layout to one not used at the moment to see if it can be used correctly.
If it's not a great loss (but you may save a backup), delete Rename Latte (local home) settings and start new, with both monitors active:

mv $HOME/.config/lattedockrc $HOME/.config/lattedockrc.old
mv $HOME/.config/latte $HOME/.config/latte.old

After renaming, start Latte from kRunner (Alt+F2).


It could be a bug.
Post your Latte version.

1 Like

Latte-Dock version:

 ╭─dromundkaas@pure in ~/.local/share/Steam/steamapps/compatdata/22330/pfx/drive_c/users/steamuser/My Documents/my games/oblivion took 15s
 ╰─λ latte-dock --version
Icon theme "papirus" not found.
Icon theme "tela" not found.
Icon theme "adwaita" not found.
Icon theme "gnome" not found.
Icon theme "ubuntu-mono" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
lattedock 0.9.86

Left the "not found" messages in, in case they're important.

I've tried changing from Dragonized layout to Garuda and tested it, the same problem when moving to the second display, and the same result when copying (appears on the left monitor on the left side).

I've renamed the config directories as you suggested, then used Alt+F2 to start "latte" (shows up as "Latte Dock" in the suggestion popup). That makes the top bar disappear completely.

I've reversed the renaming and restarted latte-dock (with --replace), and I have my top bar back.

I suggest you install stable latte-dock from arch repos (not the -git version from chaotic/AUR) and see if it works better.

I have employed a workaround for this problem, so the issue is resolved. Thank you for your help.

Don't let the community die uninformed.

5 Likes

I left it intentionally vague, my finding is that Garuda is not yet ready for the spotlight/my daily driver, so I'm testing another distribution.

Looks like the same issue I've been having. I know you are using a different distro now, but it is a latte-dock specific issue on the current git repository.

I've made an issue on the Latte-dock gitlab page:

I still haven't gotten a response.
In the meantime, I've just downgraded the package. Unfortunately, the stable package on the Arch Repo is pretty old(11/04/2020 or 04/11/2020 in American format). I guess there hasn't been a "stable" release in a while.

4 Likes

Very well done, this is how things get fixed :slight_smile:

4 Likes

The same when some say it is still a young distribution.

Garuda is based on long proven and continuously maintained arch based software.

If there are problems they will be solved :slight_smile: :wink:

3 Likes

Michail Vourlakos just added a commit that should fix this bug!

I resubmitted the issue with the KDE bug tracker and he got back to it much quicker.
He's got a really impressive work ethic, he does several commits per day consistently.

It looks like he is in the midst of his commits right now and the package on the Chaotic-AUR is not fully up to date yet.
Once he's done with commits for the day and the Chaotic-AUR is updated, I think I'll give it a shot!

Edit: Gave it a shot and it worked! The only potential problem is that it looks like the "copy" function is missing. I let him know, perhaps it has been moved to another part of the interface and I am just unaware.

3 Likes

Complaining on the distribution forum rarely accomplishes getting bugs resolved with third party software. This is not the way Linux works.

This is the way responsible Linux users get things resolved with a bug in software from an upstream project. Kudos to you @ThePoorPilot .

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.