Timeshift problem - can't delete snapshots

Timeshift problem - can't delete snapshots

So some time ago I hade some boot problems , I solved them but I think I created some files that should not have touched and now I have this message on updates:

------------------------------------------------------------------------------
Removing snapshot: 2021-04-23_18-00-02
E: Failed to delete directory: /run/timeshift/backup/timeshift-btrfs/snapshots/2021-04-23_18-00-02
E: 
E: rm: cannot remove '/run/timeshift/backup/timeshift-btrfs/snapshots/2021-04-23_18-00-02/@/etc/resolv.conf': Operation not permitted

E: Failed to remove snapshot: 2021-04-23_18-00-02
------------------------------------------------------------------------------

This is repeated multiples times for varius snapshots and it is always the same file, resolv.conf.

How can I fix this?

Thx for the help and thanks for the Garuda team for making this amazing distro. :heart:

System Info
System:    Kernel: 5.12.13-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a019a97b-523d-419c-bc13-9ba65f07bdd9 rw 
           [email protected] loglevel=3 quiet 
           Desktop: KDE Plasma 5.22.2 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 15s-eq1xxx v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 8707 v: 37.18 serial: <filter> UEFI: AMI v: F.22 date: 07/03/2020 
Battery:   ID-1: BAT0 charge: 33.0 Wh (85.1%) condition: 38.8/38.8 Wh (100.0%) volts: 11.9 min: 11.3 
           model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Discharging cycles: 349 
CPU:       Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP arch: Zen 2 family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600104 cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31939 
           Speed: 1397 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 
           6: 1397 7: 1397 8: 1397 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Hewlett-Packard driver: amdgpu v: kernel bus-ID: 03:00.0 
           chip-ID: 1002:1636 class-ID: 0300 
           Device-2: Luxvisions Innotech Limited HP TrueVision HD Camera type: USB driver: uvcvideo bus-ID: 1-3:2 
           chip-ID: 30c9:0013 class-ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.12.13-zen1-2-zen LLVM 12.0.0) v: 4.6 Mesa 21.1.3 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 03:00.1 
           chip-ID: 1002:1637 class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480 
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.13-zen1-2-zen running: yes 
           Sound Server-2: JACK v: 1.9.18 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.31 running: yes 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard driver: rtw_8822ce 
           v: N/A modules: rtw88_8822ce port: f000 bus-ID: 01:00.0 chip-ID: 10ec:c822 class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
           IF-ID-2: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 0bda:b00c class-ID: e001 
           serial: <filter> 
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: no 
           address: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 287.02 GiB (60.2%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730 SDBPNTY-512G-1006 size: 476.94 GiB 
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: HPS2 
           scheme: GPT 
Partition: ID-1: / raw-size: 290.86 GiB size: 290.86 GiB (100.00%) used: 286.98 GiB (98.7%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 39.1 MiB (13.1%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 290.86 GiB size: 290.86 GiB (100.00%) used: 286.98 GiB (98.7%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-4: /var/log raw-size: 290.86 GiB size: 290.86 GiB (100.00%) used: 286.98 GiB (98.7%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-5: /var/tmp raw-size: 290.86 GiB size: 290.86 GiB (100.00%) used: 286.98 GiB (98.7%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.39 GiB used: 201.7 MiB (14.2%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.39 GiB used: 196 MiB (13.8%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.39 GiB used: 199 MiB (14.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.39 GiB used: 195.5 MiB (13.7%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.39 GiB used: 200.7 MiB (14.1%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.39 GiB used: 196.5 MiB (13.8%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.39 GiB used: 200.2 MiB (14.1%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.39 GiB used: 196.4 MiB (13.8%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 54.5 C mobo: 53.0 C gpu: amdgpu temp: 54.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 316 Uptime: 13m wakeups: 1231 Memory: 11.12 GiB used: 4.32 GiB (38.9%) Init: systemd v: 248 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 2158 lib: 544 flatpak: 0 Shell: Zsh v: 5.8 
           running-in: konsole inxi: 3.3.04 

You need root privileges. How did you try removing the snapshot?

4 Likes

it is done automatically with the pacman hook so i suppose that it already has root privileges

Ahem, ahem. Don't you normally run pacman with root privileges? :eyes:

1 Like

If you've solved your boot problems and can now boot again into garuda, are you not able to remove older snapshots using the timeshift gui?

3 Likes

If nothing else works, you could try with the manual deletions here, but be very careful..
https://bbs.archlinux.org/viewtopic.php?id=266965

5 Likes

its not working as it should

error message
------------------------------------------------------------------------------
Removing snapshot: 2021-07-03_09-23-57
Deleting subvolume: @ (Id:944)
E: ERROR: Could not destroy subvolume/snapshot: Directory not empty

E: Failed to delete snapshot subvolume: '/run/timeshift/backup/timeshift-btrfs/snapshots/2021-07-03_09-23-57/@'
E: Failed to remove snapshot: 2021-07-03_09-23-57
------------------------------------------------------------------------------

thx, this did the job

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.