Timeshift: Can't Restore from Snapshots

My timeshift finds the partition and the snapshots but does nothing , i tried also the snapshots from grub and it's the same doen't restore other version also tried from Live Garuda KDE with the same result i upload a screenshot of timeshift and my logs also

I am probably not going to download a compressed file from "zippyshare" to view the logs.

However, I would ask how you are testing to validate if your snapshots are being restored or not.

Timeshift is probably only restoring the root partition so changes made to user config in your home directory may not change.

4 Likes

once you boot into a snapshot you need then to chose and restore it
?

2 Likes

I am assuming you came to this conclusion by trying to restore a deleted personal file.
TImeshift doesn't restore your files in the home directory. You need to explicitly specify it to do that, by default it will just backup the really really essential stuff.

no i use it to restore to previous upgrade like i did days before it was broken when i had an issue with Latte-Dock ,after that and much search with it i used the "Downgrade" command to go back to Latte Version 0.9.12 and 2 days ago i tried some changes to the theme but i couldn't restore the original "Splash Screen" of Garuda so i tried with the Timeshift , it says done but not change happen after reboot also tried restoring to previous snapshot from grub and from live USB garuda , same result , can't find what prohibits the Timeshift to complete the restore... and every time i boot the pc after entering password etc. it loads timeshift like i presume to inform me with this way that it didn't succeed and also the "Browse" button and the "view timeshift log" not working

From my mega drive if its more "safe" for you but the previously server i use it cause it hasn't any pop ups and redirections...

Config files in $HOME are not backed up by default with timeshift (only root config files are).

3 Likes

Latte config files files are stored in the .config directory in the home sub volume, which isn't backed up.

No its not "safe" no person in the right mind will download a file containing god knows what off a random dude on the internet, please try to understand none of us can take such a risk, if you were in place of him or us would you download a unknown file?I dont question your intents, Most probably the file is safe but its not worth the risk

2 Likes

I agree, thats bad practice. If its a text file our Privatebin would be the more appropriate place to share :wink:

2 Likes

Its the log files of Timeshift ... How should i upload them then? I don't know witch one will be useful for anyone to understand what is wrong so i upload them all ...

The problem is that a zip file could possibly contain anything - this most likely how most peoples systems are getting infected by random malware. You can most likely extract *.log files from the archive - those can be uploaded to a pastebin service then (eg. our already mentioned PrivateBin) and the link will be posted here :slight_smile:

Ok i can do that but there are too much lines...

i paste 2 files the one is restore.log and the other is gui.log

If a specific file needed just ask i have backed up all the logs from a day before until 10 of August

Maybe a mounted drive inside your $HOME folder, or an mounted NTFS partition with incompatible file-names.

Failed to mount device '/dev/sdc1' 
Failed to read cron tab

Have you configured Timeshift to backup $HOME as well?
Try again a timeshift snapshot, after unmounting all non-system mounts/partitions.

4 Likes

I have see that and umount the drives and tried again with no luck all of that before contact the forum , executed from terminal the timeshift and it didn't give any error but again on reboot it didn't restored a thing and every time i reboot there is the timeshift screen again ... The way i check if it didn't work is by the kernel cause the last snapshot i restore from has the zen 5.13.8 and i have now the 5.13.9 and no i didn't select the $HOME to be backed up .

And also here i umount all the drives attached to my system and tried to restore again here is the restore.log :

I think we have a language problem. I am not really sure I understand what you are doing and how you explain about failing to restore etc.

Please,...:

  1. Read carefully and slowlly how restoring snapshots is suggested to be done.
    Restoring System Back To Working State | Garuda Linux wiki
  2. Open your terminal and run these commands and post the output here.
uname -a
cat /proc/cmdline
checkupdates | wc -l
  1. Then run
sudo timeshift --restore
  1. Select an old snapshot and after the command is fully finished/exited, copy all terminal output (including the issued command, up to the last line) and save it in a log file. (if the program automatically reboots, it's OK. Just inform us.)
  2. Reboot and at grub menu, make sure you select the default option for Garuda.
  3. Login and post the output of these
uname -a
cat /proc/cmdline
checkupdates | wc -l
3 Likes

Ok i Successfully restored one older snapshot so clearly something wasn't ok with my last one , thanks anyway for your time , problem solved!

How?
What was the solution?
You can admit and explain what you had done wrong, helping other users not do the same.
Unless you care only for yourself :face_with_raised_eyebrow:

3 Likes

I didn't do anything wrong maybe the snapshot i was trying to restore was corrupted , i tried another snapshot (older) from last month and it worked... The only issue i still have is with the timeshift running when i start Garuda... also is there anyway to mark this post as solved? or some admin does? i see only the solution tick that i pressing every time i solve or is solved some post

Read manual,

you must restore the working snapshot with timeshift after boot,
to be save after that do

sudo update-grub

It must be also a pop-up about.

2 Likes