Time not syncing

I am dualbooting windows and garuda. On windows the time works perfectly after I set it to use UTC as this archwiki page suggests System time - ArchWiki
but on garuda the system time is behind I have enabaled ntp but the time is not syncing as you can see here

[sudo] password for zany130:
               Local time: Thu 2021-09-02 14:12:17 EDT
           Universal time: Thu 2021-09-02 18:12:17 UTC
                 RTC time: Thu 2021-09-02 18:12:17
                Time zone: America/New_York (EDT, -0400)
System clock synchronized: no
              NTP service: active
          RTC in local TZ: no

checking the systemd timesync unit shows this

systemctl status systemd-timesyncd.service
● systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2021-09-02 14:05:10 EDT; 11min ago
       Docs: man:systemd-timesyncd.service(8)
   Main PID: 313160 (systemd-timesyn)
     Status: "Daemon is running"
      Tasks: 1 (limit: 19031)
     Memory: 1.1M
        CPU: 76ms
     CGroup: /system.slice/systemd-timesyncd.service
             └─313160 /usr/lib/systemd/systemd-timesyncd

Sep 02 14:05:10 Kiseki systemd[1]: Starting Network Time Synchronization...
Sep 02 14:05:10 Kiseki systemd[1]: Started Network Time Synchronization.

so I don't know what could be the problem.

inxi -Faz
System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=ef15347e-a4da-4628-afc3-2bff20cbb710 rw
           [email protected] quiet nvidia-drm.modeset=1 splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=e7745511-30a0-4b3d-93c1-4bc3daa8b2b8 loglevel=3
           sysrq_always_enabled=1
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: X470 Taichi serial: <filter> UEFI: American Megatrends v: P3.50 date: 07/18/2019
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3 serial: <filter>
           charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2
           microcode: 800820D cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86396
           Speed: 4029 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 4029 2: 4040 3: 4050 4: 4048 5: 4050
           6: 4027 7: 4030 8: 4027 9: 4040 10: 4045 11: 4049 12: 4047
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia v: 470.63.01
           alternate: nouveau,nvidia_drm bus-ID: 0e:00.0 chip-ID: 10de:1b80 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 6400x2160 s-dpi: 102 s-size: 1594x543mm (62.8x21.4") s-diag: 1684mm (66.3")
           Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 52 size: 1872x1053mm (73.7x41.5") diag: 2148mm (84.6")
           Monitor-2: DP-0 res: 2560x1080 dpi: 81 size: 798x334mm (31.4x13.1") diag: 865mm (34.1")
           OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 0e:00.1
           chip-ID: 10de:10f0 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.34 running: yes
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: e000 bus-ID: 08:00.0
           chip-ID: 8086:24fb class-ID: 0280
           IF: wlp8s0 state: down mac: <filter>
           Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: d000 bus-ID: 0a:00.0
           chip-ID: 8086:1539 class-ID: 0200
           IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:6 chip-ID: 8087:0aa7
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.27 TiB used: 453.17 GiB (19.5%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 43.9 C
           scheme: GPT
           ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 3B7QCXE7 temp: 28.9 C
           scheme: GPT
           ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164 size: 1.82 TiB block-size: physical: 4096 B
           logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
Partition: ID-1: / raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 85.16 GiB (39.5%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:7
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 563 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:6
           ID-3: /home raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 85.16 GiB (39.5%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:7
           ID-4: /var/log raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 85.16 GiB (39.5%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:7
           ID-5: /var/tmp raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 85.16 GiB (39.5%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:8
           ID-2: swap-2 type: zram size: 15.55 GiB used: 2.36 GiB (15.2%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 54.2 C mobo: 36.0 C gpu: nvidia temp: 50 C
           Fan Speeds (RPM): fan-1: 0 fan-2: 1254 fan-3: 1248 fan-4: 1249 fan-5: 1225 gpu: nvidia fan: 24%
           Power: 12v: N/A 5v: N/A 3.3v: 3.28 vbat: 3.28
Info:      Processes: 496 Uptime: 1h 0m wakeups: 3 Memory: 15.55 GiB used: 9.69 GiB (62.3%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 2098 note: see --pkg apt: 0 pacman: 2093 lib: 551
           flatpak: 5 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: alacritty inxi: 3.3.06

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Could you please try with
systemctl restart systemd-networkd?
Ref
https://wiki.archlinux.org/title/Systemd-timesyncd

1 Like

Tried no luck

Maybe the suggested troubleshooting there?
https://wiki.archlinux.org/title/Systemd-timesyncd#Dynamically_set_NTP_servers_received_via_DHCP

still not showing the right time even tried rebooting

Maybe you could try with a /etc/systemd/timesyncd.conf set-up. e.g. (just copying from the wiki above)

[Time]
NTP=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
FallbackNTP=0.pool.ntp.org 1.pool.ntp.org 0.fr.pool.ntp.org

well by default it looks like this

╰─λ sudo cat /etc/systemd/timesyncd.conf.bak
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it under the
#  terms of the GNU Lesser General Public License as published by the Free
#  Software Foundation; either version 2.1 of the License, or (at your option)
#  any later version.
#
# Entries in this file show the compile time defaults. Local configuration
# should be created by either modifying this file, or by creating "drop-ins" in
# the timesyncd.conf.d/ subdirectory. The latter is generally recommended.
# Defaults can be restored by simply deleting this file and all drop-ins.
#
# See timesyncd.conf(5) for details.

[Time]
#NTP=
#FallbackNTP=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
#RootDistanceMaxSec=5
#PollIntervalMinSec=32
#PollIntervalMaxSec=2048

which according to the wiki is how its supposed to be by default

I tried changing it to this

 ╰─λ sudo cat /etc/systemd/timesyncd.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it under the
#  terms of the GNU Lesser General Public License as published by the Free
#  Software Foundation; either version 2.1 of the License, or (at your option)
#  any later version.
#
# Entries in this file show the compile time defaults. Local configuration
# should be created by either modifying this file, or by creating "drop-ins" in
# the timesyncd.conf.d/ subdirectory. The latter is generally recommended.
# Defaults can be restored by simply deleting this file and all drop-ins.
#
# See timesyncd.conf(5) for details.

[Time]
NTP=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
FallbackNTP=0.pool.ntp.org 1.pool.ntp.org 0.fr.pool.ntp.org
RootDistanceMaxSec=5
PollIntervalMinSec=32
PollIntervalMaxSec=2048

with no luck

some interesting things I found

● systemd-networkd.service - Network Configuration
     Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2021-09-03 08:02:48 EDT; 3s ago
TriggeredBy: ● systemd-networkd.socket
       Docs: man:systemd-networkd.service(8)
   Main PID: 19546 (systemd-network)
     Status: "Processing requests..."
      Tasks: 1 (limit: 19031)
     Memory: 1.3M
        CPU: 39ms
     CGroup: /system.slice/systemd-networkd.service
             └─19546 /usr/lib/systemd/systemd-networkd

Sep 03 08:02:48 Kiseki systemd-networkd[19546]: enp10s0: Link UP
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: enp10s0: Gained carrier
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: anbox0: netdev ready
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: anbox0: Link UP
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: lo: Link UP
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: lo: Gained carrier
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: enp10s0: Gained IPv6LL
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: Enumeration completed
Sep 03 08:02:48 Kiseki systemd[1]: Started Network Configuration.
Sep 03 08:02:48 Kiseki systemd-networkd[19546]: anbox0: netdev exists, using existing without changing its parameters

● systemd-timedated.service - Time & Date Service
     Loaded: loaded (/usr/lib/systemd/system/systemd-timedated.service; static)
     Active: active (running) since Fri 2021-09-03 08:02:48 EDT; 3s ago
       Docs: man:systemd-timedated.service(8)
             man:localtime(5)
             man:org.freedesktop.timedate1(5)
   Main PID: 19547 (systemd-timedat)
      Tasks: 1 (limit: 19031)
     Memory: 1.0M
        CPU: 56ms
     CGroup: /system.slice/systemd-timedated.service
             └─19547 /usr/lib/systemd/systemd-timedated

Sep 03 08:02:48 Kiseki systemd[1]: Starting Time & Date Service...
Sep 03 08:02:48 Kiseki systemd[1]: Started Time & Date Service.

● systemd-timesyncd.service - Network Time Synchronization
     Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2021-09-03 08:02:48 EDT; 3s ago
       Docs: man:systemd-timesyncd.service(8)
   Main PID: 19550 (systemd-timesyn)
     Status: "Daemon is running"
      Tasks: 1 (limit: 19031)
     Memory: 1.1M
        CPU: 60ms
     CGroup: /system.slice/systemd-timesyncd.service
             └─19550 /usr/lib/systemd/systemd-timesyncd

Sep 03 08:02:48 Kiseki systemd[1]: Starting Network Time Synchronization...
Sep 03 08:02:48 Kiseki systemd[1]: Started Network Time Synchronization.

 ╭─[email protected] in ~ took 13ms
 ╰─λ timedatectl show-timesync
SystemNTPServers=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org 192.168.2.1
FallbackNTPServers=0.pool.ntp.org 1.pool.ntp.org 0.fr.pool.ntp.org
RootDistanceMaxUSec=5s
PollIntervalMinUSec=32s
PollIntervalMaxUSec=34min 8s
PollIntervalUSec=0
Frequency=0

 ╭─[email protected] in ~ took 6ms
 ╰─λ timedatectl timesync-status
       Server: n/a (n/a)
Poll interval: 0 (min: 32s; max 34min 8s)
 Packet count: 0

 ╭─[email protected] in ~ took 4ms
 ╰─λ timedatectl
               Local time: Fri 2021-09-03 08:03:44 EDT
           Universal time: Fri 2021-09-03 12:03:44 UTC
                 RTC time: Fri 2021-09-03 12:03:44
                Time zone: America/New_York (EDT, -0400)
System clock synchronized: no
              NTP service: active
          RTC in local TZ: no

the RTC and universal time are actually correct its the local time thats bad

I'm sorry, I'm out of ideas.
If it really matters, you could try disabling systemd-timesyncd and using ntpd in the varous options in https://wiki.archlinux.org/title/System_time#Time_synchronization.
But I wouldn't want to make things unnecessarily complicated, maybe there is a solution.

1 Like

no problem I found out how I can manually force it to sync here System time - ArchWiki but ideally this should just be working out of the box, like it does in vanilla arch so either something is wrong with how garuda syncs time or something I did is breaking it. I remember having this issue since day 1 of using garuda so idk.

1 Like

Well, for me, with standard Dr460nized configuration, everything works ootb...

1 Like

Garuda time sync is fine, for me and the rest of the world :slight_smile:

For me, it is the other way around, the M$ time is always adjusted.
I always have to turn off a switch in time settings that M$ must set at boot time.

yeah agree usually it's windows that has the wrong time but on this machine its Linux don't know why all my configs related to time on garuda seem to be fine (posted about them above) so can't really figure out what could be wrong

whats even more strange is i was using a vanilla arch install before this configured almost exactly the same way (which is why I switched to garuda since its basically exactly how i would setup arch) and it was working fine there dualbooting with windows so this is really strange. If anyone has any ideas please let me know

a tempory solution could be to have a startup script run
sudo ntpd -qg and sudo hwclock --systohc though if I'm going to that maybe it would just be better to replace systemd-timesync ?

1 Like

Same here! I had to manually bump a time sync to get the right time!
I have no idea why it fails.

Because Windows idiots are driving the bus.

2 Likes

At first I thought you are telling me that you're the Bus Driver which made me think there's no need to tell me, I can see that myself!)

But then I found a Switch in Garuda Settings Manager to keep RTC in Localtime and all is good now!

4 Likes

I will mark your issue aa solved.

Welcome to Garuda.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.