ThinkPad W541 Frozen Boot


I have attempted to install Garuda Dr460nized Gaming Edition onto my Lenovo ThinkPad W541 (w/ nvidia Quadro k1100m). Booting the live image works just fine (though I am unable to see the initial GRUB menu that allows for allowing/disabling proprietary drivers), but I am unable to successfully boot on the installed system (systemd seems to initialize properly, but at some point the screen goes grey and then a Lenovo Splash screen appears (no error messages) at which point everything freezes and I am forced to reboot).

Interestingly enough, when I had placed my old hard drive with the same edition of Garuda on it (installed for an hp envy x360 m6-w105dx in case it is relevant), it had worked just fine (minus the nvidia card as it uses different drivers). Any help with this issue would be appreciated.

Below you will find my system configuration (taken from within live iso):

  Kernel: 6.2.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda
    root=miso:LABEL=GARUDA_DR460NIZEDGAMING_RAPTOR quiet systemd.show_status=1 ibt=off
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: 5.27.3 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Laptop System: LENOVO product: 20EGS0PH00 v: ThinkPad W541 serial: <superuser required>
    Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20EGS0PH00 v: NO DPK serial: <superuser required> UEFI: LENOVO
    v: GNET78WW (2.26 ) date: 01/26/2016
  ID-1: BAT0 charge: 66.6 Wh (99.4%) condition: 67.0/99.5 Wh (67.3%) volts: 12.2 min: 10.8
    model: SANYO 45N1779 type: Li-ion serial: <filter> status: not charging
  Info: model: Intel Core i7-4710MQ bits: 64 type: MT MCP arch: Haswell gen: core 4 level: v3
    note: check built: 2013-15 process: Intel 22nm family: 6 model-id: 0x3C (60) stepping: 3
    microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 3126 high: 3321 min/max: 800/3500 scaling: driver: intel_cpufreq
    governor: performance cores: 1: 2966 2: 2977 3: 3050 4: 3288 5: 2973 6: 3304 7: 3133 8: 3321
    bogomips: 39906
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo driver: i915 v: kernel
    arch: Gen-7.5 process: Intel 22nm built: 2013 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1,
    HDMI-A-2, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
  Device-2: NVIDIA GK107GLM [Quadro K1100M] vendor: Lenovo driver: N/A alternate: nouveau
    non-free: series: 470.xx+ status: legacy-active (EOL~2023/24) arch: Kepler code: GKxxx
    process: TSMC 28nm built: 2012-18 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:0ff6 class-ID: 0300
  Device-3: Bison Integrated Camera type: USB driver: uvcvideo bus-ID: 3-12:5 chip-ID: 5986:026a
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x34ed built: 2012 res: 1920x1080 hz: 60 dpi: 142
    gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel HD Graphics 4600 (HSW GT2)
    direct-render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 class-ID: 0403
  Device-3: NVIDIA GK107 HDMI Audio vendor: Lenovo driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
  Sound API: ALSA v: k6.2.7-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Intel Ethernet I217-LM vendor: Lenovo driver: e1000e v: kernel port: 5080
    bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 8086:08b2 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 3-11:4
    chip-ID: 8087:07dc class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 1 state
: up address: <filter>
  Local Storage: total: 946.42 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS541010A7E630 size: 931.51 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: A4A0 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Glide size: 14.91 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 2332
  Processes: 229 Uptime: 1h 10m wakeups: 1 Memory: 15.5 GiB used: 3.35 GiB (21.6%) Init: systemd
  v: 253 default: graphical tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1798
  libs: 505 tools: octopi,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.25
Garuda (2.6.15-1):
  System install date:     2023-06-22
  Last full system update: 2023-03-19
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            snapper-cleanup.service 

Hi there, welcome to the forum!
One thing you could try, since it is a fresh install, is burning and installing the Dr460nized non-gaming edition.
For some still unknown reasons, the gaming edition seems to be giving booting problems to many new users recently.
Then you can install from the tools every gaming thing you need.

1 Like

Thank you for your prompt reply.

I have attempted using the non-gaming edition and experienced the same issues that I have listed in my post.

This should be your problem.
Neither the kernel (nouveau) nor the proprietary driver seem to be loaded.
Unfortunately I’m not an expert of Nvidia cards, but I’m sure other users will jump in.
For the moment you could try this tutorial.

Basically, either try to switch to or boot to a TTY and update your system fully, or do this chrooting from the live ISO if you cannot get to a TTY.


will take care of everything (refresh mirrors and update).
You could also try the

sudo dkms autoinstall

In the end, from the Nvidia site, it seems to me that the nvidia-470xx-dkms driver (which is in the chaotic-AUR) should work on your card.
Try also auto-detection/installation:

sudo mhwd -a pci nonfree 0300

Or as last resort:

sudo pacman -Syu nvidia-470xx-dkms

I have attempted to do as you have stated, but I am unable to run garuda-update (or any download command) with the error(s) that the host(s) could not be resolved.

I have already redone my mirrorlists but I cannot seem to fix this problem. I have also tried to manually set up my resolv.conf file as I have found others mentioning this might be an issue for internet access within chroot.

However, for whatever reason I am unable to make any changes to the file or even delete it (I've tried changing permissions with chattr but receive error: "operation not supported while reading flags on /etc/resolve.conf"). I have also made a separate file with the appropriate nameservers and changed the path in resolvconf.conf to no avail.

I think it might be useful to copy the exact commands (inputs and outputs) executed in your terminal from the live USB, to see how you chrooted and what you tried afterwards.
Maybe it can provide some insights...


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.