There is a .snapshot folder in my root thats holding the system

i am on garuda xfce , i updated garuda and then after reboot the system would freeze with black screen so i put live usb and chroot into the system , whatever i try to do it says there is not enough space on my ssd but my ssd have almost 40 gb free , ofcurse i ran $ gdu to analyze the ssd disk and see whats eating the storage or causing problems , and when i ran $ gdu using root , there appear to be a .snapshot folder thats somehow 500 gb - my ssd is 128gb ! - and i have never ever even think about using snapshot never the less creating one , this folder poped out of nowhere , initially if i try to do anything on the terminal pacman doesn’t work, it keep saying that the disk is full it wouldn’t even delete anything , but i was able to delete a VM i had on the ssd , now that i have some space pacman worked and i immeadiatley removed this snapper tool thing.

but here is the problem , i can’t install anything with pacman just remove and somehow i can’t delete this .snapshot folder using root or changing the permission to 777 or chown to user , whatever i try
it keeps give an error saying its a [ read-only filesystem ]

rm: cannot remove (X) : Read-only file system
chown: changing ownership of ‘451/snapshot/**etc’: Read-only file system

Gofile - Your all-in-one storage solution video

how can i solve this problem ?

What’s the problem with not posting garuda-inxi?
It contains additional, useful information about the status of your system.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help

  • Show us the results of your searches, and what you’ve tried

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

Read about snapshots.





Those are your snapshots. They share underlying storage so du is probably not reporting the disk space they actually use.

If you want to delete snapshots, use btrfs-assistant or snapper-tools. However, this may be unrelated to your actual issue.


I don’t really understand your logic here. Why did you even attempt to delete files that you didn’t know what purpose they served without even trying to find some information about them online? If I’m not completely mistaken you’d have successfully wiped your entire root partition clean if that rm command had succeeded, because the latest snapshot always represents the current state of the machine.

If it doesn’t boot, then you should ask your dear friend, the internet.
In your post you haven’t made clear what “freeze with black screen” is supposed to mean. Does the system print out anything on screen to the screen? Does it stay on? Does it just reboot?

Just as @SGS suggested, you should post your garuda-inxi. It contains integral information for us to assist you, especially in the case of an unbootable system. Since you’re able to chroot into your system, run the command there and paste the output here, as the post template suggests.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.