Theme Problems

I mentioned the error of my taskbar in the theme that comes by default when you download Garuda. Since this problem could not be solved and it bothered me so much, I decided to change my theme. However, I noticed that it does not work properly in other themes that come by default. To fix this problem I have previously installed updates, switched between X11 and Waylands and even reinstalled my OS with a new USB but it is not working, someone please help. I am about to go crazy.

Kernel: 6.6.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=40a1b073-0fd3-4276-b76e-b74cd211bf9b rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: Gigabyte product: H610M H DDR4 v: -CF
serial: <superuser required>
Mobo: Gigabyte model: H610M H DDR4 serial: <superuser required>
UEFI: American Megatrends LLC. v: FSa date: 10/19/2023
Info: model: 12th Gen Intel Core i5-12400F bits: 64 type: MT MCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 5
microcode: 0x32
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB
L3: 18 MiB desc: 1x18 MiB
Speed (MHz): avg: 1027 high: 3286 min/max: 800/4400 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 800 4: 1040
5: 800 6: 800 7: 800 8: 800 9: 3286 10: 800 11: 800 12: 800
bogomips: 59904
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: Gigabyte
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: none off: HDMI-A-2 empty: DP-1,DP-2,HDMI-A-1
bus-ID: 01:00.0 chip-ID: 10de:2504 class-ID: 0300
Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
s-diag: 554mm (21.82")
Monitor-1: HDMI-A-2 mapped: HDMI-1 note: disabled model: Samsung SMB2230N
serial: <filter> built: 2010 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
memory: 11.72 GiB
API: Vulkan v: 1.3.274 layers: 11 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3060 driver: nvidia v: 545.29.06
device-ID: 10de:2504 surfaces: xcb,xlib
Device-1: Intel Alder Lake-S HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:7ad0 class-ID: 0403
Device-2: NVIDIA GA106 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
Device-3: C-Media SN-RGW9 driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:4
chip-ID: 0d8c:0012 class-ID: 0300 serial: <filter>
API: ALSA v: k6.6.8-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Local Storage: total: 1.36 TiB used: 45.4 GiB (3.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: MLD M300 NVMe SSD
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: EDFMF0.0 temp: 40.9 C
scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: HD105SI
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: 0001 scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 45.4 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 45.4 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 45.4 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 465.46 GiB size: 465.46 GiB (100.00%)
used: 45.4 GiB (9.8%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.44 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 43.0 C mobo: 38.0 C gpu: nvidia temp: 50 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Processes: 308 Uptime: 0m wakeups: 0 Memory: total: 16 GiB
available: 15.45 GiB used: 1.84 GiB (11.9%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1778 libs: 519 tools: octopi,paru Shell: fish v: 3.6.4
running-in: konsole inxi: 3.3.31
Garuda (2.6.21-1):
System install date:     2023-12-23
Last full system update: 2023-12-24
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

What is the issue?
I don’t see anything wrong with your theme, just something unusual with the Top Panel being shrunk to the left, but users can make it the width and position they want so maybe that’s your creation, which is why at the moment it’s not wrong to me.


I haven’t changed anything in the themes. In the other global themes I downloaded, there are problems background and taskbar. Every theme I change turns out to have a broken feature.

Ok, and on the picture in Post #1 what’s wrong?

There is a problem with the taskbar. The start screen does not appear. Files explorer and icons not showing properly. Don’t change wallpaper

Oh, that’s pretty bad, all those issues!
What if you boot from Garuda ISO and try applying theme changes, change Global Theme, click Dolphin, look at icons, etc… is it the exact same behavior?

Yes, Is there any debug I can throw at you?

Also, I just noticed something new. If I move my mouse over an empty area in the file explorer, black squares appear where my mouse passes and then they disappear. I can’t show this with a screenshot because they don’t show up in the screenshot.

I’m definitely gonna open a used NVidia store.


If I had been as knowledgeable in the past as I am today, I would never have used Windows and bought an Nvidia graphics card :smiley:

1 Like

If you only knew how many of us have said the same. I had a pair of high-end cards in SLI. All that money. Wasted. sniffle

But there’s others here that still swear at by them, so whatcha gonna do? :person_shrugging:

I don’t know, my biggest mistake when buying my computer was asking only one person. He changed my mind with just one word.

I dunno, it’s a nice rig! :smiley:

But, anyway, different drivers may yield different results. Your rig is new enough you’re probably gonna need to diddle with 'em. Someone who actually has Nvidia will probably respond. I’m no help with this.

EDIT: To address your questions below: Yes and no.


Do you think the problem I shared here will be solved or can you guess how long it will take to be solved?

I also think it may be hardware related, mostly NVIDIA. As Bro mentioned, we have seen way too many weird issues with NVIDIA cards.

Are you able to try a different brand? AMD or on-board Integrated Graphics?
Or maybe just different NVIDIA software driver, as Bro, again, mentioned.

1 Like

I don’t know, I really want to use Garuda, but this problem is very frustrating, I don’t know what to do, I’ve tried everything.

I spent 1200 USD on a new RTX 3070 two or three years ago (during the shortage). Not that the card is malfunctioning or anything but because of all of the ridiculous hoops to jump through to get hardware acceleration running in some cases (e.g. in browsers) and it not working at all in some cases (i.e. some browsers again), I’m looking for an AMD card. I’ll probably buy as top of the line one as I can when I get my tax return in about 3-4 months. By then Plasma 6 will be out and I can do a fresh / clean install of an unused NVMe SSD I have and a new AMD card.

1 Like

Restart the display server (x11) with CTRL+ALT+BACKSPACE. Do you have the same problems afterwards?
Switch to wayland. Do you have the same problems?
Switch to open source driver nouveau. Do you have the same problems?

btw: the Intel Core i5-12400F does not have an iGPU.

1 Like

Not work I already tried

Sorry, I missed that in your first post @ trying wayland.
I read through your other topic. But if you have this even with a live session and the open source driver… That looks like a hardware issue. Do you have the opportunity to test another GPU, for example from a friend? Try another Linux distribution and see if it also gives you this error.

EDIT: I have no idea whether the RTX 3060 Lite Hash Rate is fully supported. Have you ever searched on the web?

Your garuda-inxi looks completely normal, but part of your error description sounds like hardware acceleration is missing.

Go to /var/log/ and open the Xorg.0.log with an editor. Copy the entire content to and post the generated link here.
This way we can take a look at possible error messages for missing hardware acceleration.

1 Like