Theme not applying to applications with raised permissions

I changed my theme. It applied properly to most things, but gparted used the original theme. While searching to fix that I came across a post that said that the issue was likely because gparted runs with elevated permissions. I tested this hypothesis by running “sudo mousepad”, and mousepad also used the original theme.

I tried running systemsettings as root and changing the theme there. That did not work.

I tried logging in as root and changing the theme there. That did not solve the problem.

Any suggestions?

First suggestion is to provide the mandatory garuda-inxi log wrapped in the </> function.


as said above the inxi would make helping way more simple, but
go here, an find a theme thats is yours or close to it. Dont forget to test it since some of them are broken due to gnome being gnome.

@dalto has posted a simple method in the past for standardizing user and root colors/themes:


As already stated please provide the output of the garuda-inxi command if you wish to receive further assistance. We can only guess as to your systems configuration and desktop without it.


The only negative is konsave hasn’t been updated for kde6 yet or at least its how it seems. [Feature Request] Add plasma 6 support · Issue #106 · Prayag2/konsave · GitHub

I actually really miss the tool I used it all the time on kde 5

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.