The Ol' "Disabling IRQ #11" makes it IMPOSSIBLE to boot OS

Hi, im new to Linux. Been using Garuda Linux for about 9 months now as my main OS and I've been loving every moment of it. Until today, that is. Sorry, its hard to hide my frustration.

So this is how it happened. I was browsing youtube, killing time I should've been studying, when suddenly the screen goes black. No warnings, no error screens, no funny colors no nothing, just black. Turns out, the PC had shutdown. weird. there was no power outage or such an event, so theres no reason for this. I pay no mind and proceed to turn my PC on again, choose the HDD Garuda OS in the boot menu (I have 2 HDDs one with windows 10 and the other with Garuda), and BAM! I get this code:


[   1.774915] Disabling IRQ #11
_

After many tries and 25 minutes I take it the OS will be stuck in this screen forever. It won even boot. I can get to the boot manager, but even if I try to load previous snapshots of Garuda the same error persists. The OS doesnt boot so its impossible to run any other for of diagnosis. using the [c] command to see the GRUB command line wasn't very helpful as I had no idea what I was doing.

Browsing the internet was surprisingly unfruitful. There have been people with similar errors before, but most topics I found on google are from other forums and different Linux distros, plus their errors are not the same as mine and their solutions didn't work for me either. Most topics with similar problems have no answers, wich leads me to believe this is either a problem so simple anyone can solve and im dumb, or I got so lucky no one ever had this problem before. Also, all posts I found are really old, for some reason. usually from 2009-2012.

Searched this forum too but, no dice. seems no one here has had this failure before.

Some posts seem to indicate some sort of hardware failure, i've yet to test the HDD on another PC (I dont have another PC) but seems to me the same error will persist regardless. My hardware works fine in my windows OS, its just garuda that is failing, wich leads me to believe its not the all the other hardware, it has to be the HDD.

Another relevant information is that I edited the GRUB file one day before this happened, maybe I did something?

I apologize for the wordy post, and also apologize if this is just a silly problem that I should know how to solve, I'm new to linux and this is, in fact, my first linux ever and I have no idea what I'm doing.

Any help would be welcome.

EDIT Heres the inxi file! I`ve initiated a new garuda OS .iso via USB stick.

 [email protected] in ~ as 🧙 
 λ inxi -Faz
System:
  Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=garuda misolabel=GARUDA_GNOME_WHITETAILEDEAGLE quiet
    systemd.show_status=1 driver=nonfree nouveau.modeset=0 i915.modeset=1
    radeon.modeset=1
  Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: A320M-HD serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: P5.40 date: 07/09/2019
CPU:
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1937 high: 3799 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3799 2: 1515
    3: 2190 4: 1374 5: 1375 6: 1375 7: 3799 8: 1516 9: 2179 10: 1377 11: 1377
    12: 1373 bogomips: 81588
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Gigabyte driver: nvidia
    v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 07:00.0 chip-ID: 10de:1c81
    class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: gnome-shell driver:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
    s-diag: 583mm (23")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.5x13.2") diag: 686mm (27")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 07:00.1 chip-ID: 10de:0fb9
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel bus-ID: 09:00.3 chip-ID: 1022:1457 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel port: f000 bus-ID: 06:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.51 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: NVME SSD 128GB size: 119.24 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    type: SSD serial: <filter> rev: R0629A0 temp: 49.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EARS-00Y5B1 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 0A80
    scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Apple model: HDD HTS545050A7E362
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B
    speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: B990
    scheme: MBR
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Kingston
    model: DataTraveler 3.0 size: 28.9 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.61 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 56 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 326 Uptime: 5m wakeups: 0 Memory: 15.61 GiB
  used: 3.83 GiB (24.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1123 lib: 290 Shell: fish v: 3.3.1
  default: Bash v: 5.1.12 running-in: gnome-terminal inxi: 3.3.11
McFly: Importing shell history for the first time. This may take a minute or two...done.

 [email protected] in ~ as 🧙 took 2s

4 Likes

You are right, the error message points directly to a hardware failure, and your topic header indicates a certain amount of familiarity with operating systems and hardware--maybe .

So the first question I would ask is have you tried another kernel, such as the LTS?

The second question is why did you ignore the required information that we need to help you? I mean the part about posting the terminal output from inxi -Faz? It is a very powerful tool and with one easy post, it tells us a lot of information about your system. Information that can help us to help you.

Please do so if you wish continued help. :smiley:

regards

2 Likes

I didn't ignore the

inxi -Faz 

command, its just that I cant boot the OS, so, how am I going to install inxi and run it on the terminal? I tried running inxi on the GRUB command line, obviously it didnt work. Can I access the terminal even without being able to boot the OS? I have no idea how to do that.

1 Like

Boot from the live usb and you can get inxi -Faz from there.
You can also fix grub with the liveusb.
But i think it looks like your hardware maybe failing

6 Likes

You can also use the live USB to chroot into your installed system (there is a tool for that or a tutorial in the FAQ) and get the chance to check if it works and e.g. update or install a new kernel.

PS: Welcome to the forum! Although in difficult times...

3 Likes

So I can just boot a diferent .img os version of garuda through the usb stick and run inxi from that? had no idea.

I'm going to try that then and get an inxi file. then im going to edit the original post and put the inxi file there.

4 Likes

Done posted the inxi file, guys.

Ok, i can see here that the new USB garuda has a chroot app right in the garuda welcome window. though I have no idea how to use it. how do I check my broken OS with this chroot ?

Thanks! been lurking since the day I adopted the OS. You guys are fast! I thought it would take days for a response. usually does with forums.

If you installed Garuda on the SSD, your broken system is /dev/nvme0n1
Chroot there and see if you can read the directories with ls and maybe try update or sudo pacman -Syu

3 Likes

I did this and, apparently, its update and it can list and read the directories fine. I can also access the directories and explore them thru the usb file explorer. I`m going to use this opportunity to get some important files from this broke OS and save them in the windows partition. well, I guess the HDD is working. I think the problem is the actual OS, have I broken it somehow?

I`ve also noticed that, for some reason, the /root/ file from the old system is completely empty.

IRQ issues are mostly a thing from the distant past. These days it is very rare to encounter an IRQ problem.

Have you installed any new hardware recently just before this happened? If so remove that hardware item and see if the problem goes away.

3 Likes

I haven`t made any changes to hardware. not even a new gamepad.

Well. Ive saved necessary files in another place. so they`re safe. technically, nothing is holding me back from nuking the old OS. I think this is my only timely option. idk what to do anymore. this is the weirdest thing that ever happened to me.

Seems so, what do you change?

1 Like

Before reinstalling, maybe you could try a desperate

sudo btrfs check /dev/nvme0n1

Form the live USB. And in case of errors, the repair option.

1 Like

The way you described the failure it points to a hardware failure, but if the live environment is working correctly then obviously that shouldn't be the problem. Very strange.

In the old days IRQ issues were usually corrected by juggling around your add in cards to a different slot on your mobo.

1 Like

Ah, I had lost this piece of information.
Have you tried reinstalling the GRUB, when in chroot?

1 Like

You have a lot of other drives connected (older balky drives can prevent booting).

Disconnect all but your boot drive.

If any of these drives are mounted in fstab they should be commented out, or simply add the nofail option to the fstab load line.

2 Likes

Just woke up from a nap...installing and booting into a different kernel may solve (or not) all this guesswork.

2 Likes

Ok uhhhh
Hi, gentlemen. Thank you for all the massive support, but I ended up nuking the whole system. And it worked, my HDD is fine. so, first i'll answer all the posts, then I'll explain my logic. It will be a pretty big post.

This might be the cause of my woes, but I honestly dont think it is. I was this issue with Garuda, when tried to use my PC after I had it blocked or sleeping, the keyboard would be dead and it wouldn't come back. I even searched this forums for help, but the solutions here were inconclusive. changed my GRUB after I had seen a tutorial on Youtube, and it did solve that problem. Day later this IRQ #11 apocalipse happened. don't know if it was that, but, that was it.

I did try to check it, didnt work. actually saw my HDDs as completely fine and healthy.

I did, actually did reinstall GRUB, it still failed and with the same IRQ #11 error. Looks like GRUB wasnt the problem.

reason for that is that I had some USB sticks in there while I ran the command. But I tried booting normally (just with the nvme and the HDD) before even posting here, so thats not it.

Maybe it would, but I went nuclear, so we'll never know. ://// sad day dudes.

end of part 1

Decided to make a part 2 that first post was getting too big.

In short, I tried to rebuild the OS using all the suggestions I got from here and otherwise on the internet. Nothing worked, it didnt even scratch the problem. I think that for some reason the entire OS got corrupted. perhaps the /.root directory got somehow corrupted. In the end nuking the OS was the most timely option, like I said, I had managed to access the files inside the HDD via the USB garuda without any problems, so I just saved what I needed and went with a clean system reinstall.
Reinstalling systems is a boring and sad task, mainly because I will spend the next few days re-customizing and re-installing dependencies and a bunch of things you never know you need until you do. its a massive setback, but oh well.

If you, future internet user, find this post, know this: if you get the IRQ #11 error on your linux distro, it means your OS has died, but your files are prolly safe. to the best of my knowledge, at least. all you have to do is use a USB flash OS to save whatever files you need and then proceed to destroy the bad OS. though luck, story of my life.

thanks for all the support guys. might make a thread about the whole keyboard dying on me after a PC sleeping session, it might hit me in the future. lol.

1 Like