The extent of the grub problem

Hey there,
I changed my password yesterday to be much more secure than the one I was using earlier. That password included unicode characters which are available on my keyboard layout.
Today when I booted into my system I noticed, that the keymap was not applied in tty (greetd-tuigreet), so I could not log in due to missing keys.
I decided to boot into a live environment and edit the grub cfg file to include setkmap=de in the kernel parameters, after which I updated grub, all from within chroot, with the latest grub installed. Then I rebooted.

Since then I have been facing a stupid issue: Grub refuses to boot into my system correctly; It seems to boot with my home partition, but with a very old root parition, presumably from my latest backup restore which is months old and still uses plasma instead of wayfire.

I tried reinstalling grub, resetting the grub config file, ... Nothing worked. I thought, maybe I should delete the restore backups (@restore_backupxyz), but can I just do that? It's a btrfs thing after all. I thought you could do that, but I don't want to break my system further.

What am I supposed to do?
Thanks!

Edit: I want to mention that I have in fact tried to downgrade grub or install grub on the live environment and copy the files over, but the former didn't work as chroot apparwntly doesn't like pacman actions, or the pacman file cache isn't mounted. The latter was also unsuccessful because pacman is locked in a live enviroment (why though)

No inxi because I'm on my phone rn

The BTRFS snapshot / subvolume is determined by this kernel parameter:

rootflags=subvol=<subvolume>

You can change it on GRUB command line. The default should be

[email protected]
1 Like

How do I use this? I don't want to hardcode this in grub. If I enter this in the grub commandline, do I have to manually boot into my system? If not, how do I exit it afterwards? Sorry, but I have no idea how to use the grub command line

Edit: @mrvictory (forgot the reply)

Edit: Good news it's doing the garbage that I expected


Why tf is it doing that

Edit again: Now that I got it working again, do you have any idea, how I can set a tty keyboard layout? The boot option did nothing.

Edit again again: I also seemingly can't use my password, as everytime I try to log in it just sais authentication failed. I have verified that it works in chroot and that tty reads my inputs correctly in the login field (I thought the passeord cooldown reset after a reboot?)

1 Like

Choose whatever boot entry, hit "e" and put any kernel parameters to the end of the line starting with "linux".

1 Like

Crapping hell. Managed to log in after overwriting /etc/shadow with a known good copy. Why did it not work before?

Anyways. Ima mark this as solved. If you know a way to force a keyboard layout for tty, please hit me up.

For anyone interested: I find-replace'd all garbage backup entries with @ and now it's booting correctly.

Grub seems to be the buggiest mess currently. Maybe it's not that good to ship commit-based builds into garuda. Imo it should wait for releases or tested versions (chaotic unstable mirror when)

(Maybe gonna switch to refind if it's usable)

1 Like

https://wiki.archlinux.org/title/Linux_console/Keyboard_configuration

GRUB comes from Arch repos, not Garuda. All Garuda can do is to put a grub package to its own repo to override Arch.

2 Likes

Linux console/Keyboard configuration - ArchWiki

I have tried that, but interestingly, the keymap refuses to have unicode characters. üäöß, ... don't exist. Instead they are replaced with @[], ...

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.