Terminal Prompt issue

So I am returning to *nix after a long time away and I have a small issue that is bugging me to no end.

What is causing the “user@host in ~ took 8ms” to appear in my terminal and how can I be rid of it?

Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm

Check starship.toml in ~/.config.

Here is the template you are missing while posting in Garuda Community and not in Issues & Assistance

Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:


Refusing to post the output of the required “garuda-inxi” on a help request will likely result in you not receiving any help from the Garuda team. A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki’s, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum’s search engine and on the web. For in depth information on how to search for answers to Linux issues effectively, read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.

1 Like

I have found the culprit, Starship. The specific config is located at ~/.bashrc and can be disabled by commenting out the following section:

 Load starship prompt if starship is installed
if  [ -x /usr/bin/starship ]; then
    __main() {
        local major="${BASH_VERSINFO[0]}"
        local minor="${BASH_VERSINFO[1]}"

        if ((major > 4)) || { ((major == 4)) && ((minor >= 1)); }; then
            source <("/usr/bin/starship" init bash --print-full-init)
            source /dev/stdin <<<"$("/usr/bin/starship" init bash --print-full-init)"
    unset -f __main
1 Like