Terminal Autocomplete in Garuda Dragonized

Hi guys, i'm still pretty new to linux and i still cant figure out what the terminal in garuda is using to have that autocomplte suggestion?

What terminal do you use and where is your inxi -Faz?

uhh idk about the Inxi-Faz but ive switche to bash and im using yakuake

It is in the template you just delete.


Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

Got it, brb im just gonna install inxi first

It is installed BTW

I should have included in the question first that im trying to implement on my kali machine what i like about my garuda machine, but idk how to do some of those changes and this is one of them but this is my inxi -Faz

System:    Kernel: 5.10.0-kali9-amd64 x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-kali9-amd64 root=UUID=0f44fd2d-d4fa-4537-96a5-6c01f2057255 ro quiet 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.26.0 
           Distro: Kali GNU/Linux 2021.3 base: Debian testing 
Machine:   Type: Vmware System: VMware product: VMware Virtual Platform v: N/A serial: <filter> Chassis: No Enclosure type: 1 
           serial: <filter> 
           Mobo: Intel model: 440BX Desktop Reference Platform serial: <filter> BIOS: Phoenix v: 6.00 date: 07/22/2020 
Battery:   ID-1: BAT1 charge: 28.1 Wh (100.0%) condition: 28.1/48.9 Wh (57.5%) volts: 16.1 min: N/A 
           model: VMware Virtual Battery type: Unknown serial: N/A status: Unknown 
CPU:       Info: 4x Single Core model: Intel Core i5-8300H bits: 64 type: SMP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: A (10) microcode: FFFFFFFF cache: L2: 32 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 18432 
           Speed: 2304 MHz min/max: N/A Core speeds (MHz): 1: 2304 2: 2304 3: 2304 4: 2304 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT Host state unknown 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: VMware SVGA II Adapter driver: vmwgfx v: bus-ID: 00:0f.0 chip-ID: 15ad:0405 class-ID: 0300 
           Display: x11 server: X.Org 1.20.11 compositor: xfwm4 v: 4.16.1 driver: loaded: vmware 
           unloaded: fbdev,modesetting,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") s-diag: 583mm (23") 
           Monitor-1: Virtual1 res: 1920x1080 hz: 60 
           OpenGL: renderer: llvmpipe (LLVM 11.0.1 256 bits) v: 4.5 Mesa 20.3.5 compat-v: 3.1 direct render: Yes 
Audio:     Device-1: Ensoniq ES1371/ES1373 / Creative Labs CT2518 driver: snd_ens1371 v: kernel bus-ID: 02:02.0 
           chip-ID: 1274:1371 class-ID: 0401 
           Sound Server-1: ALSA v: k5.10.0-kali9-amd64 running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
           Sound Server-3: PipeWire v: 0.3.38 running: yes 
Network:   Device-1: Intel 82371AB/EB/MB PIIX4 ACPI vendor: VMware Virtual Machine type: network bridge driver: N/A 
           modules: i2c_piix4 port: 1060 bus-ID: 00:07.3 chip-ID: 8086:7113 class-ID: 0680 
           Device-2: Intel 82545EM Gigabit Ethernet vendor: VMware PRO/1000 MT Single Port driver: e1000 v: kernel port: 2000 
           bus-ID: 02:01.0 chip-ID: 8086:100f class-ID: 0200 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 80 GiB used: 15.32 GiB (19.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: VMware model: Virtual S size: 80 GiB block-size: physical: 512 B logical: 512 B 
           type: N/A serial: N/A rev: 1.0 scheme: MBR 
Partition: ID-1: / raw-size: 79.04 GiB size: 77.25 GiB (97.73%) used: 15.32 GiB (19.8%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 975 MiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda5 maj-min: 8:5 
Sensors:   Message: No sensor data found. Is lm-sensors configured? 
Info:      Processes: 235 Uptime: 54m wakeups: 1628 Memory: 3.83 GiB used: 1.8 GiB (47.0%) Init: systemd v: 249 runlevel: 5 
           tool: systemctl Compilers: gcc: 10.2.1 alt: 10 clang: 11.0.1-2 Packages: apt: 2436 lib: 1100 Shell: Bash v: 5.1.8 
           running-in: yakuake inxi: 3.3.06

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Edit your post, please.


IDK kali. Sorry.

I understand but on the case that it isnt kali or debian based, how do i customize the autocomplete in the terminal?

Use fish.e.g.


There are specific support routes for Kali. It is Debian-based so anything implemented on Garuda (being Arch-based) may not directly apply. Therefore, the question of

would be better asked of the Kali community.


Or use zsh, which can have autocompletion, and, if I remember correctly, was a standard in Kali a couple of years ago (the last time I saw it)


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.