Telegram problem

Hi, I'm just wondering what's happening with Telegram? None of the versions in the AUR, standard Arch packaging and Chaotic-AUR are working for me at the moment. I presume you guys are going to rebuild the version(s) in Chaotic-AUR? If so, do you know when they will be available as I use Telegram a lot. Many thanks for your help and providing this great distro. I'm really enjoying i3 at the moment.

About which package are you talking specifically & how does it "not work" for you?

1 Like

I mainly concentrated on chaotic-aur/telegram-desktop-bin-dev and telegram-desktop, I did try other versions also but these were the two I kept coming back to. I don't have a smart phone, just a burner, so I give them my phone no. and they send a code which I enter, which verifies it's me. However, I only get as far as entering my phone no. and then it just freezes up. This has only happened since the issue with libicui18n.so.68. I'm at a little bit of a loss.

telegram-desktop is a package from Arch repos & telegram-desktop-bin-dev is updated :thinking:
What does launching via terminal give as output?

1 Like

My system seems to have serious problems. When I run pacman-Si on both telegam-desktop & telegram-desktop-bin-dev, they both show as being installed. When I run pacman-Rsn on telegram-desktop it doesnt actually remove it from my system. Telegram-desktop from the terminal launches Telegram, telegram-desktop-bin-dev just comes back as an unrecognised command.
I think I'll need to remove all traces of all versions of Telegram from the system and then hopefully proceed with telegram-desktop-bin-dev. I have no idea how this happened. Apart from the fact that I must be an idiot! ;D

That is just the package name, it probably installs the binary as telegram-desktop.

2 Likes

Thanks! I'll start cleaning up my system and hopefully sort this mess out. Thanks for your time and help. Appreciated.

2 Likes

Why are you writing about telegram in a solved Firedragon thread?

Yah, I had been discussing Telegram earlier in thee thread due to the fact that it appears to have been impacted by the same issue as Firedragon. It's just frustration and carelessness. Please excuse my ignorance. I've deleted the offending post. Hope all is good now.

1 Like

Wait for the package to be fixed.

I have no idea if it might help this, but try running telegram with English language from terminal LANG=en telegram-desktop.

This doesn't sound like a Garuda issue. Does the "burner" phone you have still work? Does it receive any SMS at all?

Thanks for the input but unfortunately it doesn't help. Ive decided to simply wait for the package to be updated and hopefully all will be well.

Oh the burner phone is working just fine. I've received my usual texts here in Germany and one today from the UK as well, so all is well with the phone. Thanks for your input.

Does the web client work?

I hadn't thought of that but sadly no. Thanks again for the input.

In which case it is definitely not an issue with the telegram-desktop package. Possibly you have overused the SMS code feature, or your account has been disabled/restricted, or you're being monitored by GCHQ, or ...

In any event, you'd be better off taking this up with Telegram themselves.

4 Likes