Telegram problem for change download folder

Hello. I have a problem with Telegram. When I go to 'Settings' - 'Advanced' - 'Storage data' - 'Download path' - 'Custom folder, manual delete'.
When I try to select the folder where I want my downloads, the 'open' button doesn't work. The problem is that it won't let me change the download folder. I normally use SalientOS which is Arch, and I don't have that problem. I want to give Garuda a chance. But I have this problem. I give the button 'Open' and it does not work, it does not let me select any different folder, and I would like the Telegram downloads to be on a different hard drive than the OS. The same has happened to me with Arcolinux that the 'Open' button does not work, but in SalientOS it works correctly.
Could someone help me to fix this problem? I use garuda-dr460nized-linux-zen-210425.iso
Thank you.

This sounds like more of a software issue than a Garuda issue. I could see how that would be a deal breaker when it comes to OS selection though. :crazy_face:

Have you looked at editing the telegram configuration file and the directory path manually?

3 Likes

Try telegram-desktop-git.

1 Like

telegram-desktop-git, same problem.
tbg, Garuda is not for me then :crazy_face:. I need Telegram for my daily work. I need to move a lot of files and I need to change the download folder and in Garuda (Arch) I can't. Instead in SalientOS (Arch) if I can. I think the problem is from GarudaOS clearly, Telegram I think it is the same in SalientOS as in GarudaOS ,all is Arch Linux, so the problem is in Garuda I think.
Anyway, thanks for your help.
Greetings. :wink:

Try kotatogram-desktop-bin from AUR or kotatogram-desktop-git from the repo.
Its a modded client which might have the functionality you are searching for :eyes: (using it myself to have system fonts working)

1 Like

Thanks dr460nf1r3. kotatogram same results, bottom 'open' not work. Impossible change download folder.
Thanks for your time and your answer :wink:
Best regards.

Hello @anon22672752,

I have a solution for you.

Let's assume your storage folder shall be:

~/telegram_storage/ 
  1. Create that folder
  2. Open Telegram and go to "Settings - Advanced - Download Path"
  3. Click on "Custom Folder, cleared only manually"
  4. A window open. Without navigating anywhere, type the path (~/telegram_storage) in the "Name"-field and press "open".
  5. "Save"

Have fun :grin:

4 Likes

Either you are a troll, or you are simply clueless as your statement is beyond baseless.

Learn some Linux before making blanket accusations.

There are more than a few workarounds for this issue, but rather than actually wanting to resolve them you simply slag off Garuda and say you're returning to another OS. This is the standard line from most who simply open posts to troll a distros forum.

As you've stated several times that you have no intention of trying to resolve this issue and are simply returning to another OS, I think we can close out this thread now.

Bye bye. :wave:

4 Likes

Permissions issue.

You can't use the directory because you don't have the correct file/directory permissions set.

Think again. :wink:

6 Likes