Telegram doesnot open

Hello Garuda users.
I cun't open telegram after update system help me

System:
Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=945d5778-e926-4d38-b368-0906a3eb7dd5 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: A320M-S2H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F53 date: 01/05/2021
CPU:
Info: model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64 type: MCP
arch: Zen level: v3 note: check built: 2017-19 process: GF 14nm
family: 0x17 (23) model-id: 0x11 (17) stepping: 0 microcode: 0x8101016
Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 2070 high: 2879 min/max: 1600/3500 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2260 2: 2879
3: 1557 4: 1586 bogomips: 27947
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 07:00.0
chip-ID: 1002:15dd class-ID: 0300 temp: 49.0 C
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: 24HC1QR serial: <filter>
built: 2020 res: 1920x1080 hz: 120 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 600mm (23.6") ratio: 16:9, 15:9
modes: max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon Vega 8 Graphics
(raven LLVM 15.0.7 DRM 3.52 6.3.9-zen1-1-zen) direct-render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 07:00.1
chip-ID: 1002:15de class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
IF-ID-1: enp7s0f3u4 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
Device-1: OPPO RMX2027 driver: rndis_host v: kernel type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-4:2 chip-ID: 22d9:276a
class-ID: 0a00 serial: <filter>
Report: bt-service: enabled,stopped note: tool can't run
Drives:
Local Storage: total: 585 GiB used: 234.77 GiB (40.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SSD 128GB size: 119.24 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter>
fw-rev: XKR scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT3500SC 6
CTB5029G21Y034 size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s tech: HDD rpm: 7200 serial: <filter> fw-rev: A52B
scheme: GPT
Partition:
ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 54.84 GiB (46.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 54.84 GiB (46.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 54.84 GiB (46.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%)
used: 54.84 GiB (46.1%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.59 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 49.2 C mobo: N/A gpu: amdgpu temp: 49.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 259 Uptime: 27m wakeups: 0 Memory: available: 13.59 GiB
used: 3.48 GiB (25.6%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 1664 libs: 499 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-06-30
Last full system update: 2023-06-30 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

I cun't open telegram after update system help me

here is logs

qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqeglfs.so: failed to map to memory: Invalid argument
qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqlinuxfb.so: failed to map to memory: Invalid argumen
t
qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqminimal.so: failed to map to memory: Invalid argumen
t
qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqminimalegl.so: failed to map to memory: Invalid argu
ment
qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqoffscreen.so: failed to map to memory: Invalid argum
ent
qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqvkkhrdisplay.so: failed to map to memory: Invalid ar
gument
qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqvnc.so: failed to map to memory: Invalid argument
qt.core.plugin.loader: /usr/lib/qt6/plugins/platforms/libqxcb.so: failed to map to memory: Invalid argument
qt.qpa.plugin: Could not find the Qt platform plugin "xcb" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the applicat
ion may fix this problem.

Available platform plugins are: wayland-egl, wayland.

fish: Job 1, 'telegram-desktop' terminated by signal SIGABRT (Abort)

Have you tried the suggestion given by your own logs?

sudo pacman -Rns telegram-desktop
sudo paccache -ruk0

This should uninstall the software and then you can reinstall with

sudo pacman -S telegram-desktop
1 Like

already did 5 times not work

does

sudo pacman -S telegram-qt

help? The project says they have telegram's qt bindings

2 Likes

Just to confirm did you uninstall and clean the pacman cache with the commands above?

Before going to reinstallation?

Otherwise instead of reinstalling telegram from remote sync repo it will just reinstall the corrupted package from the local pacman cache.

What did you remove?
The app work fine here.
Check log from

cat /var/log/pacman.log | grep '2023-06-30' | egrep 'installed|upgraded|removed'
2 Likes

Reboot.

3 Likes

fixed

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.