Telegram desktop

Installed telegram desktop the standard way

sudo pacman -S telegram-desktop

however this message is output :

╭─[email protected] in ~ took 15s
[🔴] × telegram-desktop
telegram-desktop: error while loading shared libraries: libprotobuf.so.28: cannot open shared object file: No such file or directory

Need help to resolve this! I am new to garuda and AL

Is your system fully up-to-date?

Try running sudo pacman -Syu

In an Arch-based distro, you need to make sure system is updated before installing software.

4 Likes

Hi, I had tried to update system previously, but run into following error:

Packages (503) alacritty-0.9.0-1  alsa-card-profiles-1:0.3.34-1  alsa-lib-1.2.5.1-3  alsa-plugins-1:1.2.5-2  alsa-topology-conf-1.2.5.1-1  alsa-ucm-conf-1.2.5.1-1  android-tools-31.0.2-1
               aom-3.1.2-1  appstream-glib-0.7.18-2  archlinux-appstream-data-20210423-1 [removal]  archlinux-appstream-data-pamac-20210723-1  at-spi2-core-2.40.3-1  atkmm-2.28.2-2
               audit-3.0.4-1  automake-1.16.4-1  bind-9.16.20-1  binutils-2.36.1-3  blas-3.10.0-1  bleachbit-4.4.0-1  blueman-2.2.2-1  bluetooth-support-1-4  bluez-5.61-1
               bluez-hid2hci-5.61-1  bluez-libs-5.61-1  bluez-plugins-5.61-1  bluez-utils-5.61-1  boost-libs-1.76.0-1  brltty-6.3-4  btrfs-progs-5.13.1-1  bubblewrap-0.5.0-1
               ca-certificates-20210603-1  ca-certificates-mozilla-3.69-1  ca-certificates-utils-20210603-1  cairomm-1.14.3-2  catfish-4.16.2-1  cblas-3.10.0-1  celt-0.11.3-4
               chaotic-keyring-20210617-1  chaotic-mirrorlist-20210716-1  cifs-utils-6.13-3  ckbcomp-1.205-1  clang-12.0.1-1  colord-1.4.5-4  compiler-rt-12.0.1-2  conky-lua-nv-1.12.2-1
               cryptsetup-2.4.0-1  curl-7.78.0-1  dav1d-0.9.1-1  dbus-glib-0.112-2  dbus-python-1.2.18-1  device-mapper-2.03.13-1  dhclient-4.4.2.P1-1  diffutils-3.8-1  downgrade-10.1.0-1
               e2fsprogs-1.46.4-1  egl-wayland-1.1.7-1  elfutils-0.185-1  enchant-2.3.1-1  ethtool-1:5.13-1  evolution-data-server-3.40.4-1  exfatprogs-1.1.2-1  expat-2.4.1-1
               f2fs-tools-1.14.0-2  ffmpeg-2:4.4-4  file-5.40-5  filesystem-2021.05.31-1  find-the-command-git-1.4.2.r2.g0fc7e85-1  firefox-91.0.2-1  firefox-extension-bitwarden-1.50.0-4
               flameshot-0.10.1-1  flashfocus-git-v2.2.3.r5.g79dfb99-1  flatpak-1.11.3-1  fluidsynth-2.2.2-1  fontconfig-2:2.13.94-1  fprintd-1.94.0-1  fuse-common-3.10.4-1  fuse3-3.10.4-1
               fwupd-1.6.3-1  fwupd-efi-1.1-1  fzf-0.27.2-1  game-devices-udev-0.15-1  garuda-assistant-1.1.1-1  garuda-bash-config-1.0.1-1  garuda-boot-options-1.0.1-1
               garuda-browser-settings-1.2.0-1  garuda-common-settings-2.0.2-1  garuda-gamer-1.0.3-1  garuda-hooks-2.2.0-1  garuda-hotfixes-1.0.0-2  garuda-icons-r29.5730a02-1
               garuda-network-assistant-1.1.0-1  garuda-settings-manager-notifier-git-r25.eb0ea49-1 [removal]  garuda-setup-assistant-1.1.2-1  garuda-system-maintenance-1.1.3-1
               garuda-wallpapers-r59.a88383b-1  garuda-welcome-1.0.7-1  garuda-zsh-config-1.1.3-1  gcc-11.1.0-1  gcc-libs-11.1.0-1  gd-2.3.2-4  gdbm-1.20-1  gdk-pixbuf2-2.42.6-2
               geoip-database-20210824-1  git-2.33.0-1  glib2-2.68.4-1  glibc-2.33-5  glibmm-2.66.1-2  glslang-11.6.0-1  glu-9.0.2-1  glyr-1.0.10-3  gnome-desktop-1:40.4-1  gnupg-2.2.29-1
               gnutls-3.7.2-2  gparted-1.3.1-1  gpgme-1.16.0-1  gpsd-3.23-1  gptfdisk-1.0.8-1  groff-1.22.4-6  grub-2:2.06-1  gsound-1.0.3-1  gst-plugins-bad-1.18.4-11
               gst-plugins-bad-libs-1.18.4-11  gtk-update-icon-cache-1:4.4.0-1  gtk3-1:3.24.30-2  gtkmm3-3.24.5-2  gupnp-1.2.7-1  harfbuzz-2.9.0-1  harfbuzz-icu-2.9.0-1  hblock-3.2.2-1
               hdparm-9.62-1  hwids-20210613-1  hwinfo-21.76-1  hwloc-2.5.0-1  iana-etc-20210728-1  iio-sensor-proxy-3.1-1  imagemagick-7.1.0.4-2  imath-3.1.2-1  imlib2-1.7.3-1
               inetutils-2.1-1  input-devices-support-1-2  intel-compute-runtime-21.21.19914-1  intel-gmmlib-21.2.1-1  intel-graphics-compiler-1:1.0.7423-2  intel-media-driver-21.3.2-1
               intel-opencl-clang-12.0.0-1  intel-ucode-20210608-1  inxi-3.3.06.1-1  iproute2-5.13.0-1  iputils-20210722-1  jack-0.125.0-9 [removal]  jack2-1.9.19-2  js78-78.13.0-1
               json-glib-1.6.6-1  kauth-5.85.0-1  kconfig-5.85.0-1  kcoreaddons-5.85.0-1  kernel-modules-hook-0.1.7-2  kitemmodels-5.85.0-1  kmod-29-1  knotifications-5.85.0-1
               kvantum-qt5-0.20.1-1  kvantum-theme-qogir-git-r63.421a2a6-1  kwindowsystem-5.85.0-1  lapack-3.10.0-1  ldb-2:2.3.0-1  less-1:590-1  lib32-clang-12.0.1-1  lib32-curl-7.78.0-1
               lib32-e2fsprogs-1.46.4-1  lib32-expat-2.4.1-1  lib32-gcc-libs-11.1.0-1  lib32-glibc-2.33-5  lib32-libdrm-2.4.107-1  lib32-libelf-0.185-1  lib32-libidn2-2.3.1-1
               lib32-libldap-2.4.59-1  lib32-libva-mesa-driver-21.2.1-1  lib32-libx11-1.7.2-1  lib32-libxcrypt-4.4.25-1  lib32-libxfixes-6.0.0-1  lib32-llvm-libs-12.0.1-2  lib32-mesa-21.2.1-1
               lib32-mesa-vdpau-21.2.1-1  lib32-nvidia-utils-470.63.01-1  lib32-ocl-icd-2.3.0-1  lib32-opencl-mesa-21.2.1-1  lib32-opencl-nvidia-470.63.01-1  lib32-util-linux-2.37.2-1
               lib32-vulkan-icd-loader-1.2.184-1  lib32-vulkan-intel-21.2.1-1  lib32-vulkan-mesa-layers-21.2.1-1  lib32-vulkan-radeon-21.2.1-1  lib32-zstd-1.5.0-2  libarchive-3.5.2-1
               libavif-0.9.2-1  libbsd-0.11.3-1  libbytesize-2.6-1  libcaca-0.99.beta19-5  libcanberra-0.30+2+gc0620e4-5  libcanberra-pulse-0.30+2+gc0620e4-3 [removal]  libcap-2.53-1
               libcap-ng-0.8.2-3  libclc-12.0.1-1  libcolord-1.4.5-4  libconfig-1.7.3-1  libdrm-2.4.107-1  libedit-20210522_3.1-1  libelf-0.185-1  libepoxy-1.5.9-1  libfprint-1.94.0-1
               libfreeaptx-0.1.1-1  libgit2-1:1.1.1-1  libgudev-237-1  libgusb-0.3.7-1  libhandy-1.2.3-1  libibus-1.5.25-2  libidn2-2.3.2-1  libimagequant-2.15.1-1  libinput-1.18.1-1
               libinput-gestures-2.67-1  libjcat-0.1.8-1  libjpeg-turbo-2.1.1-1  libksba-1.6.0-1  libldap-2.4.59-2  liblouis-3.18.0-1  libmbim-1.26.0-2  libmd-1.0.3-1  libmfx-21.3.2-1
               libmm-glib-1.16.10-1  libndp-1.8-1  libnftnl-1.2.0-1  libnghttp2-1.44.0-1  libnice-0.1.18-2  libnl-3.5.0-3  libnm-1.32.10-1  libnma-1.8.32-1  libogg-1.3.5-1
               libp11-kit-0.24.0-1  libpamac-aur-11.0.1-1  libpcap-1.10.1-1  libphonenumber-8.12.29-1  libplacebo-3.120.3-3  libproxy-0.4.17-2  libpulse-15.0-1  libqmi-1.30.0-1
               librsvg-2:2.50.7-1  libsigc++-2.10.7-2  libsoup-2.74.0-1  libsrtp-1:2.4.0-1  libssh-0.9.6-1  libstemmer-2.1.0-1  libsynctex-2021.58686-3  libtasn1-4.17.0-1  libtirpc-1.3.2-1
               libtool-2.4.6+42+gb88cebd5-16  libtorrent-rasterbar-1:1.2.14-1  libuv-1.42.0-1  libva-2.12.0-1  libva-mesa-driver-21.2.1-1  libva-utils-2.12.0-1  libwacom-1.11-1
               libwebp-1.2.1-1  libwpe-1.10.1-1  libx11-1.7.2-1  libx86emu-3.2-1  libxcrypt-4.4.25-1  libxfixes-6.0.0-1  libxfont2-2.0.5-1  libxft-2.3.4-1  libxmlb-0.3.2-1
               libxnvctrl-470.63.01-1  lightdm-settings-1.5.4-1  lightdm-slick-greeter-1.5.3-1  linux-api-headers-5.12.3-1  linux-firmware-20210818.c46b8c3-1  linux-zen-5.13.13.zen1-1
               linux-zen-headers-5.13.13.zen1-1  llvm-libs-12.0.1-3  logrotate-3.18.1-1  lvm2-2.03.13-1  lz4-1:1.9.3-2  m4-1.4.19-1  man-db-2.9.4-2  man-pages-5.12-2  meld-3.20.4-1
               memtest86+-5.31b-1  menumaker-0.99.13-1  mercurial-5.8.1-1  mesa-21.2.1-1  mesa-vdpau-21.2.1-1  mhwd-db-garuda-git-r56.6c1fd7a-1  mhwd-nvidia-470.57.02-1  micro-2.0.10-2
               mintstick-1.4.6-1  mkinitcpio-30-2  mkinitcpio-busybox-1.33.1-1  modem-manager-gui-0.0.20-2  modemmanager-1.16.10-1  mousepad-0.5.6-1  mpfr-4.1.0.p13-1  mpg123-1.28.2-1
               mtools-1:4.0.35-1  mujs-1.1.3-1  nano-5.8-1  nettle-3.7.3-1  network-manager-applet-1.24.0-1  networkmanager-1.32.10-1  networkmanager-strongswan-1.5.2-2
               nextcloud-client-3.3.1-1  nfs-utils-2.5.4-1  nfsidmap-2.5.4-1  nm-cloud-setup-1.32.10-1  nm-connection-editor-1.24.0-1  noto-fonts-emoji-20210625-1  nspr-4.32-1  nss-3.69-1
               nss-mdns-0.15.1-1  nvidia-dkms-470.63.01-1  nvidia-settings-470.63.01-1  nvidia-utils-470.63.01-1  ocl-icd-2.3.1-1  opencl-mesa-21.2.1-1  opencl-nvidia-470.63.01-1
               openexr-3.1.1-1  openfortivpn-1.17.0-1  openldap-2.4.59-2  openmpi-4.1.1-2  openssh-8.7p1-1  openssl-1.1.1.l-1  openvpn-2.5.3-1  ostree-2021.3-1  p11-kit-0.24.0-1
               pace-1.4.1.1-2  pacman-6.0.0-5  pacman-contrib-1.4.0-4  pacman-mirrorlist-20210822-1  pacutils-0.11.1-1  pamac-aur-10.1.3-1  pambase-20210605-2  pango-1:1.48.9-2
               pangomm-2.46.1-2  paru-1.8.2-1  pavucontrol-1:5.0-1  pcre-8.45-1  pcre2-10.37-1  pcsclite-1.9.3-1  performance-tweaks-2.0.0-1  perl-5.34.0-2  perl-clone-0.45-3
               perl-encode-locale-1.05-8  perl-error-0.17029-3  perl-file-basedir-0.09-1  perl-file-desktopentry-0.22-8  perl-file-listing-6.14-2  perl-file-mimeinfo-0.30-2
               perl-html-parser-3.76-2  perl-html-tagset-3.20-11  perl-http-cookies-6.10-2  perl-http-daemon-6.06-3  perl-http-date-6.05-4  perl-http-message-6.33-1
               perl-http-negotiate-6.01-9  perl-io-html-1.004-2  perl-ipc-system-simple-1.30-3  perl-libwww-6.56-1  perl-lwp-mediatypes-6.02-9  perl-mailtools-2.21-5  perl-net-http-6.21-2
               perl-timedate-2.33-3  perl-try-tiny-0.30-6  perl-uri-5.09-2  perl-www-robotrules-6.02-9  perl-xml-parser-2.46-3  perl-xml-writer-0.625-7  pipewire-1:0.3.34-1
               plymouth-git-0.9.5.r84.ge554475-4  polkit-0.119-1  polkit-qt5-0.114.0-1  polybar-3.5.6-1  poppler-21.08.0-1  poppler-qt5-21.08.0-1  powertop-2.14-1  pragha-1.3.4-3
               profile-sync-daemon-6.44-2  protobuf-3.17.3-1  pulseaudio-15.0-1  pulseaudio-alsa-1:1.2.5-2  pulseaudio-bluetooth-15.0-1  pulseaudio-equalizer-15.0-1  pulseaudio-jack-15.0-1
               pulseaudio-lirc-15.0-1  pulseaudio-rtp-15.0-1  pulseaudio-zeroconf-15.0-1  python-3.9.6-1  python-attrs-21.2.0-1  python-cffi-1.14.6-1  python-click-8.0.1-1
               python-cryptography-3.4.8-1  python-dateutil-2.8.2-1  python-idna-3.2-1  python-kiwisolver-1.3.2-1  python-mako-1.1.5-1  python-markupsafe-2.0.1-1  python-marshmallow-3.13.0-1
               python-matplotlib-3.4.2-3  python-more-itertools-8.8.0-1  python-numpy-1.20.3-1  python-pillow-8.3.1-1  python-pyqt5-sip-12.9.0-1  python-requests-2.26.0-1
               python-service-identity-21.1.0-1  python-setuptools-1:57.4.0-1  python-sysv_ipc-1.1.0-1  python-twisted-21.7.0-1  python-urllib3-1.26.6-1  python-xapp-2.2.1-1
               python-xlib-0.31-1  qogir-gtk-theme-git-2021.08.02.r2.gb34a16d-1  qogir-icon-theme-git-2021.07.14.r4.g05548ae5-1  qt5-base-5.15.2+kde+r215-2  qt5-declarative-5.15.2+kde+r29-1
               qt5-script-5.15.5-2  qt5-wayland-5.15.2+kde+r29-1  qt5-webengine-5.15.5-1  qt5ct-1.3-1  re2-1:20210801-1  reflector-2021.7.8-1  ristretto-0.11.0-1  rpcbind-1.2.6-1
               rsync-3.2.3-4  rubberband-1.9.2-1  run-parts-5.3-1  sdl2-2.0.16-2  shaderc-2021.1-2  smbclient-4.14.7-1  snappy-1.1.9-1  sof-firmware-1.8-1  soundtouch-2.3.0-1
               spirv-llvm-translator-12.0.0-1  sqlite-3.36.0-1  sshfs-3.7.2-1  sstp-client-1:1.0.15-1  starship-0.57.0-1  strongswan-5.9.3-1  stunnel-5.60-1  subversion-1.14.1-3
               sudo-1.9.7.p2-1  svt-av1-0.8.7-1  svt-hevc-1.5.1-1  systemd-249.3-1  systemd-libs-249.3-1  systemd-swap-4.4.0-2 [removal]  systemd-sysvcompat-249.3-1  talloc-2.3.3-1
               tdb-1.4.5-1  tevent-1:0.11.0-1  texinfo-6.8-2  timeshift-20.11.1+4+gd437358-1  tint2-17.0.1-1  totem-pl-parser-3.26.6-1  tpm2-tss-3.1.0-1  tumbler-4.16.0-3  udisks2-2.9.3-1
               unarj-2.65-1  unrar-1:6.0.7-1  upower-0.99.13-1  usbutils-014-1  util-linux-2.37.2-1  util-linux-libs-2.37.2-1  vpnc-1:0.5.3.r496.r153-2  vte-common-0.64.2-2  vte3-0.64.2-2
               vulkan-icd-loader-1.2.188-1  vulkan-intel-21.2.1-1  vulkan-mesa-layers-21.2.1-1  vulkan-radeon-21.2.1-1  vulkan-swrast-21.2.1-1  vulkan-tools-1.2.184-1  webkit2gtk-2.32.3-1
               webrtc-audio-processing-0.3.1-3  whois-5.5.10-1  wireless-regdb-2021.04.21-1  wpebackend-fdo-1.10.0-1  xapp-2.2.2-1  xdg-dbus-proxy-0.1.2-3  xdotool-3.20210804.2-1
               xf86-input-libinput-1.1.0-1  xf86-video-amdgpu-21.0.0-1  xfce4-power-manager-4.16.0-3  xfce4-terminal-0.8.10-2  xfconf-4.16.0-2  xfsprogs-5.13.0-1  xkeyboard-config-2.33-1
               xorg-server-1.20.13-2  xorg-server-common-1.20.13-2  xorg-server-xephyr-1.20.13-2  xorg-xrdb-1.2.1-1  zbar-0.23.1-7  zimg-3.0.2-1  zram-generator-0.3.2-1
               zsh-autosuggestions-0.7.0-1  zstd-1.5.0-1  zxing-cpp-1.2.0-1

Total Installed Size:  5593.27 MiB
Net Upgrade Size:        74.51 MiB

:: Proceed with installation? [Y/n] y
(498/498) checking keys in keyring                                                                                  [---------------------------------------------------------------------] 100%
downloading required keys...
:: Import PGP key 0706B90D37D9B881, "Chaotic-AUR Wild Bear Node <[email protected]>"? [Y/n] y
error: key "0706B90D37D9B881" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

I could not update my system

The solution for that is here:

3 Likes

Also, you could update your system with update in the future

1 Like

Here it is, waiting for the update :wink:

Thanks! didnt know about this. Btw, is this any cause for concern?

error: failed retrieving file 'chaotic-aur.db' from geo-mirror.chaotic.cx : Connection timeout after 10001 ms
error: failed retrieving file 'chaotic-aur.db' from cdn-mirror.chaotic.cx : Connection timeout after 10003 ms

apologies as I am still finding my way around linux in general -- probably tried to run before I could walk XD

This resolved my solution as well, now I am able to run tg desktop! Much thanks!

This is a problem in the chaotic-aur mirrorlist, which, if I remember correctly, unlike the arch mirrorlist, must be solved manually like here.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.