Teamviewer daemon not autostarting


Today I tryed use Teamviewer from both AUR and Chaotic-AUR packages. Everything is working pretty good except autostarting daemon.
I tryed following commands:

systemctl start teamviewerd
systemctl enable teamviewerd
systemctl enable teamviewerd --now
sudo teamviewer --daemon enable
systemctl enable teamviewerd.service
systemctl start teamviewerd.service

And after reboot teamviewer is asking to enable daemon again.
What am I missing? I am using Arch linux for a long time but I am facing this issue for the first time.

Could you please try the following?

sudo systemctl disable teamviewerd.service
sudo teamviewer --daemon enable

Sorry for late reply but I was out of my PC.
I tried it but didn't work. Still same problem at startup.
Any ideas?

everything seems right but it is still asking to start deamon when I restart the PC.


Really strange, I have no clue...
Just out of curiosity, isn't there an option in the settings to start TeamViewer with the system? Maybe this takes care of everything...

1 Like

Creating autostart script starting with sleep 5 solved it.
Thanks for help


teamviewer support

Guess we can close your support ticket now that your issue is resolved. :wink: