TeamSpeak3 steals my OS audio?

Hi, guys!

I'm having a pretty weird things going on after I switched to pipewire from pulseaudio.
So I'm uninstalled pulseaudio, installed pipewire, ALSA is also installed.

After a reboot I noticed that when I'm using TeamSpeak3 for Linux - I have literally no sound in system. When I try to open a YouTube video - it just stalls, cause it have literally no sound. No sound in audio or video players. Also OBS is not recording a desktop audio or microphone (as I see - equalizer is just dead). As soon as I close TeamSpeak3 - sound returns, all working as intended.

What is the possible issue I can solve to make all my setup work?

Here is my system info:

System:
Kernel: 5.19.13-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9dbc2d80-f8ff-4292-9f96-dc64de48b51f rw [email protected]
splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=a34c3215-eb63-4d11-b6c9-b05946c5521a loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Micro-Star product: GS65 Stealth Thin 8RF v: REV:1.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-16Q2 v: REV:1.0 serial: <superuser required>
UEFI: American Megatrends v: E16Q2IMS.112 date: 05/21/2019
Battery:
ID-1: BAT1 charge: 76.7 Wh (95.5%) condition: 80.3/80.3 Wh (100.0%)
volts: 16.7 min: 15.2 model: MSI BIF0_9 type: Li-ion serial: N/A
status: not charging
CPU:
Info: model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Coffee Lake
gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 9 MiB desc: 1x9 MiB
Speed (MHz): avg: 3691 high: 4002 min/max: 800/4100 scaling:
driver: intel_pstate governor: performance cores: 1: 4000 2: 2200 3: 4002
4: 4002 5: 3998 6: 4001 7: 4000 8: 4002 9: 3998 10: 4000 11: 3900
12: 2200 bogomips: 52799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA GP104M [GeForce GTX 1070 Mobile] vendor: Micro-Star MSI
driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-10) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: none empty: DP-2,HDMI-A-2 bus-ID: 01:00.0
chip-ID: 10de:1ba1 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP-1-1 model: AU Optronics 0x80ed built: 2017
res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: NVIDIA GeForce GTX 1070 with Max-Q Design/PCIe/SSE2
v: 4.6.0 NVIDIA 515.76 direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 1-2:2 chip-ID: 0c76:161f
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
class-ID: 0300 chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:10f0 class-ID: 0403
Device-3: JMTek LLC. USB PnP Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k5.19.13-zen1-1-zen running: yes
Sound Interface: sndio v: N/A running: no
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 3c:00.0 chip-ID: 1969:e0b1 class-ID: 0200
IF: enp60s0 state: down mac: <filter>
IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 953.88 GiB used: 436.3 GiB (45.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: RBUSNS8180S3512GJ
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 61D1 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Transcend
model: TS512GSSD230S size: 476.94 GiB block-size: physical: 512 B
logical: 512 B type: SSD serial: <filter> rev: 02J0 scheme: GPT
Partition:
ID-1: / raw-size: 467.46 GiB size: 467.46 GiB (100.00%) used: 436.3 GiB
(93.3%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw-size: 701 MiB size: 699.6 MiB (99.80%) used: 308 KiB
(0.0%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 467.46 GiB size: 467.46 GiB (100.00%) used: 436.3
GiB (93.3%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-4: /var/log raw-size: 467.46 GiB size: 467.46 GiB (100.00%) used: 436.3
GiB (93.3%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-5: /var/tmp raw-size: 467.46 GiB size: 467.46 GiB (100.00%) used: 436.3
GiB (93.3%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.47 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.79 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda6 maj-min: 8:6
Sensors:
System Temperatures: cpu: 58.0 C pch: 55.0 C mobo: N/A gpu: nvidia
temp: 55 C
Fan Speeds (RPM): N/A
Info:
Processes: 329 Uptime: 13m wakeups: 1 Memory: 15.47 GiB used: 2.84 GiB
(18.4%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1983
libs: 559 tools: aura,octopi,paru Shell: fish v: 3.5.1 running-in: konsole
inxi: 3.3.22
Garuda (2.6.8-1):
System install date:     2022-05-26
Last full system update: 2022-10-10
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper

Update.
Also all my directories in /etc/pipewire/ are empty, no config files, nothing:

╭─[email protected] in /etc/pipewire🔒 as 🧙
╰─λ ls
drwxr-xr-x - root 25 апр 23:55  client-rt.conf.d
drwxr-xr-x - root 25 апр 23:55  client.conf.d
drwxr-xr-x - root 25 апр 23:55  jack.conf.d
drwxr-xr-x - root 25 апр 23:55  minimal.conf.d
drwxr-xr-x - root  9 окт 00:27  pipewire-pulse.conf.d
drwxr-xr-x - root 25 апр 23:55  pipewire.conf.d

So I can't use this solution: PipeWire - ArchWiki

These directories exist not because they are supposed to be full of stuff, but rather they are meant to be a place to store config files where PipeWire will find them and respect the settings they prescribe. Unless you, your Linux distribution, or some software you install on your machine puts something inside these directories it is normal for them to be empty.

To try the intervention you found in ArchWiki, just make the file first:

micro /etc/pipewire/media-session.d/alsa-monitor.conf

Add the line needed:

api.alsa.headroom = 1024

Ctrl+q to exit out of micro, make sure to save the file.

:point_up: Note: that intervention is specifically for systems running pipewire-media-session; if you are running WirePlumber, there is a separate set of instructions below that you should follow instead.

3 Likes

@BluishHumility thanks for reply.
Created the directory and config file as mentioned in ArchWiki, rebooted - unfortunately it didn't help.
Launched TeamSpeak after reboot - and I don't have sound in the whole system.
Closing TeamSpeak - the sound appears again.

In case with OBS its like vise versa: if I open TS before OBS - I don't have sound in OBS and the whole system. With the option of starting OBS first, the sound in the entire system does not disappear, but I'm getting this error in TeamSpeak:

image

It seems that the OBS reserves the devices I use for itself and same for TeamSpeak.

Update:
I also have a wine version of TeamSpeak installed and it works perfectly with OBS and OS, but I'm really interested to make the native Linux TeamSpeak client to work because wine version is pretty laggy.

Can you boot a snapshot that is at least 7 days old? I also had a similar problem (as soon as I start Apex Legends all sound is gone) and using older version fixed it for me.

@mrvictory I know that it will probably fix the problem, but I want to fix it with my current state of system (with all installed updates).
I also just installed flatpak version of TeamSpeak and it works as intended.

Still I want to solve the following issue and get Arch version of TS to work. :thinking:
Also I'm pretty sure that this is not a TS fault, because Arch version was updated 2021-10-13 last time.

So maybe one of the system updates broke the TS?

I wasn't clear. I meant that not an older version of an application but older version of pipewire fixed it for me.

2 Likes

Ah, yes, now I see what do you mean. But unfortunately I don't have older version of pipewire, because it was my first time installation, so I don't have older version in my package cache. :upside_down_face:

My snapahots got auto deleted :man_facepalming:, I will investigate later when I have time. Meanwhile you can check out downgrade.

The commands below has sort-of brought back audio for me, I have to disable/enable sound or change sound level but it works. Reboot after running these.

sudo pacman -Rdd pipewire-audio
sudo pacman -U https://archive.archlinux.org/packages/l/lib32-pipewire/lib32-pipewire-1:0.3.58-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/l/lib32-pipewire-jack/lib32-pipewire-jack-1:0.3.58-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/p/pipewire/pipewire-1:0.3.58-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/p/pipewire-alsa/pipewire-alsa-1:0.3.58-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/p/pipewire-jack/pipewire-jack-1:0.3.58-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/p/pipewire-v4l2/pipewire-v4l2-1:0.3.58-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/p/pipewire-zeroconf/pipewire-zeroconf-1:0.3.58-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/w/wireplumber/wireplumber-0.4.11-4-x86_64.pkg.tar.zst
3 Likes

mrvictory Will definitely try this. Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.