Tauon music box just closes after trying to open it

I try to open Tauon-Music-Box but soon after I open it, it closes soon after. This is what it says when I run it in console

Tauon Music Box v7.1.3
Copyright 2015-2022 Taiko2k [email protected]

Window size: [990, 625]

(tauon.py:9497): Gtk-WARNING **: 18:25:14.962: Theme parsing error: gtk-dark.css:5822:26: '-shadow' is not a valid color name

(tauon.py:9497): Gtk-WARNING **: 18:25:14.962: Theme parsing error: gtk-dark.css:5825:14: not a number

(tauon.py:9497): Gtk-WARNING **: 18:25:14.962: Theme parsing error: gtk-dark.css:5826:13: not a number

(tauon.py:9497): Gtk-WARNING **: 18:25:14.962: Theme parsing error: gtk-dark.css:5827:11: Expected a length
GTK theme is: sweet-dark
Running from installed location
User files location: /home/dosos/.local/share/TauonMusicBox
Found XDG-Downloads: /home/dosos/Downloads
Found XDG-Music: /home/dosos/Music
Install directory: /opt/tauon-music-box
Traceback (most recent call last):
  File "/opt/tauon-music-box/tauon.py", line 246, in <module>
    exec(main)
  File "/opt/tauon-music-box/t_modules/t_main.py", line 666, in <module>
    import pylast
  File "/usr/lib/python3.10/site-packages/pylast/__init__.py", line 37, in <module>
    import httpx
ModuleNotFoundError: No module named 'httpx'

My system

System:
  Kernel: 5.17.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=92738ace-d95f-4f3e-9a50-f9170e33d3ba rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: AX370M-DS3H v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370M-DS3H-CF v: x.x serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: F22 date: 03/15/2018
CPU:
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3692 high: 3880 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3859 2: 3870
    3: 3836 4: 3505 5: 3848 6: 3804 7: 2753 8: 3860 9: 3528 10: 3703 11: 3869
    12: 3880 bogomips: 81435
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: DP-1
    empty: DP-2, DP-3, DVI-D-1, HDMI-A-1 bus-ID: 08:00.0 chip-ID: 1002:67df
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: DP-1 mapped: DisplayPort-0 model: Dell S3220DGF
    serial: <filter> built: 2020 res: 2560x1440 dpi: 93 gamma: 1.2
    size: 697x392mm (27.44x15.43") diag: 806mm (31.7") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 13.0.1 DRM
    3.44 5.17.5-zen1-1-zen)
    v: 4.6 Mesa 22.0.2 direct render: Yes
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 08:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: N/A
    modules: iwlwifi pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 07:00.0
    chip-ID: 8086:24fb class-ID: 0280
  Device-3: Realtek RTL8814AU 802.11a/b/g/n/ac Wireless Adapter type: USB
    driver: rtl8814au bus-ID: 3-4:2 chip-ID: 0bda:8813 class-ID: 0000
    serial: <filter>
  IF: wlp9s0f3u4 state: up mac: <filter>
Drives:
  Local Storage: total: 2.04 TiB used: 192.53 GiB (9.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS240G2G0A-00JH30 size: 223.58 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0000
    scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM006-2DM164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: MBR
Partition:
  ID-1: / raw-size: 223.58 GiB size: 223.58 GiB (100.00%)
    used: 192.53 GiB (86.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /home raw-size: 223.58 GiB size: 223.58 GiB (100.00%)
    used: 192.53 GiB (86.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 223.58 GiB size: 223.58 GiB (100.00%)
    used: 192.53 GiB (86.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-4: /var/tmp raw-size: 223.58 GiB size: 223.58 GiB (100.00%)
    used: 192.53 GiB (86.1%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.77 GiB used: 1015 MiB (12.8%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 53.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 797
Info:
  Processes: 341 Uptime: 8m wakeups: 0 Memory: 7.77 GiB
  used: 2.48 GiB (31.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1450 lib: 451 Shell: fish
  v: 3.4.1 running-in: kitty inxi: 3.3.15
Garuda (2.6.2-1):
  System install date:     2021-08-02
  Last full system update: 2022-05-06
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Timeshift (maybe)
  Failed units:            bluetooth-autoconnect.service 

I've tried reinstalling using yay -S, tried opening it again and it nothing changed, tried rebooting nothing changed.

The information on the AUR page

https://aur.archlinux.org/packages/tauon-music-box

Indicates you can do pacman -S python-httpx. If that does not work you may find some more useful information in the comments section.

6 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.