Task switcher animation changed

Hello.

To be honest, I'm new so my belief can be wrong, but I think it's just animation and it don't need output. Although walk through now looks like simple switch through (the simple alternative animation) if you know what I mean. In case I can provide some logs I'm not aware about, I will provide them as you instruct me

What I tried to solve issues?

  • it happened after some installations, like lollypop, mpv, flatpak, so I tried removing them by sudo pacman -R packageName. But no help. I installed them again leaving flatpak alone as I saw flatpak is considered unsupported.
  • Restoration of old snapshots.

What I think I should possibly try?

  • Reinstalling n configuring plasma kde, sadly I'm still clueless about it, specially reconfiguration

System info:
Laptop: Acer Nitro 5 AN515-44 (2021), 512gb ssd, 8gb ram ddr4
Graphics: GTX 1650, 4gb
Os: Multiboot - Win 11 21H2, Garuda Dr4gonized (kept up to date, installed 3 days ago, my 1st ever linux)

If details given here insufficient, please guide me, I will get you required details

Edit: I just found that inxi is a command, I will post out results soon as am not on laptop at moment. Sorry for inconvenience

I am not sure exactly what you are referring to but a couple of the task switching animations were removed from the latest version of plasma by the kde developers. If you were using one of those that could explain the change.

1 Like

Ohh
Thanks for info
I will look into it and respond soon

Btw I am referring to the default one when you fresh install garuda (I mean I did 3 days ago, and that was the animation I saw, so I call it default), where active tasks scroll with window to be selected is flat while rest are tilted

Sorry for a blurry image, I clicked that in bit of hurry earlier.

CMD: inxi -Faz

OUTPUT:

System:    Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=4e4f1661-daaa-48b5-83ea-ed183be4bc11
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Acer product: Nitro AN515-44 v: V1.04 serial: <filter>
Mobo: RO model: Stonic_RNS v: V1.04 serial: <filter> UEFI: Insyde v: 1.04 date: 02/04/2021
Battery:   ID-1: BAT1 charge: 57.9 Wh (100.0%) condition: 57.9/57.5 Wh (100.7%) volts: 17.6 min: 15.4
model: LGC AP18E8M type: Li-ion serial: <filter> status: Full
CPU:       Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600103 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71862
Speed: 2711 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 2711 2: 3090
3: 1540 4: 1397 5: 1397 6: 1396 7: 1396 8: 2244 9: 2369 10: 1393 11: 2074 12: 1398
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia v: 470.74
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300
Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus-ID: 05:00.0
chip-ID: 1002:1636 class-ID: 0300
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:2 chip-ID: 04f2:b64f
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.14-zen1-1-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.4
direct render: Yes
Audio:     Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10fa
class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Acer Incorporated ALI
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000
bus-ID: 03:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:
hardware: no software: no address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 11.72 GiB (2.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 SDBPNPZ-512G-1014
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 21103900 temp: 45.9 C scheme: GPT
Partition: ID-1: / raw-size: 149 GiB size: 149 GiB (100.00%) used: 11.69 GiB (7.8%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 1 GiB size: 1021 MiB (99.61%) used: 27.9 MiB (2.7%) fs: vfat
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-3: /home raw-size: 149 GiB size: 149 GiB (100.00%) used: 11.69 GiB (7.8%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 149 GiB size: 149 GiB (100.00%) used: 11.69 GiB (7.8%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 149 GiB size: 149 GiB (100.00%) used: 11.69 GiB (7.8%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.14 GiB used: 512 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 49.8 C mobo: N/A gpu: amdgpu temp: 40.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 343 Uptime: 4m wakeups: 1 Memory: 7.14 GiB used: 2.74 GiB (38.3%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1283 lib: 307
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

Still not clear to me what the problem is.
Anyway, you could give a look at Settings -> Window Management -> Task switcher, especially the visualization drop-down field, if you find any settings that it's worth trying changing.
For animation problems in general, not related only to the task switcher, you could give a look at the "compositor".
Sometimes when you open its settings there's a message saying that it crashed and offering to reset it. Also there you'll find settings to play with. Take notes of what you change...

I tried both

  1. I tried switching animations
    And actually found that many are just not usable. I mean they all showing simple thumbnail animation

  2. No crash on compositer. No reset, defaults.

I could be wrong but it looks like you do not have your graphics installed correctly?

Possible
I just let garuda do everything
Any way to check it out?

But to be noted
"It changed" rather than not working from start
I guess I should delete whole partition of garuda os and reinstall

Is it actually safe?

Could it be that the task switcher animation you remember was the initial one (I mean, the one when you installed, before the first full update) ?
In that case, maybe this could be as @dalto suggested, several animations were removed in the recent plasma upgrade (and there's nothing we can do about it).

2 Likes

Ic
Well then
I guess I will just use thumbnail grid

1 Like

You can also push button "Get New Task Switchers" and search if there's anything you like...

PS: Welcome!

1 Like

Thanks
I guess I will give that a shot

1 Like

Final update
I did try fresh install again
and after full update
KDE removed "Cover Switch" Task Switcher theme, i.e. so called default task switcher theme in garuda.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.