Talend, Eclipse based app, libswt-gtk problem since last pacman system update

Hello Garuda users.

Since my last system update, I can't start my Talend App for a lib problem :

SWT WebKitGDBus: error creating DBus server Erreur lors de la liaison à l’adresse (GUnixSocketAddress) : Aucunfichier ou dossier de ce type
SWT WebKit: error initializing DBus server, dBusServer == 0

(Talend Open Studio for Big Data:20407): GLib-GIO-CRITICAL **: 11:20:09.505: g_dbus_server_get_client_address:assertion 'G_IS_DBUS_SERVER (server)' failed
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f20db43eb86, pid=20407, tid=20408
# JRE version: OpenJDK Runtime Environment (17.0.2+8) (build 17.0.2+8-86)
# Java VM: OpenJDK 64-Bit Server VM (17.0.2+8-86, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, linux-amd64)
# Problematic frame:
# C  [libswt-gtk-4944r26.so+0x3eb86]  Java_org_eclipse_swt_internal_C_strlen+0xf
# Core dump will be written. Default location: Core dumps may be processed with "/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h" (or dumping to /**masked**/Apps/TOS_BD-20211109_1610-V8.0.1/core.20407)
# An error report file with more information is saved as:
# /**masked**/Apps/TOS_BD-20211109_1610-V8.0.1/hs_err_pid20407.log
# If you would like to submit a bug report, please visit:
#   https://bugreport.java.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

It's seems there is a problem with libswt-gtk driver. Before the last garuda update all worked fine. I search a way to get a report of all last updated packages. Any one have an idea to my problem ?

Kernel: 6.2.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=f327471a-c329-462b-a1dc-fca7bb7580b2 rw rootflags=subvol=@
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 20TH001AFR v: ThinkPad P1 Gen 3
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: LENOVO model: 20TH001AFR v: SDK0T08861 WIN
serial: <superuser required> UEFI: LENOVO v: N2VET26W (1.11 )
date: 11/16/2020
ID-1: BAT0 charge: 10.8 Wh (15.1%) condition: 71.4/80.4 Wh (88.8%)
volts: 13.7 min: 15.4 model: SMP 5B10X19049 type: Li-poly serial: <filter>
status: discharging cycles: 225
Info: model: Intel Core i9-10885H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xF4
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3046 high: 4743 min/max: 800/5300 scaling:
driver: intel_pstate governor: performance cores: 1: 2400 2: 4495 3: 2400
4: 2400 5: 4093 6: 2400 7: 2400 8: 2400 9: 2400 10: 2400 11: 3845 12: 4743
13: 3494 14: 2400 15: 2400 16: 4080 bogomips: 76800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
class-ID: 0300
Device-2: NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] vendor: Lenovo
driver: nvidia v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2023-02) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: none empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0
chip-ID: 10de:1fb8 class-ID: 0300
Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 2-8:2 chip-ID: 04f2:b6cb class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (19.96x11.22")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 model-id: CSO 0x1500 built: 2019 res: 1920x1080 hz: 60
dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 3840x2160
API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel UHD Graphics (CML GT2)
direct-render: Yes
Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo
driver: sof-audio-pci-intel-cnl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:06c8 class-ID: 0401
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel pcie:
gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
class-ID: 0403
Sound API: ALSA v: k6.2.5-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.67 running: yes
Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
IF-ID-2: veth26cd6f9 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-3: veth3edc00a state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-4: vetheb79d99 state: up speed: 10000 Mbps duplex: full
mac: <filter>
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 2-14:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Local Storage: total: 953.87 GiB used: 212.44 GiB (22.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 5108AGLA temp: 42.9 C scheme: GPT
ID-1: / raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 212.4 GiB (36.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
used: 33.6 MiB (13.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 212.4 GiB (36.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 212.4 GiB (36.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 585.94 GiB size: 585.94 GiB (100.00%)
used: 212.4 GiB (36.3%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.98 GiB used: 4.82 GiB (15.6%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 57.0 C pch: 60.0 C mobo: N/A
Fan Speeds (RPM): fan-1: 2277 fan-2: 2120
Processes: 409 Uptime: 42m wakeups: 2411 Memory: 30.98 GiB
used: 12.93 GiB (41.7%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 1551 libs: 367 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2021-11-16
Last full system update: 2023-03-13
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Is this the package in question?
If so, it seems out-of-date since more than 4 years.
If not, please give details of the package name, where it was installed from, etc.

1 Like

It's not this package. There is no AUR package for this app. This is exactly Talend Open Studio for Big Data in version 8.0. This app is and embedded app not managed by any package manager (downloadable here https://help.talend.com/r/en-US/8.0/studio-getting-started-guide-open-studio-for-big-data/functional-architecture). On the official documentation ARCH linux is not list on the compatibility table but the apps work fine on my laptop since more than one year.

I've just tried to download an oldest version on the app. This one worked fine but when I tried with the most recent version nothing.

There is a way to shop system updates packages history ?

garuda-update stores 7 days of logs under /var/log/garuda/ (if this is what you meant, sorry...)
Otherwise, you can check into /var/log/pacman.log, of course.

Thank, I've not found an answer to my problem on logs .... Thank to have tried to help :grinning:

I've continue to investigates. The problem seems to be linked to the DBUS (548806 – [GTK][LXDE] SIGSEGV in Java_org_eclipse_swt_internal_C_strlen), but any way to understant what appends since yesterday, the only libs updated was :

alsa-card-profiles-1:0.3.67-1  attica-5.104.0-1  baloo-5.104.0-1  bbswitch-dkms-0.8-579
bluez-qt-5.104.0-1  breeze-icons-5.104.0-1  ca-certificates-mozilla-3.89-1
firedragon-110.0.1-1.1  frameworkintegration-5.104.0-1  glib2-2.76.0-1  glibmm-2.66.6-1
gst-plugin-pipewire-1:0.3.67-1  iana-etc-20230306-1  imagemagick-
kactivities-5.104.0-1  kactivities-stats-5.104.0-1  karchive-5.104.0-1  kauth-5.104.0-1
kbookmarks-5.104.0-1  kcalendarcore-5.104.0-1  kcmutils-5.104.0-1  kcodecs-5.104.0-1
kcompletion-5.104.0-1  kconfig-5.104.0-1  kconfigwidgets-5.104.0-1  kcontacts-1:5.104.0-1
kcoreaddons-5.104.0-1  kcrash-5.104.0-1  kdbusaddons-5.104.0-1  kdeclarative-5.104.0-1
kded-5.104.0-1  kdelibs4support-5.104.0-1  kdesu-5.104.0-1  kdnssd-5.104.0-1
kdoctools-5.104.0-1  kemoticons-5.104.0-1  kfilemetadata-5.104.0-1  kglobalaccel-5.104.0-1
kguiaddons-5.104.0-1  kholidays-1:5.104.0-1  khtml-5.104.0-1  ki18n-5.104.0-1
kiconthemes-5.104.0-1  kidletime-5.104.0-1  kimageformats-5.104.0-1  kinit-5.104.0-1
kio-5.104.0-1  kirigami2-5.104.0-1  kitemmodels-5.104.0-1  kitemviews-5.104.0-1
kjobwidgets-5.104.0-1  kjs-5.104.0-1  knewstuff-5.104.0-1  knotifications-5.104.0-1
knotifyconfig-5.104.0-1  kpackage-5.104.0-1  kparts-5.104.0-1  kpeople-5.104.0-1
kpty-5.104.0-1  kquickcharts-5.104.0-1  krunner-5.104.0-1  kservice-5.104.0-1
ktexteditor-5.104.0-1  ktextwidgets-5.104.0-1  kunitconversion-5.104.0-1  kwallet-5.104.0-1
kwayland-5.104.0-1  kwidgetsaddons-5.104.0-1  kwindowsystem-5.104.0-1  kxmlgui-5.104.0-1
libmanette-0.2.6-4  libpipewire-1:0.3.67-1  libpulse-16.1-5  libwireplumber-0.4.14-1
libx86emu-3.5-3  linux-zen-6.2.5.zen1-1  linux-zen-headers-6.2.5.zen1-1
modemmanager-qt-5.104.0-1  networkmanager-qt-5.104.0-1  nss-3.89-1  pipewire-1:0.3.67-1
pipewire-alsa-1:0.3.67-1  pipewire-audio-1:0.3.67-1  pipewire-jack-1:0.3.67-1
pipewire-pulse-1:0.3.67-1  pipewire-v4l2-1:0.3.67-1  pipewire-x11-bell-1:0.3.67-1
pipewire-zeroconf-1:0.3.67-1  plasma-framework-5.104.0-1  prison-5.104.0-1  purpose-5.104.0-1
qqc2-desktop-style-5.104.0-1  solid-5.104.0-1  sonnet-5.104.0-1  sudo-1.9.13.p3-1
syndication-5.104.0-1  syntax-highlighting-5.104.0-1  threadweaver-5.104.0-1  tinyxml-2.6.2-10

Anyone have an idea ? The only way I've found is to use an ubuntu virtualbox .....

Hello from Germany,
since yesterday I have same Problem wie DBus with program Fakturam

have you find out what the problem.
my first Idea was pipewire a day after change pipewire the problem came up
but after rollbacke the problem is still there

Thanks for Ideas und tips


I had a similar issue with eclipse, and i temporarily fixed it by downgrading glib2 from 2.76.0-1 to 2.74.

It seems to have to do something with glib2 internals which I don't fully understand. The error also popped up here: [rawhide]: Error binding to address GUnixSocketAddress · Issue #1418 · coreos/fedora-coreos-tracker · GitHub

Hope this helps

Hello have downgrade to 2.74 now this happend

WARNING: Using incubator modules: jdk.incubator.vector, jdk.incubator.foreign
WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven
SWT OS.java Error: Failed to load swt-pi3, loading swt-pi4 as fallback.
Ein Fehler ist aufgetreten. Informationen hierzu enthält die Protokolldatei
[gregor@compi fakturama2]$ 

the log.

!SESSION 2023-03-22 16:58:47.019 -----------------------------------------------
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.gemini.dbaccess.derby 4 0 2023-03-22 16:58:47.563
!MESSAGE FrameworkEvent ERROR
org.osgi.framework.BundleException: Ausnahme in org.eclipse.gemini.dbaccess.derb
y.Activator.start() von Bundle org.eclipse.gemini.dbaccess.derby.
        at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(
        at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleCon
        at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(Equino
        at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.start
        at org.eclipse.osgi.container.Module.doStart(Module.java:605)
        at org.eclipse.osgi.container.Module.start(Module.java:468)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(

Please refer to Reporting bugs | Garuda Linux wiki

Also parts of your log are cut off.

You should share the mentioned log file.

hello, my workaround : use virtualbox on ubuntu ..... shame ....
I will wait a new release of my software to solve the problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.