Systemd-networkd-wait-online.service failed

systemd-networkd-wait-online.service is shown as a failed unit in my inxi
Can it be fixed?
Or do I just leave it like that?
I have seen this failed unit in several others inxis in this forum.

❯ sudo systemctl status systemd-networkd-wait-online.service
× systemd-networkd-wait-online.service - Wait for Network to be Configured
     Loaded: loaded (/etc/systemd/system/systemd-networkd-wait-online.service; enabled; preset: disabled)
     Active: failed (Result: exit-code) since Sat 2022-10-29 10:57:53 IST; 1min 29s ago
       Docs: man:systemd-networkd-wait-online.service(8)
    Process: 19922 ExecStart=/usr/lib/systemd/systemd-networkd-wait-online (code=exited, status=1/FAILURE)
   Main PID: 19922 (code=exited, status=1/FAILURE)
        CPU: 6ms

Oct 29 10:55:53 austin-swiftsf31443 systemd[1]: Starting Wait for Network to be Configured...
Oct 29 10:57:53 austin-swiftsf31443 systemd-networkd-wait-online[19922]: Timeout occurred while waiting for network connectivity.
Oct 29 10:57:53 austin-swiftsf31443 systemd[1]: systemd-networkd-wait-online.service: Main process exited, code=exited, status=1/FA>
Oct 29 10:57:53 austin-swiftsf31443 systemd[1]: systemd-networkd-wait-online.service: Failed with result 'exit-code'.
Oct 29 10:57:53 austin-swiftsf31443 systemd[1]: Failed to start Wait for Network to be Configured.

Thank you

Try to give a look at this one, extending the timeout...
https://bbs.archlinux.org/viewtopic.php?id=256366
Also, maybe rummage a bit into the issues...

Of course, I assume you need that service (systemd-networkd is being used???), otherwise just disable or mask it. Or try the --any configuration:
https://wiki.archlinux.org/title/Systemd-networkd#systemd-networkd-wait-online

3 Likes

I tried the above links, still, the issue persists.

Ya systemd-networkd is active and running, I don't know if I need it.

/etc/systemd/system/.#systemd-networkd-wait-online.service8d36b8a4c71ffef7

[Unit]
Description=Wait for Network to be Configured
Documentation=man:systemd-networkd-wait-online.service(8)
DefaultDependencies=no
Conflicts=shutdown.target
Requires=systemd-networkd.service
After=systemd-networkd.service
Before=network-online.target shutdown.target

[Service]
Type=oneshot
ExecStart=
ExecStart=/usr/lib/systemd/systemd-networkd-wait-online --any
RemainAfterExit=yes

[Install]
WantedBy=network-online.target

We normally use networkmanager as NM.
As far as I can remember, systemd-networkd was needed by Anbox (at least, that's the only time I used it).
If you don't use Anbox anymore, you could consider disabling that service.

5 Likes

Yup!
I had installed anbox last week to check whether it worked and then uninstalled it(cause it was not working).
I completely forgot I had enabled systemd-networkd service!
Ya now I don't require it.
Thanks @filo

Problem resolved!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.