System won't boot after updating drivers

I cannot normaly boot the system after I installed nividia drivers (first loading screen freezes and nothing happens). Snapshots works fine, but everything happens again after reboot. I also cannot acces firewall or update the system

inxi -Fxxxza
PrivateBin

Firewall:

λ systemctl status firewalld
Unit firewalld.service could not be found.

System update:

sudo pacman -Syu

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for user:
:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to update chaotic-aur (unable to lock database)
error: failed to synchronize all databases

I also watched the guide on installation. Did the same, except I chose erase option

In the Garuda Assistant / Maintanence section you can unlock pacman database.

1 Like

Remove the .db lock, then refresh the mirror list, then do a system-wide update with pacman -Syyu.

4 Likes

pacman -Syyu
error: you cannot perform this operation unless you are root

Nvm, I found out that I need just to add sudo at begin

I got everything fixed after some brainstorming and three sacrifices to Satan. Many thanks for help, I've learn a lot today thanks to you guys

is not a solution how you mark it.

Details needed :slight_smile:

Got snapshot to work with commands from c00ter and another one that I managed to dig from forum (sudo mhwd -a pci nonfree 0300). So basically a system update and driver update. Tested the snapshot and used it as replacement, problem was solved.
Then something clicked in and realized that I'm simply missing a firewalld. Downloaded it and ran around arch forums for command to enable it (systemctl enable "firewalld")
Now I'm off to do something about massive CPU usage that started recently.

I found your 3 sacrifices woefully inadequate. To have the remotest chance that I will grant you computer stability you must sacrifice your persistent reliance on Windows, Mac, and Ubuntu. Well that, and a short term servitude contract. I would deem those terms acceptable for granting you this rarest of attainable dreams.

All our bookkeeping ledgers and records of condemned souls are stored on M$ server 2008 machines. Damn Bill Gates and his lawyers (for real) for bamboozling me into giving him an extra 15 years for free M$ server software licences and support in perpetuity. He'll pay dearly when he shuffles off his motal coil. All the last minute philanthropy in the world isn't going to save him from an excruciating eternity burning in our VIP lava pit in the lake of fire. M$ Server 2008 indeed, he'll pay dearly for that swindallage. I'm counting the minutes until it's payback time. Burn, baby, burn.

:imp:

4 Likes